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Legal disclaimer

Alibaba Cloud reminds you to carefully read and fully understand the terms and conditions of this legal
disclaimer before you read or use this document. If you have read or used this document, it shall be deemed
as your total acceptance of this legal disclaimer.

1.

You shall download and obt ain this document from the Alibaba Cloud website or other Alibaba Cloud-
aut horized channels, and use this document for your own legal business activities only. The content of
this document is considered confidential information of Alibaba Cloud. You shall strictly abide by the
confidentiality obligations. No part of this document shall be disclosed or provided to any third party for
use wit hout the prior written consent of Alibaba Cloud.

. No part of this document shall be excerpted, translated, reproduced, transmitted, or disseminated by

any organization, company or individual in any form or by any means without the prior written consent of
Alibaba Cloud.

. The content of this document may be changed because of product version upgrade, adjustment, or

other reasons. Alibaba Cloud reserves the right to modify the content of this document without notice
and an updated version of this document will be released through Alibaba Cloud-aut horized channels
from time to time. You should pay attention to the version changes of this document as they occur and
download and obt ain the most up-to-date version of this document from Alibaba Cloud-aut horized
channels.

. This document serves only as a reference guide for your use of Alibaba Cloud products and services.

Alibaba Cloud provides this document based onthe "status quo", "being defective", and "existing
functions" of its products and services. Alibaba Cloud makes every effort to provide relevant operational
guidance based on existing technologies. However, Alibaba Cloud hereby makes a clear statement that
it in no way guarantees the accuracy, integrity, applicability, and reliability of the content of this
document, either explicitly or implicitly. Alibaba Cloud shall not take legal responsibility for any errors or
lost profits incurred by any organization, company, or individual arising from download, use, or trust in
this document. Alibaba Cloud shall not, under any circumstances, take responsibility for any indirect,
consequential, punitive, contingent, special, or punitive damages, including lost profits arising from t he
use or trust inthis document (evenif Alibaba Cloud has been notified of the possibility of such a loss).

. By law, allthe contents in Alibaba Cloud documents, including but not limited to pictures, architecture

design, page layout, and text description, are intellectual property of Alibaba Cloud and/or its
affiliates. This intellect ual property includes, but is not limited to, trademark rights, patent rights,
copyrights, and trade secrets. No part of this document shall be used, modified, reproduced, publicly
transmitted, changed, disseminated, distributed, or published wit hout the prior written consent of
Alibaba Cloud and/or its affiliates. The names owned by Alibaba Cloud shall not be used, published, or
reproduced for marketing, advertising, promotion, or ot her purposes wit hout the prior written consent of
Alibaba Cloud. The names owned by Alibaba Cloud include, but are not limited to, "Alibaba Cloud",
"Aliyun", "HiChina", and other brands of Alibaba Cloud and/or its affiliates, which appear separately or in
combination, as well as the auxiliary signs and patterns of the preceding brands, or anyt hing similar to
the company names, trade names, trademarks, product or service names, domain names, patterns,
logos, marks, signs, or special descriptions that third parties identify as Alibaba Cloud and/or its
affiliates.

. Please directly contact Alibaba Cloud for any errors of this document.
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Document conventions

Style

/\ Danger

warning

) Notice

@ Note

Bold

Courier font

Italic

(1 or [alb]

{} or {a|b}

Description

A danger notice indicates a situation that
will cause major system changes, faults,
physical injuries, and other adverse
results.

A warning notice indicates a situation
that may cause major system changes,
faults, physical injuries, and other adverse
results.

A caution notice indicates warning
information, supplementary instructions,
and other content that the user must
understand.

A note indicates supplemental
instructions, best practices, tips, and
other content.

Closing angle brackets are used to
indicate a multi-level menu cascade.

Bold formatting is used for buttons ,
menus, page names, and other Ul
elements.

Courier font is used for commands

ltalic formatting is used for parameters
and variables.

This format is used for an optional value,
where only one item can be selected.

This format is used for a required value,
where only one item can be selected.

Example

& Danger:

Resetting will result in the loss of user
configuration data.

warning:

Restarting will cause business
interruption. About 10 minutes are
required to restart an instance.

p Notice:

If the weight is set to 0, the server no
longer receives new requests.

@ Note:

You can use Ctrl + A to select all files.

Click Settings> Network> Set network
type.

Click OK.

Runthe cd /d C:/window command to
enter the Windows system folder.

bae log list --instanceid

Instance_ID

ipconfig [-all|-t]

switch {active|stand}
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1.ASO overview

Apsara Stack Operations (ASQ) is an operations management system developed for the Apsara Stack
operations management personnel, such as field operations engineers, operations engineers on the
user side, and operations management engineers, operations security personnel, and audit personnel of
the cloud platform. ASO provides operations engineers with information about running conditions of
the systemin a timely manner and allows themto perform O&M operations.

ASO provides the following features:
e Monitoring and alerting

The Alert Monitoring module allows operations engineers to be quickly informed of system alerts,
locate problems based on the alert information, track problem processing, and configure alerts.

e Resource management

The Resource Management module monitors and manages hardware devices in the data center. You
can monitor and manage the overall status information, monitoring metrics, alert delivery status, and
port traffic of physical servers, physical switches, and network security devices.

e Inventory management

The Inventory Management module allows you to view the resource usage and inventory of various
services and manage system resources effectively.

e Products

The Products module allows you to access the O&M services of other products onthe cloud platform
and to configure ISV access configurations.

e NOC

The Network Operation Center (NOC) module provides operations capabilities such as the
visualization of end-to-end monitoring, automated implementation, automated fault location, and
network traffic analysis to enhance the efficiency of network operations engineers, reduce the
operations risk, and improves the quality of Apsara Stack services.

e Storage operations center

The Storage Operation Center module contains Apsara Distributed File System and miniOSS.
e Task management

The Task Management module allows you to perform O&M operations without using command lines.
e System management

The System Management module provides features such as user management, two-factor
authentication, role management, department management, logon policy management, application
whitelist, server password management, operation logs, and authorization. As the module for
centralized management of accounts, roles, and permissions, System Management supports the
Single Sign-0On (SS0). After you log onto the ASO console, you can perform O&M operations on all
components of the cloud platform or be redirected to the 0&M page without providing the
username or password.
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2.Preparations before operations
2.1. Prepare an operations account

Before you perform O&M operations in the Apsara Stack Operations (ASO) console, make sure that you
have obtained an operations account from an administrator.

Performthe following steps to create an operations account and grant permissions to the account:
1. Log onto the ASO console as a system administrator.

2. Create arole. For more information, see Role management.

3. Create an operations account and grant the role to the account. For more information, see User
management.

@ Note Foramore fine-grained division of the operations role, the administrator can create a
basic role based on Operation Administ rator Manager (OAM) in the Appendix, grant permissions to
the role, and then grant the role to the corresponding operations account. >

2.2.Log on to the ASO console

This topic describes how to log on to the Apsara Stack Operations (ASQO) console.

Prerequisites

e The URL of the ASO console, and the username and password used for logging on to the console are
obtained fromthe deployment personnel or an administrator.

The URL of the ASO console is in the following format: region-id.aso.intranet-domain-id.com.

e A browser is available. We recommend that you use the Google Chrome browser.

Procedure

1. Open your browser.
2. Inthe address bar, enter the URL region-id.aso.int ranet-domain-id.com and press the Enter key.

@ Note Youcanselect a language fromthe drop-down list in the upper-right corner of the
page.
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3. Enteryour username and password.

@ Note Obtainthe username and password for logging on to the ASO console fromthe
deployment personnel or an administrator.

When you log on to the ASO console forthe first time, you must change the password of your
username as prompted.

To enhance security, a password must meet the following requirements:
o It must contain uppercase and lowercase letters.

o It must contain digits.

o It must contain special characters such as exclamation points (1), at signs (@), number signs (#),
dollar signs ($), and percent signs (%).

o It must be 10to 20 characters in length.

4. ClickLog Ontogotothe ASO console.

2.3. ASO console overview

When you log onto the ASO console, the homepage appears. This topic describes the basic operations
and features of the ASO console.

ASO seff | (4 y English(US) 0
L] 7

(@ Alert Monitoring

Unsolved Alerts - Last Week

Product Alerts

tianji 139

P1 P2 P3 P4
:73

‘© 2008-2019 Alibaba Cloud Computing Limited. All rights reserved.

The following table describes the ASO homepage sections.

Section Description
@ Cloud Switch the cloud from the drop-down list.
. Switch the region from the drop-down list and centralize each
@ Region .
region.
) Authorization Click this section to go to the Authorization page and then
information view the authorization conditions of services.
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Section

@) Help center

® Current user

® Language
Current user

@ . )
information
Left-side

o
navigation pane

® Operation area

Description

View the alert knowledge base and upload other HT ML
documents that are related to O&M.

Show the name of the current logon user.

Show the language of the current environment.

Move the pointer over this section and select an item to view
the personal information of the current user, modify the

password, configure logon parameters, or log off from the
ASO console.

Select an O&M operation.

The information display and operation area.
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3.System settings
3.1. Default operations roles

This topic describes the default roles of Apsara Stack Operations (ASO) and their responsibilities.

For quick management, the following roles are preset in ASO: Operation Administrator Manager (OAM)
super administrator, system administrator, security of ficer, security auditor, and multi-cloud
configuration administrator. The following table describes these roles and their responsibilities.

Role Responsibility
OAM super administrator The administrator of OAM, with the root permissions of the system.

Manages platform nodes, physical devices, and virtual resources, backs
System administrator up, restores, and migrates product data, and searches for and backs
up system logs.

Manages permissions, security policies, and network security, and

Security officer . . A . .
y reviews and analyzes security logs and activities of auditor officers.

Audits, tracks, and analyzes operations of the system administrator

Security auditor ) .
y and the security officer.

Multi-cloud configuration Manages multi-cloud operations, and adds, deletes, and modifies
administrator multi-cloud configurations.

3.2. System Management

System Management centrally manages the departments, roles, and users involved in Apsara Stack
Operations (ASQO), making it easy to grant different resource access permissions to different users. As
the core module for centralized permission management, the user center integrates the functions such
as department management, role management, logon policy management, and user management.

3.2.1. Departments

This topic describes how to create, modify, and delete departments on the Department Management
page.

Context

By default, after Apsara Stack operations (ASO) is deployed, a root department is created. You can
create departments under the root department. Departments are displayed in a hierarchy and you can
create sub-departments under each level of departments.

Departments created under the root department are level-1 departments. Departments created under
a level-1 department are level-2 departments, and so on. In ASO, sub-departments of a department
referto departments of all levels under the department. Departments reflect the tree structure of an
enterprise or a unit. Each user can belong to only one department.

Procedure
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1. Log onto Apsara Stack Operations.

2. Inthe left-side navigation pane, choose System Management > Departments. The
Department Management page appears.

3. Onthe Department Management page, performthe following operations:
o Add a department

Inthe left catalog tree, select the department to which you want to add a department and click
Add Department inthe upper part of the page. Inthe Add Department dialog box, specify
Department Name and click OK. Then, you can view the created department under your
selected catalog.

o Modify a department

Inthe left catalog tree, select the department that you want to modify and click Modify
Department inthe upper part of the page. In the Modify Department dialog box, modify
Department Name and click OK.

o Delete a department

) Notice Before you delete a depart ment, make sure that it does not contain any users.
Otherwise, the department cannot be deleted.

Inthe left catalog tree, select the department that you want to delete and click Delete
Department inthe upper part of the page. In the message that appears, click OK.

3.2.2. Role management

You can add customroles in the ASO console to more efficiently grant permissions to users.

Context

A role is a set of access permissions. You can assign different roles to different users to meet
requirements for system access control. Roles are classified into basic roles and user-created roles. The
basic roles, also known as atomic roles, are preset by the OAM system and cannot be modified or
deleted by users. The user-created roles can be modified and deleted.

Procedure

1. Inthe left-side navigation pane, choose System Management > Roles.

2. Onthe Role Management page that appears, performthe following operations:

o Query roles
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@ Note To query roles, you must have the ASO security officer role or system
administrator role.

In the upper-left corner of the page, enter a role name in the Role field, and then click Search
to view the role information in the list.

Add arole
@ Note To add aroleinthe ASO console, you must have the ASO security officer role.

ClickAdd inthe upper part of the page. Inthe Add dialog box that appears, specify Role
Name, Role Description, and Basic Role, and then click OK.

Modify a role

@ Note To modify a user in the ASO console, you must have the ASO security officer
role.

Find the role that you want to modify, and then click Modify in the Actions column. Inthe
Modify Role dialog box that appears, modify the information, and then click OK.

Delete arole

) Notice Before you delete a role, make sure that the role is not bound to any user.
Otherwise, the role cannot be deleted.

Find the role that you want to delete, and then click Delete in the Actions column. In the
message that appears, click OK.

3.2.3. Region management

In multi-region scenarios, you can bind a department to a region as a system administrator. Afterthat,
users in the department can manage and view resources in the region.

Context

In multi-region scenarios, a region is managed by its own administrator. After an administrator logs on
to the ASO console, the administrator can only manage resources in the authorized region.

Relationship between departments and regions:

e A department can be bound to multiple regions.

e A region can be bound to multiple departments.

Procedure

1
2
3

N

. Inthe left-side navigation pane, choose System Management > Region Management.
. (Optional)in the upper-left corner of the page, enter a department name and click the search icon.

. Clickthe target department inthe tree on the left and select one or more regions in the Regions
list on the right.

. ClickUpdate Association.
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3.2.4. Logon policies

The administrator can configure logon policies to control the logon time and IP addresses of users.

Context

The system has a default policy as the initial configuration. You can configure logon policies to better
control the read and write permissions of users and improve the system security.

Procedure

1. Inthe left-side navigation pane, choose System Management > Logon Policy Management.

Logon Policy Management

olicy Name

2. Onthe Logon Policy Management page, performthe following operations:
o Query policies

In the upper left corner of the page, enter a policy name in the Policy Name field, and then click
Search to view the policy information in the list.

o Add a policy

Click Add Policy inthe upper part of the page. In the Add Policy dialog box, specify Policy
Name, Start Time, End Time, and IP addresses prohibited for logon. Click OK.

o Modify a policy

Find the policy that you want to modify, and then click Modify inthe Actions column. Inthe
Update Policy dialog box, modify the information, and then click OK.

o Delete a policy

Find the policy that you want to delete, and then click Delete in the Actions column. Inthe
message that appears, click OK.

3.2.5. User management

You can create users as an administrator and assign different user roles to meet different requirements
for system access control.

Prerequisites
Before you create a user, make sure that the following requirements are met:

e A department is created. For more information, see Depart ment management.

e A customrole is created if needed. For more information, see Role management.

Context

User management provides different permissions for different users.

Procedure
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1. Inthe left-side navigation pane, choose System Management > Users.The Users tab appears.
2. Performthe following operations:

o Query users

@ Note To searchfor usersin ASO, you must have the security officer role or system
administrator role.

In the upper-left corner of the tab, configure the User Name, Role, and Department
parameters, and then click Search to view the user information in the list.

o Add auser
@ Note To add auserin ASO, you must have the ASO security officer role.

Click Add inthe upper part of the tab. Inthe Add User dialog box, configure the information,
such as User Name and Password, and then click OK.

The added user is displayed in the user list. The value of the Primary Key Value parameteris
used for authentication when other applications call application APl operations in ASO.

o Modify a user
@ Note To modify a user in ASO, you must have the ASO security officer role.

Find the user to be modified, and then click Modify in the Actions column. In the Modify User
dialog box, modify the parameters, and then click OK.

o Delete a user

Find the userto be deleted, and then click Delete inthe Actions column. In the message that
appears, click OK.

@ Note Deleted users are displayed on the Recycled tab. To restore a deleted user,
clickthe Recycled tab. Find the userto be restored, click Cleared in the Actions column, and
then click OK.

o Bind a logon policy
Select a userin the user list. Click Bind Logon Policy to bind a logon policy to the user.
o Query personal information of the current user

Move the pointer over the profile picture in the upper-right corner of the page, and select
Personal Information fromthe drop-down list. In the Personal Information dialog box, view
the personal information of the current user.

Unauthorized @ English(US) O

Personal Information
Logon Settings

Log Out
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o Logon settings

Move the pointer over the profile picture in the upper-right corner of the page, and select
Logon Settings fromthe drop-down list. In the Logon Settings dialog box, configure Logon
Timeout, Multiple-Terminal Logon Settings, Maximum Allowed Password Retries, Account
Validity, and Logon Policy. Click Save.

Logon Setfings

Logon Timeout (Minutes)

180

Restore Default

Multiple-Terminal Logon Settings
Multiple-Terminal Logon Allowed Forbid Mulfi-Logon in ASO
Forbid Multi-Logon in D&M

Maxdmum Allowe

3.2.6. Two-factor authentication

To make user logon more secure, you can configure two-factor authentication for users.

Context
You can use one of the following authentication methods in the ASO console:
e Google two-factor authentication

This authentication method uses a password and mobile app to provide a two-layer protection for
accounts. You can obtain the logon key after you configure users in ASO, and then enter the key in
the Google Authenticator app of your mobile phone. The app dynamically generates a verification
code forlogon based on the time and key.

e USB key authentication

If you use this authentication method, you must install the drive and browser controls (only Windows
+ |IE 11 environment is supported) based on the third-party manufacturer instructions. The third-party
manufacturer provides the USB key hardware and the service for authentication and verification of
certificates. The USB key contains the serial number and certificate information. You must bind the
user account with the serial number on the management page of the two-factor authentication, and
configure the authentication server provided by the third-party manuf acturer. Then, you can enable
the USB key authentication for the user.
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If the USB key authentication is enabled for the account, upon logon, the ASO frontend calls the
browser controls, reads the certificate in the USB key, obtains the random code fromthe backend,
encrypts the information, and then sends the information to the backend. The backend calls the
authentication server to parse the encrypted strings, verifies the certificate and serial number, and
then completes the other logon processes if the verification is successful.

e PKlauthentication

If you use this authentication method, you must enable ASO HTTPS mutual authentication and
change the certificate provided by the user. The third-party manufacturer makes the certificate and
verifies the certificate at the backend. After HTTPS mutual authentication is enabled, the request
carries a client certificate upon logon and is passed to the backend. The backend calls the DNS and
verification services of the third-party manufacturer for verification. The certificate includes the name
and ID card number of a user. Therefore, bind the name and ID card number with a user account when
you configure the authentication method in ASO.

Both USB key authentication and PKI authentication depend on the authentication server provided by
the third-party manufacturer to verify the encrypted information or certificate provided upon logon.
Therefore, you must add the authentication server configurations before you use these two
authentication methods.

Google two-factor authentication is implemented based on public algorithms. Therefore, no third-
party authentication service is required, and you are not required to configure the authentication server.

Procedure

1. Inthe left-side navigation pane, choose System Management > Two Factor Authentication.
2. Onthe Two Factor Authentication page, you can performthe following operations:
o Google two-factor authentication
a. Set Current Authentication Method to Google Two-Factor Authentication.

b. ClickAdd User in the upper-right corner of the page. Inthe Add User dialog box, enter a
username and click OK. The added user is displayed in the user list.

¢. Find the user for whomyou want to enable Google two-factor authentication, and then
clickCreate Key inthe Actions column. Afterthe Added message appears, Show Key is
displayed in the Actions column. Click Show Key, and the key is displayed in plaintext in the
Key column.

d. Enterthe key in the Google Authenticator app on your mobile phone. The app dynamically
generates a verification code for logon based on the time and key. After two-factor
authentication is enabled, you are required to enter the verification code on your app when
you log onto the system.

@ Note The Google Authenticator app and server generate the verification code by
using public algorithms and based on the time and key, and can work offline without
connecting to the Internet or Google server. Therefore, you must keep your key
confidential.

e. To disable two-factor authentication, click Delete Key in the Actions column.
o USB key authentication
a. Set Current Authentication Method to USB Key Authentication.
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b.

e.

In the upper-right corner of the Authentication Server Configuration section, click Add
Server. In the Add Server dialog box, specify the IP Address and Port parameters for the
server. Click OK. The added server is displayed in the server list. Click Test inthe Actions
column to test the connectivity of the authentication server.

. Inthe upper-right corner of the User List section, click Add User. Configure the parameters

in the dialog box that appears and click OK. The added user is displayed in the user list.

. Find the username for which you want to enable the USB key authentication, and then click

Bind Serial Number in the corresponding Actions column. In the Confirm message, click
OK. ASO calls the browser control to automatically enter the serial number. If the serial
number fails to be specified, enter it manually in the Bind Serial Number dialog box to bind
the username with the serial number.

@ Note The serial number for USB key authentication is stored within the USB key.
Insert the USB key, install the drive and browser control, and then read the serial number
by using the browser control.

ClickEnable Authentication inthe Actions column.

o PKlauthentication

a.
b.

e.

Set Current Authentication Method to PKI Authentication.

In the upper-right corner of the Authentication Server Configuration section, click Add
Server. In the Add Server dialog box, specify the IP Address and Port parameters. Click OK.
The added server is displayed in the server list. Click Test in the Actions column to test the
connectivity of the authentication server.

. Inthe upper-right corner of the User List section, click Add User. Inthe Add User dialog

box, specify Username, Full Name, and ID card Name. Click OK. The added user is
displayed in the user list.

. (Optional)Find the username for which you want to enable the PKI authentication, and then

click Bind inthe Actionscolumn. Enter the full name and ID card number of the userto bind
the user account with the name and ID card number.

ClickEnable Authentication inthe Actions column.

o No authentication

Set Current Authentication Method to No Authentication. Two-factor authentication is
then disabled and all two-factor authentication methods become invalid.

3.2.7. Application whitelists

This topic describes how to add, modify, or delete application whitelists as a system administrator.

Context

All access permissions on ASQO services are managed by Operation Administrator Manager (OAM).
Accounts that do not have a corresponding role are not allowed to access ASO services. The
application whitelist feature allows you to access ASO services in scenarios where no permissions are
granted. After the application whitelist feature is enabled, the application can be accessed by all users
who have logged on. The valid application whitelist permissions are read-only and read/write. The
configured value is the logon user permission.
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The application whitelist is managed by the system administrator. You can access the application
whitelist page after you log on as a system administrator.

When you add a whitelist, specify the product name and permission. The current product name is aso,
and the service name is the name of the backend service registered in ASO. The whitelist takes effect
only if the configurations are valid.

Procedure
1. Inthe left-side navigation pane, choose System Management > Application Whitelist.

Application Whitelist

Add to Whitelist

Product Permission Actions

Network Monitoring Read-only

2. Onthe Application Whitelist page, performthe following operations:
o Add awhitelist

In the upper-right corner of the page, click Add to Whitelist. Inthe Add to Whitelist dialog
box, specify Service and Permission and click OK.

o Modify permissions
Select Read/Write orRead-only fromthe drop-down list in the Permission column.
o Delete a whitelist

Find the whitelist that you want to delete and click Delete inthe Actions column. In the
message that appears, click OK.

3.2.8. Manage server passwords

The Server Password module allows you to configure and manage server passwords and query history
passwords for servers deployed in the Apsara Stack environment.

Context

Server password management covers passwords of all the servers in the Apsara Stack environment.

e The system automatically collects information of all the servers in the Apsara Stack environment.
e The server password is updated periodically.

e You can configure the password expiration period and password length.

e You can manually update the passwords of one or more servers at a time.

e The systemrecords the history of server password updates.

e You can search for server passwords by product, hostname, or IP address.

Procedure
1. Inthe left-side navigation pane, choose System Management > Server Password.

The Password Management tab appears. The Server Password tab shows the passwords of all
the servers in the current Apsara Stack environment.
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| History Password | Configuration

IP

Enter an IP. Configuration

Product Host Name Password Update Time

ROOT i Sep 30, 2020, 03:38:06
ROOT i Sep 30, 2020, 03:38:06
ROOT i Sep 30, 2020, 03:36:06

ROOT * Sep 30, 2020, 03:38:07

2. You can performthe following operations:

o

(e]

Query servers

Onthe Password Management tab, select a product or host name, or enter an IP address, and
then click Search.

Query a password
a. Onthe Password Management tab, find a server.

b. ClickShow inthe Password column. The server password in plaintext is displayed and turns
into ciphertext after 10 seconds. Alternatively, click Hide to show the cipher text.

Update a password
a. Onthe Password Management tab, find a server.
b. ClickUpdate Password inthe corresponding Actions column.
c. Inthe Update Password dialog box, specify Password and Confirm Password. Click OK.
Then, the password of the corresponding server is updated.
Update multiple passwords
a. Onthe Password Management tab, select multiple servers.
b. ClickBatch Update inthe upper part of the tab.
c. Specify Password and Confirm Password. Click OK.
The passwords of the selected servers are updated.
Configure the password expiration period
a. Onthe Password Management tab, select one or more servers.
b. Click Configuration in the upper part of the tab.

¢. Inthe Configuration Item dialog box, specify Password Expiration Period and Unit. Click
OK.

Server passwords are updated immediately after the configuration and will be updated
again after an expiration period.

Query the update history of server passwords

Click the History Password tab. Select a product, hostname, or IP address, and then click Search
to view the update history of server passwords in the search results.

30
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o Query historical passwords of servers
a. Onthe History Password tab, find a server.

b. ClickShow inthe Password column. The host password in plaintext is displayed and turns
into the ciphertext after 10 seconds. Alternatively, you can click Hide to show the cipher
text.

o Query and modify the password configuration policy

Click the Configuration tab. On the Configuration tab, view the metadata of server password
management, including the initial password, password length, and retry times.

m |nitial Password shows the password assigned when server password management is
deployed in the Apsara Stack environment. This parameter is necessary to modify the
password of a server in the Apsara Stack environment.

m Password Length indicates the length of passwords automatically updated by the system.

m Retry Times indicates a limit of how many times a password can fail to be updated before
the system stops trying.

m Status specifies whether the configuration takes effect. By default, Status is disabled. To

enable Status, turn on m In the Confirm message, click OK.

To modify the configurations, click Modify in the Actions column. In the dialog box that
appears, specify Initial Password, Password Length, and Retry Times. Click OK. Modify
Status.

3.2.9. Operations logs

You can view logs to know the usage of all resources and the running status of all function modules on
the platformin real time.

Context

The Operation Logs page allows you to view all the records of backend API calls, including audit
operations. The auditor can filter logs by username and time period, and view the call details. You can
also export the selected logs.
Procedure
1. Inthe left-side navigation pane, choose System Management > Operations Logs.
2. Onthe Log Management page, performthe following operations:
o Query logs

In the upper-left cormner of the page, specify User Name and Time Period, and then click
Search.

o Delete logs

Select one or more logs to be deleted, and then click Delete in the upper part of the page. In
the message that appears, click OK.

o Export logs

Clickthe ] icon to export the displayed logs.
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@ Note If the number of logs to be exported exceeds the threshold (10,000 by default),
only the first 10,000 logs can be exported.

3.2.10. View authorization information

The Authorization page allows customers, field engineers, and operations engineers to query services
that have authorization problems and troubleshoot the problems.

Prerequisites

Make sure that the current logon user has administrator permissions. Only a user with administrator
permissions can view the trial authorization information or enter the authorization code to view the
formal authorization information on the Authorization Det ails tab.

When a non-administrator user accesses this page, a message indicating that the user has insufficient
permissions is displayed.

Procedure

1. Inthe left-side navigation pane, choose System Management > Authorization. The
Authorization Details tab appears.

Authorization Specification Details \ Authorization Specification Information

Authorizaion Type :  Tiial AuthorizafionExgired/Quota Excested
ECS Instance 1D :
Gloud Patform Version ©

Authorization Greated At - Nov 21. 2019, 15:50:20

‘Senvice Content Authorization Mode Servioe Authorizations Actual Authorizations Soiemes Licemss Lpriie sl | Scoffeses L icease prisie =l
Tech Support Started At Tach Support Expire At

VFC Standard Authorization Mode Nov21, 209, 15:50:20

Container 5 {cs) ans Authorization Mods 2(s| (s MNov 21,2019, 15:50:20

Graph Analytics Graph Analyfics Enterprise Authorization (s Dec 21, 209, 15:50:20

Enterprise Distributed

Apr 4, 2023, 155020
Application Service: (EDAS)

Dataphin Inteligence Edition Authorization Mode Nov 21, 208, 15:50:20 May 8, 2072, 15:50:20

2. Performthe following operations to view the authorization information.

@ Note Forformal authorization, you must enter the authorization code to view the
authorization information. Obtain the authorization code in the authorization letter attached
by the project contract or contact the commercial business manager (CBM) of your project to
obtain the authorization code.

o Onthe Authorization Details tab, view the basic authorization information.

You can view authorization information, including aut horization version, customer information,
authorization type, Elastic Compute Service (ECS) instance ID, cloud platformversion, the
creation time of authorization, and the authorization information of all services within the
current Apsara Stack environment.

The following table describes the detailed authorization information.
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Authorization information

Authorization Version

Authorization Type

Customer information

ECS Instance ID

Cloud Platform Version

Authorization Created At

Authorization information of a
service

Description

You can use the BP number in the version to associate with a
project or contract.

Notes:

= TRIAL in the version indicates that the authorization is a trial
authorization. The trial authorization is valid within 90 days
from the date of deployment.

® FORMAL in the version indicates that the authorizationis a
formal one. The authorization information of the service comes
from the signed contract.

Indicates the current authorization type and authorization status.
Includes the customer name, customer ID, and customer user ID.

The ECS instance ID in the deployment planner of the field
environment.

The Apsara Stack version of the current cloud platform.

The start time of the authorization.

Includes the service name, service content, current authorization
mode, service authorization quantity, actual authorization
quantity, software license update and technical support start
time, software license update and technical support end time,
and real-time product authorization status.

If the following information appears in the Authorization
Status column of a service:

= RENEW Service Expired

Indicates that the customer must renew the subscription as
soon as possible. Otherwise, field operations services (including
ticket processing) will be terminated.

m Specifications Above Quota

Indicates that the specifications deployed for a service have
exceeded the contract quota, and the customer must scale up
the service as soon as possible.

o Clickthe Authorization Specification Details tab to view the authorization specification

information of a service.

The following table describes the authorization specification information and the corresponding

description.

> Document Version: 20210128

33



Operations and Maintenance Guide-
System settings

ltem Description
Service Name The name of an authorized service.
Specification Name The specification name of an authorized service.

e . The total number of current authorizations of a specification for a
Specifications

service.
Specification Quota The authorization quota of a specification for a service.
Specification Status The current authorization status of a specification for a service.

o Clickthe Authaorization Specification Information tab to view the authorization
specification information and the authorization specification excess information of services.

In the upper part of the tab, specify Licensing Specification Level as IDC Level, select IDC ID,
service name, start time, and end time, and then click Search. You can view the authorization
specification information of a service in the current environment, including the maximum and
minimum number of specifications and their occurrence time points as well as the average
number of specifications within the specified time range.

Inthe Authorization Specification Information or Authorization Specification Excess
Information section, clickthe + icon on the left side of a service to view the specifications,
specification quota, and recorded time of authorization specifications of the specified time
range last day for the specification of the service. Click View More to view the authorization
specification information of the service within the specified time range by date.

3.2.11. Multi-cloud management

The Multi-cloud Management module provides the function of multi-cloud configurations. By using the
multi-cloud configurations, you can perform Operations & Maintenance (0&M) operations on dif ferent
data centers on an operations and maintenance platform.

3.2.11.1. Add multi-cloud configurations

If a multi-cloud environment is used, you can add multi-cloud configurations as a multi-cloud
configuration administrator or super administrator. After you add multi-cloud configurations, you can
switch to different data centers in the same console and then view or performrelated operations.

Prerequisites
Before you add multi-cloud configurations, make sure that the following requirements are met:

e Data centers are interconnected and share accounts that have the same usernames and passwords
with each other.

e You are granted the permissions of a multi-cloud configuration administrator or super administrator.

Procedure

1. Log onto the ASO console as a multi-cloud configuration administrator or super administrator.
2. Inthe left-side navigation pane, choose System Management > Multi-cloud Management.

3. Inthe upper part of the page, click Add.
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4. Inthe dialog box that appears, add the console link of another data center and click OK.
Parameter Description
Name The name of another data center.

The console link of another data center. Make sure that the console

Console Link L . .
link is correct. Otherwise, an error message is returned.

Afteryou add multi-cloud configurations, you can log on to the ASO console by using a shared
account to switch to different data centers and then perform related operations.

3.2.11.2. Modify the name of a data center

Afteryou add multi-cloud configurations, you can modify the name of a data center as a multi-cloud
configuration administrator or super administrator.

Procedure

1. Inthe left-side navigation pane, choose System Management > Multi-cloud Management.
2. (Optional)Enter the target name in the Name search box and then click Search.

3. Find the target name and click Modify in the Actions column.
4

. Inthe dialog box that appears, modify the name of the data center and click OK.

3.2.12. Menu settings

You can hide, add, modify, or delete a system menu based on business needs.

3.2.12.1. Add a level-1 menu

This topic describes how to add a level-1 menu.

Procedure

1. Inthe left-side navigation pane, choose System Management > Menu Configuration.
2. Inthe upper part of the page, click Add.

3. Inthe Add Level-1 Menu pane that appears, configure the menu parameters.
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Add Level-1 Menu

nu Mame

u Name(¥#)

Menu Name(English)

nu Order

» Deletable|Yes)

The following table describes the configuration of the parameters.

Parameter Description

Menu Icon Select the icon of the target level-1 menu from the drop-down list.
Menu Name Specifies the name of the menu.

Menu Order Specifies the order of items of this menu from top to bottom.

Specifies whether to show the menu. Toggle the switch to hide or

Show or Hide show the menu. By default, the menu is displayed.

Specifies whether this menu can be deleted after being added.
Toggle the switch to configure whether the menu can be deleted.
Deletable By default, the menu can be deleted.

This parameter cannot be modified after being specified.

4. Click OK.

Result

Then, you can view the added level-1 menu in the menu list and in the left-side navigation pane.

3.2.12.2. Add a submenu

This topic describes how to add a level-2 and a level-3 menu.

Procedure

1. Inthe left-side navigation pane, choose System Management > Menu Configuration.
2. Add a level-2 menu.

i. Find the level-1 menu to which you want to add a level-2 menu, and then click Add inthe
Actions column.
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ii. Inthe Add Submenu pane, configure the submenu parameters.

Add Submenu

+ Menu Name

Menu Name[ )

Menu Name{English)

» Menu Order

Link Address

Parent Menu

The following table describes the parameters.
Parameter Description
Menu Name Specifies the name of the level-2 menu.

Specifies the order of items of this level-2 menu from top to

Menu Order
bottom.

Specifies whether to hide this level-2 menu. Turn on or off the
Show or Hide switch to hide or show the menu. By default, the menu is not
hidden.

Specifies whether this level-2 menu can be deleted after being
added. Turn on or off the switch to configure whether the menu
Deletable can be deleted. By default, the menu can be deleted.

The settings cannot be modified after being configured.

Specifies the menu path in the format of module name/path

Link Address name. Example: /Dashboard/#/dashboardView.

Parent Menu The parent menu of this menu.

iii. Click OK.
You can view the added level-2 menu under the corresponding level-1 menu in the menu list
and the left-side navigation pane.

3. Clickthe fold button on the left side of the level-1 menu to expand the level-2 menus. Add a
level-3 menu by following the preceding steps.
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@ Note The system only supports up to three levels of menus. You cannot add submenus
for a level-3 menu.

Afteryou add a level-3 menu, you can view it under the corresponding level-2 menu in the menu
list and the left-side navigation pane.

3.2.12.3. Hide a menu

T his topic describes how to hide a menu.

Prerequisites

£} Notice You cannot hide the System Management menu and its submenus.

Procedure
1. Inthe left-side navigation pane, choose System Management > Menu Configuration.
2. Performthe following operations:
o Hide a level-1 menu

In the menu list, find the level-1 menu you are about to hide, and then click Modify in the
Actions column. In the Modify Menu pane, turmn on the switch to hide the menu, and then click
OK.

o Hide a level-2 or level-3 menu

In the menu list, find the level-2 or level-3 menu you are about to hide, and then click Modify in
the Actions column. In the Modify Menu pane, turn on the switch to hide the menu, and then
click OK.

3.2.12.4. Modify a menu

This topic describes how to modify the icon, name, and order of a menu.

Procedure

1. Inthe left-side navigation pane, choose System Management > Menu Management.
2. Inthe menu list, find the menu or submenu to be modified. Click Modify in the Actions column.

3. Inthe Modify Menu pane, modify the icon, name, and order of a level-1 menu, or modify the name,
order, and link address of a submenu.

3.2.12.5. Delete a menu

This topic describes how to delete a menu that is no longer needed.

Prerequisites

) Notice Youcan only delete a menu that had Deletable enabled when the menu was added.
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Procedure
1. Inthe left-side navigation pane, choose System Management > Menu Configuration.
2. Inthe menu list, find the menu or submenu to be deleted. Click Delete inthe Actions column.

3. Inthe message that appears, click OK.
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4 .Monitoring
4.1. Alert Monitoring

The Alert Monitoring module allows operations engineers to quickly know the information of alerts
generated by the system, locate the problems based on the alert information, track the problem
processing, and configure the alerts.

4.1.1. Dashboard

The Alert Monitoring module allows you to view the overview information of alerts.

Context

You can configure filter conditions to filter alerts by adding a customfilter.

Procedure

1. Inthe left-side navigation pane, choose Alert Monitoring > Dashboard.

Recovered Recovered Recovered Recovered

0 0 5,450 1,449

Recovered

0

2. Performthe following operations:

o View the total number of alerts and the number of recovered alerts in the basic, critical,
important, and minor monitoring metrics, as well as custom filters.

@ Note Clicka monitoring metric or customfilterto go to the corresponding Alert
Events page.

o Searchforalerts

Enter a keyword, such as cluster, product, service, severity, status, or monitoring metric name, in
the search box. Click Search to search for the corresponding alert event.

o Add acustomfilter
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Clickthe . icon. In the Add Filter pane, configure the parameters.

Recovered

0

Recovered

0

© 20082019 Albaba Cloud Computing Limited. AN rights reserved.

The following table describes the parameters for adding a filter.
Parameter Description

Name The filter name to be displayed on the Dashboard page.
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Parameter Description

Configure the following filter conditions:
® Service: the service to which the alerts to be filtered belong.
® Product: the product to which the alerts to be filtered belong.
m Severity: the severity of the alerts to be filtered.
Alert levels are classified into the following types:

= PO: indicates the cleared alerts, corresponding to alerts whose Alert
Level is Restored in Monitoring > Alert History of Apsara
Infrastructure Management Framework.

® P7: indicates the critical alerts, corresponding to alerts whose Alert
Level is P1 in Monitoring > Alert History of Apsara Infrastructure
Management Framework.

® P2: indicates major alerts, corresponding to alerts whose Alert Level
is P2 in Monitoring > Alert History of Apsara Infrastructure
Management Framework.

® P3: indicates the minor alerts, corresponding to alerts whose Alert
Level is P3 in Monitoring > Alert History of Apsara Infrastructure
Management Framework.

® P4: indicates the alerts for notice, corresponding to alerts whose
Alert Level is P4 in Monitoring > Alert History of Apsara
Infrastructure Management Framework.

Conditions

® P5: indicates the system alerts.

®m Status: the current status of the alerts to be filtered.

® Monitoring Metric Type: the type of the metric to which the alerts to
be filtered belong. Valid values:

® Basic
® (Critical
® Important
= Minor
= Enter the search content: the information about the alerts to be
filtered.
® Select the start date and end date of the alerts to be filtered.

Afteryou add a customfilter, you can view the overview information that meets the filter
conditions on the Dashboard page.

o Modify a customfilter

Afteryou configure a custom filter, you can click the i icon to modify the filter conditions and

obtain the new filter results.
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o Delete acustomfilter

Afteryou add customfilters, you can click the . iconto delete afilterthat is no longer needed.

4.1.2. Alert events

The Alert Events module displays the information of all alerts generated by the system on different
tabs. The alert information is aggregated by monitoring item or product name. You can search for alerts
based onfilter conditions such as monitoring metric type, product, service, severity, status, and time
range when the alert is triggered, and then perf orm O&M operations on the alerts.

Procedure

1. Inthe left-side navigation pane, choose Alert Monitoring > Alert Events.

Monitoring & Management | Cloud Product | TimeoutAlert

Status

2. You can clickthe Hardware & System, Base Modules, Monitoring & Management, Cloud
Product, orTimeout Alert tab, and performthe following operations:

o Searchforan alert

In the upper part of the tab, you can search for an alert by specifying Monitoring Metric Type,
Product, Service, Severity, Status, Start Date, End Date, or search content.

o View alert sources

a. If the alert information is aggregated by Product Name on this tab, click+ on the left side
of the product name to show the monitoring metrics. If the alert information is aggregated
by Monitoring Iltem on this tab, skip this step.

b. Find the monitoring metric and severity of the target alert, and then click the numberin the
specific severity column.

c. Move the pointer over the alert source information in blue in the Alert Source columnto
view the alert source details.

o View the details of a metric

a. If the alert information is aggregated by Product Name on this tab, click+ on the left side
of the product name to show the monitoring metrics. If the alert information is aggregated
by Monitoring Item on this tab, skip this step.

b. Find the monitoring metric and severity of the target alert, and then click the number in the
specific severity column.

c. Clickthe alert details in blue in the Alert Details column. Onthe Alert Details page, you
canview the alert information such as the alert description, reference, impact scope, and
resolution.

o View the original alert information of an alert
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a. If the alert information is aggregated by Product Name onthis tab, click + on the left side
of the product name to show the monitoring metrics. If the alert information is aggregated
by Monitoring Item, skip this step.

b. Find the monitoring metric and severity of the target alert, and then click the numberin the
specific severity column.

. Clickthe numberin blue inthe Alerts column. The Alerts pane appears.
d. Click Details inthe Alert Information column to view the original alert information.
o Process alerts

Find the monitoring metric and severity of the target alert, and then click the numberin the
specific severity column.

@ Note If the alert information is aggregated by Product Name on this tab, click + on
the left side of the product name to show the monitoring metrics.

m [f analert is being processed by operations engineers, choose Actions > Process inthe
Actions columnto set toln Process.

m [f the alert has been processed, choose Actions > Processed inthe Actions columnto set
the alert status to Processed.

m To view the whole processing flow of an alert, choose Actions > Alert Tracing inthe
Actions column.

m View the recent monitoring data

Choose Actions > Exploration inthe Actions column corresponding to an alert to view the
trend chart of a monitoring metric of a product.

o Export reports

Click the | icon in the upper part of the tab to download the alert list.

4.1.3. Alert history

The Alert History page shows all alerts generated by the system and their information in chronological
order.

Procedure

1. Inthe left-side navigation pane, choose Alert Monitoring > Alert History.
2. Onthe Alert History page, performthe following operations:
o Searchforan alert

In the upper part of the page, you can search for an alert by specifying Monitoring Metric
Type, Product, Service, Severity, Status, Start date, End date, or search content.

o Export the alert list

Clickthe - icon in the upper part of the page to export a list of historical alerts.

o View alert sources

44 > Document Version: 20210128



Operations and Maintenance Guide-
Monit oring

Move the pointer over an alert source name in blue in the Alert Source columnto view the alert
source details.

o View the details of a metric

Click an alert name in blue in the Alert Details column. Onthe Alert Details page, you can view
the alert information such as the alert description, reference, impact scope, and resolution.

o View the original alert information
Click Det ails in the Alert Information column to view the original information of the alert.
o View the alert duration

The alert duration is the total duration of an alert fromthe start time to the time when the alert
is terminated. You can view the duration of an alert in the Duration column. You can also move
the pointer over a value in the Duration column to view the specific start time of the alert.

4.1.4. Alert configuration

The Alert Configuration module provides you with three functions: contacts, contact groups, and
static parameter settings.

4.1.4.1. Alert contacts

You can query, add, modify, or delete an alert contact based on business needs.

Procedure

1. Inthe left-side navigation pane, choose Alert Monitoring > Alert Configuration. The Contacts
tab appears.

2. You can performthe following operations:
o Searchforalert contacts

In the upper-lefter corner of the tab, specify the product name, contact name, and phone
number and then click Search. The alert contacts that meet the search conditions are displayed
in the list.

o Add an alert contact

In the upper-left corner of the tab, click Add. The Add Contact pane appears. Configure the
parameters, and then click OK.

o Modify an alert contact

Find the alert contact to be modified and then click Modify in the Actions column. Inthe
Modify Contact pane, modify the relevant information and then click OK.

o Delete an alert contact

Find the alert contact to be deleted and then click Delete inthe Actions column. Inthe
message that appears, click OK.

4.1.4.2. Alert contact groups

You can query, add, modify, or delete an alert contact group based on business needs.

Procedure
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1. Inthe left-side navigation pane, choose Alert Monitoring > Alert Configuration.

2. Clickthe Contact Group tab.

3. Performthe following operations:

o Query an alert contact group

Enter a group name in the search box and click Search. The information of the alert contact
group that meets the search condition is displayed.

Add an alert contact group

Click Add inthe upper-left corner of the tab. Inthe Add Contact Group pane, enter a group
name and select the contacts to be added to the contact group. Click OK.

Modify an alert contact group

Find the contact group to be modified, and then click Modify in the Actions column. In the
Modify Contact Group pane, modify the group name, description, contacts, and notification
method. Click OK.

Delete one or more alert contact groups

Find the contact group to be deleted, and then click Delete in the Actions column. Inthe
message that appears, click OK.

Select one or more contact groups to be deleted and click Delete All in the upper part of the
tab. In the message that appears, click OK.

4.1.4.3. Configure static parameters

You can configure alert-related static parameters based on your business needs. Only parameters
related to timeout alerts can be configured.

Context

You cannot add new alert configurations in the current version. You can modify the default parameter
configurations for timeout alerts.

Procedure

"

. Inthe left-side navigation pane, choose Alert Monitoring > Alert Configuration.
. Clickthe Static Parameter Settings tab.

. (Optional)Enter a parameter name in the search box and click Search to query the static parameter
configurations.

. Find the static parameter to be modified, and then click Modify in the Actions column.

. Inthe Modify Static Parameter pane, modify the parameter name, parameter value, and
description.

46
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Modify Static Parameter

s Paramete

Alarm Time Out

» Parame

» Paramete

Alarms that exceed a specified number of days are classified as
overdue, Unit: day

Parameter Description
Parameter Name Enter a parameter name related to the configuration.

Enter the parameter value. The default value is 5, indicating five
days.

After you complete the configuration, you can choose Alert
Monitoring > Alert Events and then click the Timeout Alert tab

Parameter Value to view alert events that meet the condition specified by this
parameter value.

For example, if the parameter value is 5, you can choose Alert
Monitoring > Alert Events and then click the Timeout Alert tab,
alert events that are retained more than five days are displayed.

Description Enter the description related to the configuration.

6. Click OK.

4.1.5. Alert overview

The Alert Overview module allows you to query the distribution of different levels of alerts for Apsara
Stack services.

Procedure

1. Inthe left-side navigation pane, choose Alert Monitoring > Alert Overview.

The Alert Overview page appears.
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o The column chart inthe upper part of the page shows the number of unresolved alerts forthe
last seven days.

o The sectioninthe lower part of the page shows the alert statistics in the current system by
service.

4.1.6. Alert subscription and push

The alert subscription and push feature allows you to configure alert notification channels and then
push alerts to operations engineers.

Procedure

1. Inthe left-side navigation pane, choose Alert Monitoring > Subscribe/Push.

Subsoribed

n iter 1 HTTP Pushed » Push
Language ndiion UR Mlerts. PusiMode  ompiate

ey cn-gingdso- . ANS
zhCN TA= hitp 80 1 AL ANS

2. Onthe Subscribe tab, click Add Channel.

3. Inthe Add Subscription pane, configure the following parameters.
Parameter Description
Channel Name The name of the subscription channel.

The subscription language. Valid values: Chinese

Subscribed Language and English.

Subscription Region The region where the subscription is located.
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Parameter

Filter Condition

Protocol

Push Interface Address
Port Number

URI

HTTP Method

Push Cycle (Minutes)

Pushed Alerts

Push Mode

Push Template

Custom JSON Fields

Description

The filter conditions used to filter alerts. Valid
values:

o Basic

o Critical

° Important
o Minor

o Custom filter

The protocol used to push alerts. Only HTTP is
supported.

The IP address of the push interface.
The port number of the push interface.
The URI of the push interface.

The request method used to push alerts. Only the
POST method is supported.

The interval for pushing alerts. Unit: minutes.
The number of alerts pushed each time.

The mode used to push alerts. Valid values:
o ALL: All alerts are pushed each push cycle.

© TOP: Only high priority alerts are pushed each
push cycle.

The template used to push alerts. Valid values:
o ASO: the default template.

o ANS: select this template to push alerts by
DingT alk, short messages, or emails. You can
only configure a single channel of this type.

@ Note A preset ANS template exists
if the system already connects with ANS.
To restore the initial configurations of the
template with one click, click Reset in the
upper part of the page.

The person who receives the push can use this
field to customize an identifier. The field must be
in the JSON format.
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Specifies whether to push alerts.
) If the switch in this pane is not turned on, after
Push Switch you configure the subscription channel, you can
enable the push feature in the Push Switch
column.

4. Click OK. To modify or delete a channel, click Modify or Delete inthe Actions column
corresponding to the channel.

5. (Optional)The newly added channel is displayed in the list. Click Test in the Actions column
corresponding to the channel to test the connectivity of the push channel.

@ Note Forthe ANS push channel, afteryou click Test in the Actions column, you must
enter the mobile phone number, email address, or DingT alk to which alerts are pushed.

6. Afteryou configure the push channel and turn on the push switch, you can click the Push tab to
view the push records.

4.1.7. Alert masking

The Alert Masking module allows you to mask a type of alerts and remove the masking as needed.

4.1.7.1. Add masking rules

Masking rules allow you to mask alerts that you no long need to pay attentionto.

Procedure

1. Inthe left-side navigation pane, choose Alert Monitoring > Alert Masking.
2. Inthe upper part of the page, click Add.

3. Inthe Add pane, configure parameters related to the alerts to be masked.
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Alert lzm

OK Cancel

Description

Parameter

Product

Cluster

Service

Alert Item

Monitoring Metric

Alert Plan

Optional. The product to which the alerts to be masked belong.
Optional. The cluster to which the alerts to be masked belong.
Optional. The service to which the alerts to be masked belong.

Optional. The alert name to be masked.

@ Note When you configure Alert Item, if the number of
alerts is large, you may need to wait a few minutes.

Optional. The monitoring metric to which the alerts to be masked
belong.

Optional. The alert details of the alerts to be masked.

Example:

{"serverrole":"ecs-yaochi.ServiceTest#","machine":"vm010012

0****ll,"level":"error"}
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Parameter Description

Optional. The severity levels of the alert. Valid values:

o PO: indicates that the alert has been cleared, corresponding to
alerts whose Alert Level is Restored in Monitoring > Alert
History of Apsara Infrastructure Management Framework.

o P1: indicates critical alerts, corresponding to alerts whose Alert
Level is P1 in Monitoring > Alert History of Apsara
Infrastructure Management Framework.

o P2: indicates major alerts, corresponding to alerts whose Alert
Severity Level is P2 in Monitoring > Alert History of Apsara
Infrastructure Management Framework.

o P3: indicates minor alerts, corresponding to alerts whose Alert
Level is P3 in Monitoring > Alert History of Apsara
Infrastructure Management Framework.

°o P4: indicates alerts for notice, corresponding to alerts whose
Alert Level is P4 in Monitoring > Alert History of Apsara
Infrastructure Management Framework.

o P5: indicates system alerts.

4. Click OK.

Result

The added masking rule is displayed in the alert masking list.

After a masking rule is added, alerts that meet the conditions in the masking rule are not displayed in
the Alert Events and Alert History tabs.

4.1.7.2. Remove the masking

You can remove the masking for masked alerts.

Procedure
1. Inthe left-side navigation pane, choose Alert Monitoring > Alert Masking.
2. (Optional)Specify a product, service, or an alert item. Click Search.

3. Find the alert masking rule to be removed, and then click Delete inthe Actions column.

Alert Masking

4. Inthe message that appears, click OK.

Result

After you remove the masking, alerts that were masked by the deleted masking rule are displayed in the
Alert Events and Alert History tabs.
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4.1.8. Alert templates

This topic describes how to query, import, and export alert templates onthe Alert Templates page.
Afteryou import an alert template to the system, the system delivers the configurations to servers for
data collection and alert notification.

Procedure

1. Inthe left-side navigation pane, choose Alert Monitoring > Alert Templates.
2. Onthe Alert Templates page, performthe following operations:
o Query an alert template

In the upper part of the page, you can search for an alert template by specifying Product,
Cluster, orService. To clearthe filter conditions, click Reset.

o Import an alert template
a. Select a product and service, and then clickImport in the corresponding Actions column.

b. Inthe Import Template dialog box, clickUpload and Parse File in the upper-left corner.

(@ Note You can contact Alibaba Cloud technical support personnelto obtain the
template file to be uploaded.

Select and upload the template file that you want to upload. The file is parsed to the
Template Details section.

Import Template

base-template(1)

-log”,~logbath™:"/", T1ilters:

+-\\d+ \\d+:\\d+:\\d+."

, 'metrics":[{"enable™:

-check _application proc_state serverrole TumblingWindow 68 by ts select t.serverrole as
serverrole,t.host as host, value(t._status) as _status from stream.aliyunidappaccess t

where t iptnamn_ umm-ak-check_application_proc_state' group by t.serverrole,t._host"}

true,"sql™:"create metric umm-ak-check application proc state host

Tumbllngwlndow 60 by ts select t.host as host, value(t._status) as tus from stream
-aliyunidappaccess t where t.scriptname="'umm-ak-check_application_proc_state' group by t
-host"},{"enable™:true,"sgl" :"create metric umm-ak
-check_application_proc_state_cluster_serverrole TumblingWindow 68 by ts select t
.cluster as cluster,t.serverrole as serverrole,t._host as host, value(t._status) as

_status from stream.aliyunidappaccess t where t.scriptname="umm-ak
-check_application_proc_state" group by t.cluster,t.serverrole,t.host"},{"enable":true

w_

,"sql":"create metric umm-ak-check appll[atlon proc state_cluster Tumbllngwlndow 60 by

c. ClickSave and Upload

The name of the uploaded file is displayed in the Associated Template column of the
alert template list.

o Export an alert template

Select a product and service, and then click Export inthe Actions column. The associated
template file is downloaded.
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4.2. Resource management

The Resource Management module allows you to view the topology information, related alerts, server
information, and monitoring data of all products that are deployed in Apsara Stack.

4.2.1. Physical servers

Operations personnel can monitor and view the physical servers where each product is located.

4.2.1.1. View the physical server information

This topic describes how to view the physical server list and the details of physical servers.

Product tab

1.

In the left-side navigation pane, choose Resource Management > Physical Servers.

The Product tab appears. In the upper-right corner of the tab, the number of current physical
servers, the number of servers with alerts, and the number of alerts are displayed.

Physical View of Device Physical Servers: @) Servers with Alerts: (180 Alers: (512

Product

middleWare staragent

middleWare staragent

middleWare staragent

2. Onthe Product tab, performthe following operations to view the physical server information:

o Expand the left-side navigation tree by selecting a region, product, and cluster in sequence to
view the list of physical servers where a cluster of a service is located.

o Inthe left-side search box, enter the product name, cluster name, group name, or hostname to
search for the corresponding node.

o Inthe right-side search box, search for physical servers by product, cluster, group, or hostname
and view the details of a physical server.

o Select a product and click Det ails inthe Actions column. On the Physical Server Details page,
you can view the basic information, monitoring details, and alert information of the physical
server to which the product belongs.

You can switch the tab to view the monitoring and alert information.

Monitoring information includes the CPU usage, system load, disk usage, memory usage, network
throughput, and disk 10. When you view the monitoring information, you can select a monitoring
item in the upper-right corner of each monitoring graph and then select the time range to view
the monitoring value in the specific time range.

In the upper-right corner of the CPU usage, system load, disk usage, memory usage, network
throughput, and disk 10 sections, you can performthe following operations:

m Clickthe E icon to view the monitoring graph in full screen.

m Click the [ icon to download the monitoring graph to your local computer.

54

> Document Version: 20210128



Operations and Maintenance Guide-
Monit oring

m Clickthe icon to manually refresh the monitoring data.

m Clickthe . icon. The icon will turn green. The system automatically refreshes the monitoring

data every 10 seconds. To disable the auto refresh feature, click the icon again.

Server tab
1. Inthe left-side navigation pane, choose Resource Management > Physical Servers.

The Product tab appears. In the upper-right corner of the tab, the number of current physical
servers, the number of servers with alerts, and the number of alerts are displayed.

2. Clickthe Server tab.
3. Onthe Servertab, performthe following operations to view the physical server list:

o Expand the left-side navigation tree by selecting an IDC and a rack in sequence to view the
physical server list in a rack.

o Enterthe rack name in the left-side search box and press the Enter key to search for and view the
list of all the physical servers in the rack.

Physical View of Device Physical Servers: (@8l Servers with Alerts: (138 Alerts: (512

4. To view the details of a physical server, enter the hostname, IP address, device function, or serial
number (SN) in the right-side search box and press the Enter key.

5. Find the physical server whose details you are about to view and then click Det ails in the Actions
column. On the Physical Machine Det ails page, view the basic information, monitoring
information, and alert information of the physical server.

You can switch the tab to view the monitoring and alert information.

Monitoring information includes the CPU usage, system load, disk usage, memory usage, network
throughput, and disk I0. When you view the monitoring information, you can select a monitoring
item in the upper-right corner of each monitoring graph and then select the time range to view the
monitoring value in the specific time range.

In the upper-right corner of the CPU usage, system load, disk usage, memory usage, network
throughput, and disk 10 sections, you can performthe following operations:

o

Clickthe E icon to view the monitoring graph in full screen.

o

Click the ¥ icon to download the monitoring graph to your local computer.

o

Clickthe icon to manually refresh the monitoring data.

o

Clickthe . icon. The icon will turn green. The system automatically refreshes the monitoring

data every 10 seconds. To disable the auto refresh feature, click the icon again.

The Physical View of Device tab
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1. Inthe left-side navigation pane, choose Resource Management > Physical Servers.

The Product tab appears. In the upper-right comer of the tab, the number of current physical
servers, the number of servers with alerts, and the number of alerts are displayed.

2. Clickthe Physical View of Device tab.

3. Onthe Physical View of Device tab, expand the left-side navigation tree by selecting an IDC and
a rack in sequence to view the corresponding rack information on the right. In addition, the rack
details pane appears on the right side of the tab and shows the server information of the rack.

Racks and servers are displayed in different colors to indicate the alert condition of servers:

o Red indicates a critical alert.
o Orange indicates a moderate alert.
o Blue indicates that the physical server is normal.

In the upper-right corner, you can view the alert legend. By default, the check box at the left of
the legend is selected, indicating that the information of racks or servers of this alert type is
displayed on the rack graph or in the rack details pane. Clear the check box at the left of a legend
to hide the information of racks or servers of this alert type on the rack graph or in the rack details
pane.

4. To view the details of a physical server, performthe following operations:

i. Find the physical server whose details you are about to view in the left-side navigation tree or
rack graph on the right side of the tab.

ii. Inthe rackdetails pane that appears, clickthe color block of a serverto view the basic
information of the server.
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iii. ClickDetails inthe Operation row of the basic information.

Product

iv. Onthe Physical Server Details page, view the basic information, monitoring details, and alert
information of the physical server.

You can switch the tab to view the monitoring information and alert information.

Monit oring information includes the CPU usage, system load, disk usage, memory usage,
network throughput, and disk 10. When you view the monitoring information, you can select a
monitoring item in the upper-right corner of each monitoring graph and then select the time
range to view the monitoring value in the specific time range.

In the upper-right corner of the CPU usage, system load, disk usage, memory usage, network
throughput, and disk 10 sections, you can performthe following operations:

m Clickthe E icon to view the monitoring graph in full screen.
m Clickthe ¥ icon to download the monitoring graph to your local computer.
m Clickthe icon to manually refresh the monitoring data.

m Clickthe . icon. The icon will turn green. The system automatically refreshes the

monitoring data every 10 seconds. To disable the auto refresh feature, click the icon again.

4.2.1.2. Add physical servers

Operations personnel can add the information of existing physical servers in the environment to the
ASO console.
Procedure

1. Inthe left-side navigation pane, choose Resource Management > Physical Servers.

The Product tab appears. In the upper-right corner of the page, the number of current physical
servers, the number of servers with alerts, and the number of alerts are displayed.

2. Clickthe Server or Physical View of Device tab.
3. Inthe upper-right corner of the Server tab orthe upper-left corner of the Physical View of
Device tab, click the [JJEHlj icon.

4. Inthe Add Physical Server pane, configure the parameters.

The following table describes the parameters.
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Parameter Description
Zone The zone where the target physical server is located.

Data Center

Rack

Room

Physical Server Name

Memory

Disk Size

CPU Cores

Rack Group

Server Type

Server Role

Serial Number

Operating System Template

IP Address

5. Click OK.

The data center where the target physical server is located.
The rack where the target physical server is located.

The room where the target physical server is located.

The name of the target physical server.

The memory size of the target physical server.

The disk size of the target physical server.

The CPU cores of the target physical server.

The rack group to which the target physical server belongs.
The type of the target physical server.

The function or purpose of the target physical server.

The serial number (SN) of the target physical server.

The template used by the operating system of the target physical

server.

The IP address of the target physical server.

4.2.1.3. Modify a physical server

This topic describes how to modify the physical server information in the systemwhen the information

is changed in the Apsara Stack environment.

Server tab

1.

In the left-side navigation pane, choose Resource Management > Physical Servers.

The Product tab appears. In the upper-right comer of the tab, the number of current physical

servers, the number of servers with alerts, and the number of alerts are displayed.

. Clickthe Server tab.

. (Optional)in the right -side search box, search for the physical server to be modified by hostname, IP

address, device function, or serial number (SN).

Find the target physical server, and then click Modify in the Actions column.
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5.

6.

Physical View of Device Physical Servers: @3 Servers with Alerts: (30  Alerts: (512

Inthe Modify Physical Server pane, modify the physical server information. You can modify the
following physical server information: zone, data center, rack, room, physical server name, memory
size, disk size, CPU cores, rack group, server type, server role, serial number, operating system
template, and IP address.

Click OK.

Physical View of Device tab

1.

7.

In the left-side navigation pane, choose Resource Management > Physical Servers.

The Product tab appears. In the upper-right corner of the tab, the number of current physical
servers, the number of servers with alerts, and the number of alerts are displayed.

Clickthe Physical View of Device tab.

Expand the left-side navigation tree by selecting an IDC and a rack in sequence to find the physical
server to be modified.

@ Note Inthe left-side search box, you can also search for the target physical server by
rack, hostname, IP address, device function, SN, or IDC.

. Inthe rack details pane that appears, clickthe color block of a serverto view the basic information

of the server.

. Click Modify inthe Operation row of the basic information.

cnqingdac-envébdall

Product

. Inthe Modify Physical Server pane, modify the physical server information. You can modify the

following physical server information: zone, data center, rack, room, physical server name, memory
size, disk size, CPU cores, rack group, server type, server role, serial number, operating system
template, and IP address.

Click OK.

4.2.1.4. Export server information

You can export the information of all physical servers within the system for offline viewing.

Product tab

> Document Version: 20210128

59



Operations and Maintenance Guide-
Monit oring

The physical server information exported fromthe Product tab includes the zone, hostname, disk size,
CPU cores, memory size, information about the data center (data center, rack, room, and rack group),
model, device function, serial number, operating systemtemplate, IP address, out-of-band IP address,
CPU architecture, host server, alerts, region, product, cluster, and service role group.

1. Inthe left-side navigation pane, choose Resource Management > Physical Servers.

The Product tab appears. In the upper-right corner of the page, the number of current physical
servers, the number of servers with alerts, and the number of alerts are displayed.

Physical View of Device

Physical Servers: (@) Servers with Alerts: (1380 Alerts: (512

Product

middieWare-staragent

middieWare staragent

2. Inthe upper-right corner of the tab, clickthe icon to export the information of all the physical

servers of all services to your local computer.

Server or Physical View of Device tab

The physical server information exported fromthe Server or the Physical View of Device tab includes
the zone, hostname, disk size, CPU cores, memory size, information about the data center (data center,
rack, room, and rack group), model, device function, serial number, operating systemtemplate, IP
address, out-of-band IP address, CPU architecture, and alerts.

1. Inthe left-side navigation pane, choose Resource Management > Physical Servers.

The Product tab appears. In the upper-right corner of the page, the number of current physical
servers, the number of servers with alerts, and the number of alerts are displayed.

2. Clickthe Server orthe Physical View of Device tab.
3. Inthe upper-right corner of the Server tab or in the upper part of the Physical View of Device

tab, clickthe icon to export all the information of physical servers to your local computer.

4.2.1.5. Delete a physical server

This topic describes how to delete a physical server that does not need to be monitored.

Server tab

1. Inthe left-side navigation pane, choose Resource Management > Physical Servers.

The Product tab appears. In the upper-right corner of the tab, the number of current physical
servers, the number of servers with alerts, and the number of alerts are displayed.

2. Clickthe Server tab.

3. (Optional)in the right-side search box, search for the physical server to be deleted by hostname, IP
address, device function, or serial number (SN).

4. Find the target physical server, and then click Delete in the Actions column.

5. Inthe message that appears, click OK.

Physical View of Device tab
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6.

. Inthe left-side navigation pane, choose Resource Management > Physical Servers.

The Product tab appears. In the upper-right corner of the tab, the number of current physical
servers, the number of servers with alerts, and the number of alerts are displayed.

. Clickthe Physical View of Device tab.

. Expand the left-side navigation tree by selecting an IDC and a rack in sequence to find the physical

serverto be deleted.

@ Note Inthe left-side search box, you can also search for the physical server to be
deleted by rack, hostname, IP address, device function, SN, or IDC.

. Inthe rack details pane that appears, clickthe color block of a serverto view the basic information

of the server.

. Click Delete inthe Operation row of the basic information.

self

Product

In the message that appears, click OK.

4.2.2. Product O&M

0&M personnel can view the product topology and the clusters and alerts related to each product.

4.2.2.1. Product overview

The Product Overview page allows you to view the statistics of all products and the related topology
and alert information.

Procedure

1.
2.

In the left-side navigation pane, choose Resource Management > Product Overview.
Onthe Product Overview page, you can view the product statistics and architecture.
o Statistics

In the upper part of the Product Overview page, you can view the number of products,
clusters, service roles, and alerts.

Product Overview

32 Total number of products 55 Total number of clusters 947 A 122

Total number of service roles Total number of alarms
Reach final state29 Reach final state5 1 Reach final state942 P1 93 16

Clickthe H icon in the upper-right corner of the Clusters or Service Roles sectionto go to the

Clusters orService Roles page.

o Architecture
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In the Architecture section, you can view the product hierarchical architecture and products in
categories.

m Architecture

In the upper part of the Architecture section, click a state of products such as All States. In
the left side of the section, click a product category such as Elastic Computing. You can find
a specific product in the product hierarchical architecture in categories.Click a product name
such as zastck to go to the corresponding Product Det ails page and view the detailed
product information.

Product Details page ©

' Cluster 1 Service role 951 Number of m

Cluster list

Number of Number of

Cluster name Products Cluster status TS e

Number of alarms

zstack 4

m Products

Clickthe E icon in the upper-right corner of the Architecture sectionto gotothe

product list page. You can click a product category in the upper part of the section to view
the name, cluster status, and number of clusters, service roles, servers, and alerts of products.

4.2.2.2. View clusters
The Clusters page allows you to view the cluster status and the number of alerts.

Procedure

1. Inthe left-side navigation pane, choose Resource Management > Cluster List.
2. Onthe Clusters page, you can search by Product Name, Cluster, or Status to view the
information of a cluster.

Column Description

The name of the cluster.

Click a cluster name to go to the Cluster Details
page. You can view the cluster statistics and
service roles.

Cluster Name

The information about the product to which the

Associated Product
cluster belongs.
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Column

Cluster Status

Number of Service Roles

Number of Servers

Number of Alerts

4.2.2.3. View service roles

Description

The status of the cluster.

o Desired State: The cluster has reached the
desired state.

o Not Desired State: The cluster has reached
the desired state for the first time but then a
service role cannot reach the desired state due
to undefined reasons.

The number of service roles within the cluster.

The number of servers within the cluster.

The number of alerts in the cluster. Alerts are
classified into the following severity levels:

o PO: an alert that has been cleared
©o P1: anurgent alert

o P2: amajor alert

°o P3: aminoralert

° P4: areminder alert

The Service Roles page allows you to view the status and alerts of each service role in a cluster.

Procedure

1. Inthe left-side navigation pane, choose Resource Management > Service Role List.

2. Onthe Service Roles page, you can search by Product Name, Cluster Name, or Status to view

the information of a service role.

Service role list

ter the product name ~~ lea ter uster name

Service role name Service role status Belonging service

mock-service-for-paas

mock-service-for-paas

Column

Service Role Name

Cluster

Producis Machine Number of alarms

Atotalof 0 sets | Nor

apsarabase .
mal:

AtotalofOsets | Nor

apsarabase -
mal:

Description

The name of the service role.
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Column Description

The status of the service role.

o Normal: The service role version is correct and
the service role is running normally.

o Service Error: An exception occurs in the
service role.

°o Inconsistent Versions: The service role has
not been upgraded to the desired version.

Service Role Status o Changing: The service role is being upgraded
or removed.

o Server Error: One or more servers on which
the service role is deployed are not in the
normal state.

o |n Operation: The service role is in an
operation other than being upgraded or
removed.

Associated Service The service to which the service role belongs.

The name of the cluster to which the service role

Associated Cluster
belongs.

The name of the product to which the service role

Associated Product
belongs.

The number of servers on which the service role is
deployed.

Click the number next to the server status

Server corresponding to a server. In the dialog box that
appears, click View Details to go to the
Physical Servers page and view detailed server
information.

Number of Alerts The total number of alerts of the service role.

4.3. Inventory Management

The Inventory Management module allows you to view the current usage and inventory of various
product resources, and manage resources in the system effectively.

4.3.1. View the RDS inventory

By viewing the Relational Database Service (RDS) inventory, you can query the usage and availability of
RDS resources to more efficiently perform O&M operations.

Procedure

1. Inthe left-side navigation pane, choose Inventory Management > RDS.
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@ Note Youcanclickthe icon in the upper-right corner of the page to set the inventory

thresholds of each engine.

2. View the RDS inventory.
On this page:

o The RDS Inventory section shows the inventory of different RDS services for the last five days.
Different RDS services are displayed in different colors.

o You can query the RDS inventory by pages by specifying Engines or Date in the RDS Inventory
Det ails section.

4.3.2. View the 0SS inventory

By viewing the Object Storage Service (OSS) inventory, you can query the usage and availability of 0SS
resources to more efficiently perform O&M operations.

Procedure

1. Inthe left-side navigation pane, choose Inventory Management > 0SS.

@ Note Youcanclickthe icon in the upper-right corner to configure the inventory

thresholds.

Inventory Awsitabiity History(TE)

Puraitable(TE)

2. View the 0SS inventory.
The following information is displayed:

o TheInventory Availability History (TB) section shows the available 0SS inventory for the last
five days.

o The Current Inventory Usage (TB) section shows the amount and percentage of 0SS
inventory that are being used.

o The 0SS Bucket Inventory Details section shows the 0SS inventory details on multiple pages
by Date.

4.4. Storage operation center

The Storage Operation Center module contains Apsara Dist ributed File System and miniOSS.
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4.4.1. Apsara Distributed File System

The Apsara Distributed File System module shows the overview information, cluster information, node
information, and the statuses of clusters.

4.4.1.1. Overview

The Apsara Distributed File System module allows you to view the overview information, health
heatmap, and data of top five clusters of a service.

Procedure

1. Inthe left-side navigation pane, choose Storage Operation Center > Apsara Distributed File
System > Qverview.

2. Select the service that you want to view fromthe Service drop-down list. You can view the
following information:

The Apsara Distributed File System module shows the overview information, health heatmap, and
data of top five clusters of services as of the current date.

o Overview

The Overview section shows the storage space, server information, and health information of the
specified service. In the Healt h section, when the value of Abnormal Disks, Abnormal
Masters, Abnormal Chunk Servers, or Abnormal Water Levels is greaterthan 0, the value is
displayed in red.

o Heatmap of Health

The Heatmap of Health section shows the health information of all clusters within the specified
service. Clusters in different health statuses are displayed in different colors.

Green indicates that the cluster works properly.

Yellow indicates that the cluster has a warning.

Red indicates that the cluster has an exception.

Dark red indicates that the cluster has a fatal error.

Grey indicates that the clusteris disabled.

Click the name of an enabled clusterto go to the corresponding cluster information page.

“  Heatmap of Health

OssHybridCluster-A-200190927- 3del

o Data of Top 5 Services
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The Data of Top 5 Services section shows the data of the top five healthiest clusters of the
specified service for the current date over the time range from 00:00 to the current time.

This section shows the top five clusters in terms of abnormal water levels, abnormal masters,
abnormal disks, and abnormal chunk servers. Click the cluster name to go to the corresponding
cluster information page.

4.4.1.2. Cluster information
The Cluster Information module allows you to view the overview information and run charts of a cluster.

Procedure

1. Inthe left-side navigation pane, choose Storage Operation Center > Apsara Distributed File
Storage > Cluster Information.

On the page that appears, the data of the first clusterin the Cluster Name drop-down list is
displayed.

2. Select the clusterthat you want to view fromthe Cluster Name drop-down list. The following
information is displayed:

@ Note Allthe enabled clusters that are accessed wit hin the current environment are
displayed in the Cluster Name drop-down list.

o QOverview

This section shows the storage space, server information, and health information of the
specified cluster. In the Healt h section, when the value of Abnormal Disks, Abnormal
Masters, Abnormal Chunk Servers, orAbnormal Water Levels is greater than 0, the value is
displayed in red font.

o Alarm Monitor

This section shows the alert information of the specified cluster. You can query data by keyword.
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Fuzzy Search:

o Replica
This section shows the replica information of the specified cluster.
o Run Chart of Clusters

This section shows the charts of historical water levels, predicted water levels, number of files,
number of chunk servers, and number of disks for the specified cluster.

Predicted water levels predicts the run chart of the next seven days.

@ Note The water level can only be predicted if there is enough historical water level
data. Some clusters may not have predicted water levels.

o Rack Information
Rack information includes rack capacity and servers in rack.

m Servers in Rack shows the number of machines in each rack of the specified cluster.
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m Storage shows the total and used storage of each rackin the specified cluster.

Total Used ! Total Used

4.4.1.3. Node information

The Node Information module allows you to view the master information and chunk server inf ormation
in a cluster.

Procedure

1. Inthe left-side navigation pane, choose Storage Operation Center > Apsara Distributed File
System > Node Information.

On the page that appears, the data of the first clusterin the Cluster Name drop-down list is
displayed, including master information and chunk server information.

2. Select the name of the clusterthat you want to view fromthe Cluster Name drop-down list. The
following information is displayed:

@ Note Allaccessed clusters that are not disabled inthe current environment are displayed
in the Cluster Name drop-down list.

o Master Info

This section shows the master information of the specified cluster. You can clickRefresh to
refresh the master information of the specified cluster.

Cluster Mame: | ECS

v Master Info

PRIMARY

o Chunk Server Info

This section shows the chunk server information of the specified cluster. You can clickRefresh to
show the chunk server information of the cluster. Click the + iconin front of a server, the disk and
SSD cache information of the serveris displayed. Fuzzy search is supported in this section.
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DiskBroken Disks/Disks = Status

NORMAL

NORMAL

NORMAL

NORMAL

NORMAL

4.4.1.4. Operations and maintenance

The Operations and Maintenance module allows you to view the cluster statuses.

Procedure

1. Inthe left-side navigation pane, choose Storage Operation Center > Apsara Distributed File
System > Operations and Maintenance.

2. Select a service fromthe Service drop-down list to view the cluster status of the service. Clusters
in different health statuses are displayed in different colors.

o Green indicates that the cluster works properly.
o Yellow indicates that the cluster has a warning.
o Red indicates that the cluster has an exception.
o Darkred indicates that the cluster has a fatal error.

o Grey indicates that the clusteris disabled.

OssHybridChuester-A-20100027-2de0

3. Move the pointer over a cluster name to view the service name, server name, and IP address to
which the cluster belongs.

4.4.1.5. Product configuration

By default, the system configures thresholds for all clusters. You can modify the water threshold, chunk
server threshold, and disk threshold for each cluster.

Procedure

1. Inthe left-side navigation pane, choose Storage Operation Center > Apsara Distributed File
System > Product Configuration.

2. Inthe upper part of the page, select the cluster that you want to configure fromthe Cluster
Name drop-down list.

3. Inthe lower part of the page, clickModify to modify the thresholds of the cluster.

The following table describes the parameters.
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Section

warn Threshold

Cluster wWater Level Error Threshold

Fatal Error
Threshold

warn Threshold
(Abnormal Chunk
Server Quantity)

Chunk Server

Error Threshold
(Chunk Server Ratio)

Description

When the storage usage of the cluster is greater
than or equal to this value, a warning alert is
triggered and the health heatmap of the cluster is
displayed in yellow. Value range: (0,100].

If this parameter is not specified, a warning alert
is triggered by default when the water level of
the cluster is greater than or equal to 65%.

When the storage usage of the cluster is greater
than or equal to this value, an error alert is
triggered and the health heatmap of the cluster is
displayed in red. Value range: (0,100].

If this parameter is not specified, an error alert is
triggered by default when the water level of the
cluster is greater than or equal to 85%.

When the storage usage of the cluster is greater
than or equal to this value, a fatal-error alert is
triggered and the health heatmap of the cluster is
displayed in dark red. Value range: (0,100].

If this parameter is not specified, a fatal-error
alert is triggered by default when the water value
of the cluster is greater than or equal to 92%.

When the number of abnormal chunk servers is
greater than or equal to this value, a warning
alert is triggered and the health heatmap of the
cluster is displayed in yellow.

If this parameter is not specified, a warning alert
is triggered by default when the number of
abnormal chunk servers is greater than or equal
to 1.

If the ratio of abnormal chunk servers to all the
chunk servers is greater than this value, an error
alert is triggered and the health heatmap of the
cluster is displayed in red.

If this parameter is not specified, an error alert is
triggered by default when the ratio of abnormal
chunk servers to all the chunk servers is greater
than or equal to 10%.
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Section Description

When the number of abnormal disks is greater
than or equal to this value, a warning alert is
triggered and the health heatmap of the cluster is

Warn Threshold displayed in yellow.

(Abnormal Disk

Quantity) If this parameter is not specified, a warning alert
is triggered by default when the number of
abnormal disks is greater than or equal to 1.

Disk When the ratio of abnormal disks to all the disks

is greater than this value, an error alert is
triggered and the health heatmap of the cluster is
Error Threshold displayed in red.
(Abnormal Disk

. If this parameter is not specified, an error alert is
Ratio)

triggered by default when the ratio of abnormal
disks to all the disks is greater than or equal to
10%.

@ Note To reset the configurations during the modification, click Cancel to cancel the
current configurations.

4. ClickSave.

4.4.2. miniOSS

The miniOSS module provides features such as monitoring dashboard, user management, permission
and quota management, array monitoring, and system management.

4.4.2.1. Monitoring dashboard

The Monitoring Dashboard module allows you to view the overview, bucket watermark heatmap, user
quota watermark heat map, watermark trend, and network traffic trend of miniOSS in the system, and
download logs to your local computer.

Procedure

1. Inthe left-side navigation pane, choose Storage Operation Center > miniOSS > Monitoring
Dashboard.

2. Onthe page that appears, view the following information:

o Overview

This section displays the bucket information, user information, and health information of
minioSS.

In the Healt h section, if the value of Abnormal Bucket Watermark or Abnormal User Quota
Watermarks is greater than 0, the value is displayed in red.
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o Bucket Watermark Heat map
This section displays the bucket capacity usage.

The number of sections in Bucket Watermark Heatmap is the same as the value of Buckets in
Overview. Buckets in different statuses are displayed in different colors:

Green indicates that the bucket works properly.

Yellow indicates that the bucket has a warning.

Red indicates that the bucket has an exception.

Dark red indicates that the bucket has a fatal error.

Grey indicates that the bucket is disabled.

Move the pointer over a bucket section to view the usage of the bucket.

adb-testll

W AEL srmark Heatmap

adb-testll astbr-backuprds_ asrbr-rds-backup.__ autotest-035EH)_. 3

autotest-al 2739, autotest-b659a8_. autotest-ci3002_. autotest-oG9014. =

o User Quota Watermark Heat map
This section displays the user quota watermark information.

User quota watermark = Used capacity of all buckets of the user/Total capacity of all buckets of
the user. Buckets of different watermark values are displayed in different colors:

Green indicates that the bucket works properly.

Yellow indicates that the bucket has a warning.

Red indicates that the bucket has an exception.

Dark red indicates that the bucket has a fatal error.

m Grey indicates that the bucket is disabled.

Move the pointer over a section to view the percentage of capacity used by all buckets of a
user.

o Watermark Trend

This section displays the historical water levels and predicted water levels of a user or bucket.
Watermark represents the disk utilization, and watermark of a user indicates the disk usage of
buckets.

Data in the watermark trend comes from scheduled tasks in the system. The system stores or
updates data every 30 minutes.

Select a bucket oruser fromthe drop-down list to view the corresponding watermark trend.
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@ Note Youcanentera keyword of a Bucket Name or Username to performa fuzzy
search.

The top 10 datain terms of the bucket watermarks is displayed on the right. Click a bucket name
inthe top 10 data to view the watermark trend of the bucket on the left.

v ‘Watermark Trend

o Network Traffic Trend

This section displays the daily network traffic data of miniOSS in the last month, including the
normal network traffic, abnormal network traffic, average weekly network traffic, and average
monthly network traffic.

In the network traffic trend:

Green indicates that the network traffic is normal.

Yellow indicates that the network traffic is abnormal.

Orange indicates the average weekly network traffic.

Blue indicates the average monthly network traffic.

v Network Traffic Trend

3. (Optional)ln the Download Log section, clickDownload Log Package, and then use the
download URL to download logs to your local computer for subsequent review and analysis.

v Dowmboad Log

Download Log Package The packaging and dewnload of the logs take about fve minutes.

4.4.2.2. User management

The User Management module consists of User List, Bucket List of User, and Network Traffic Control.
You can use this module to view user information, network traffic bandwidth, and the list of user
buckets.

Procedure
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1. Inthe left-side navigation pane, choose Storage Operation Center > miniOSS > User
Management.

2. Onthe page that appears, performthe following operations:
o View the user information
By default, all users (including the administrator and common users) are displayed in the list.

Click View All inthe Actions column corresponding to a user. In the dialog box that appeatrs,
view the SecretKey of the user.

Inthe User List section, enterthree characters of the username, such as def, and then press the
Enter key or click the search icon. This section shows information such as the username, user role,
Accesskey, and network traffic bandwidth, of the user that meets the search condition.

@ Note Afterthe search, to view all the users in the list, click Refresh.

o View the bucket information of a user

Click a username in the User List section. View the bucket information, including the bucket
name, bucket ACL, user ACL, quota, and bucket creation time, of the user in the Bucket List of
User section.

Inthe Bucket List of User section, enter five characters of the bucket name, such as atest, and
then press the Enter key or click the search icon. The information of the bucket that meets the
search condition is displayed.

® Note Afterthe search, to view all the information of all buckets, click Refresh.

“ Bucket List of User ( Current L
Fuzzy Search:

Buckst Name

adb-test0]

o Add a bucket fora common user
) Notice You can add a bucket only fora common user, instead of for an administrator.

Find the common user for whom you are about to add a bucket inthe User List section, and
then clickthe username. In the Bucket List of User section, click Add. In the dialog box that
appears, select the bucket and User ACL, enterthe quota, and then click OK.

@ Note Enteran integer from 0 to 4094 as the quota.
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Allocate Bucket

Cancel

o View the networktraffic bandwidth of a user

Find the user whose network traffic bandwidth you are about to view in the User List section,
and then click the username. View the network traffic bandwidth of the userin the Network
Traffic Control section.

Modify the network traffic bandwidth of a user

Find the user whose network traffic bandwidth you are about to modify in the User List section,
and then click the username. In the Network Traffic Control section, clickModify to modify
the network traffic bandwidth of the user, and then click Save. The traffic bandwidth value
must be 0 or a positive integer.

v Metwork Traffic Contral

Network Traffic Bandwidth

4.4.2.3. Permission and quota management

The Permission/Quota Management module allows you to view the bucket list and user list of bucket,
and add, modify, and delete a bucket.

Procedure

1. Inthe left-side navigation pane, choose Storage Operation Center > miniOSS >
Permission/Quota Management.

2. Onthe page that appears, performthe following operations:

o View the bucket information

By default, all the buckets are displayed in the bucket list. In the Bucket List section, you can
view the basic information, including the bucket name, bucket ACL, quota, and network traffic
bandwidth, of all the buckets.

Enter a keyword of the bucket name in the search box in the upper-left corner, and then press
the Enter key or click the search icon. The information of the bucket that meets the search
condition is displayed.

@ Note Afterthe search, to view all the buckets in the list, click Refresh.
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o Add a bucket

In the Bucket List section, click Add. In the dialog box that appears, enter the bucket name, and
then click OK. The bucket name must be 3 to 63 characters in length. It can contain only
lowercase letters, digits, hyphens (-), and cannot start or end with a hyphen (-).

o Modify a bucket

In the Bucket List section, click Modify in the Actions column corresponding to a bucket. Inthe
dialog box that appears, modify the bucket ACL, quota, and network traffic bandwidth, and
then click OK.

o Delete a bucket

In the Bucket List section, click Delete inthe Actions column corresponding to a bucket. Inthe
dialog box that appears, click OK.

o View the userinformation of the userto which a bucket belongs

In the Bucket List section, click a bucket name to view the user information related to the
bucket inthe User List of Bucket section.

Enter a keyword of the username in the search box in the upper part of the page, and then press
the Enter key or click the search icon. The information of the user that meets the search
condition is displayed.

@ Note Afterthe search, to view the information of all the users, click Refresh.

4.4.2.4. Array monitoring
The Array Monitoring module allows you to view the running status of each device.

Procedure

1. Inthe left-side navigation pane, choose Storage Operation Center > miniOSS > Array
Monitoring.

2. View the running status of each device.
By default, you can view the status information of all devices.

The device types include rack, controller, hard drive, rack battery, power supply unit (PSU), fan, FC
port, iSCSI port, SAS port, USB port, cluster node, cluster system, block storage, volume
Information, storage pool information, host, NFS service, CIFS service, FTP service, and file system.
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Amay Monitoring goto the amay GUR

Values in different colors indicate different states:

o Green indicates that the device is online or is running normally.
o Yellow indicates that the device is offline.

o Red indicates that the device has an exception.

In the upper part of the page, click Click to go to the array GUI.

4.4.2.5. System management

The System Management module allows you to modify the bucket watermark threshold and user
watermark threshold.

Procedure
1. Inthe left-side navigation pane, choose Storage Operation Center > miniOSS > System
Management.

2. Onthe page that appears, performthe following operations:
o Modify the bucket watermark threshold
a. Inthe Bucket Watermark Threshold section, click Modify.

b. Enter a positive number less than or equalto 100 as the warning value, error value, and fatal
error value. Make sure that the warning value is less than the error value which is less than

the fatal error value.
c. ClickSave.
o Modify the user watermark threshold
a. Inthe User Watermark Threshold section, clickModify.

b. Enter a positive number less than or equalto 100 as the warning value, error value, and fatal
error value. Make sure that the warning value is less than the error value which is less than

the fatal error value.

c. ClickSave.
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5.0perations tools
5.1. Products

The Products module allows you to click operations and maintenance services of other products onthe
cloud platform and ISV access configurations to go to the corresponding page.

5.1.1. Product list

On the Product List page, you can go to the corresponding operations and maintenance page of a
product or ISV page by using Single Sign-0n (S50) and redirection.
Prerequisites

To access the ISV page, make sure that the ISV access information is configured onthe ISV Access
Configurations page. For more information about how to configure the ISV access information, see
Configure the ISV access information.

Context

Afteryou log onto the Apsara Stack Operations (ASQ) console, you can view 0O&M icons of different
products and different ISV icons on the Product List page based on your permissions. An operations
system administrator can view all the 0&M components of the cloud platform.

The read and write permissions for product 0O&M are separated. Therefore, the system can dynamically
assign different permissions based on different roles.

Procedure

1. Inthe left-side navigation pane, choose Products > Product List.

2. Onthe Product List page, you can view the 0&M icons of different products and ISV icons based
on your permissions.

5.1.2. ISV access configurations

The ISV Access Configurations module allows you to configure, modify, and delete the ISV access
information.

5.1.2.1. Configure the ISV access information

You can configure the ISV access information in the system based on business needs. Then, you can click
anicon onthe product list page to access the corresponding ISV page.
Procedure

1. Inthe left-side navigation pane, choose Products > ISV Access Configuration.

2. Inthe upper part of the page, click Add.

3. Inthe Add pane, configure the ISV access information.

> Document Version: 20210128 79



Operations and Maintenance Guide-
Operations tools

salf cnneimengisvi-ddl

1SV Access Configurations

Enter Name

© 2009-2019 Alibaba Cloud Computing Limited. AN rights reserved.

The following table describes the parameters.

Parameter Description
Name The name of the ISV to be accessed.
Key Typically, enter an identifier related to the ISV business as the key.

Select the icon displayed on the Product List page for the ISV to

Icon be accessed.
Level-one Category and The category to which the ISV to be accessed belongs on the
Level-two Category Product List page.
Usage The function of the ISV to be accessed.
Access Link The address of the ISV to be accessed.
Description The description related to the ISV to be accessed.
4. ClickAdd.
Result

You can view the added ISV icon in the Product List page by choosing Products > Product List. Click
the icon and then you can go to the corresponding page.

5.1.2.2. Modify the ISV access information

If the ISV information is changed, you can modify the ISV access information.

Procedure

1. Inthe left-side navigation pane, choose Products > ASV Access Configuration.

2. (Optional)in the search box on the page, enter the ISV name, and then click Query. Fuzzy search is
supported.
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5.

. Find the ISV whose access information is to be modified. Click Modify in the Actions column.

1SV Access Configurations

. Inthe Madify pane, modify the name, key, icon, level-one category, level-two category, usage,

access link, or description of the ISV.

Click Modify.

5.1.2.3. Delete the ISV access information

You can delete the ISV access information added in the system based on business needs.

Procedure

1.
2.

3.
4,

In the left-side navigation pane, choose Products > ISV Access Configuration.

(Optional)in the search box on the page, enterthe ISV name, and then click Query. Fuzzy search is
supported.

Find the ISV whose access information is to be deleted. Click Delete in the Actions column.

In the message that appears, click OK.

Result

The deleted ISV will no longer be displayed in the Product List.

5.

2. NOC

Network Operation Center (NOC) is an all-round operations tool platformthat covers the whole
network (virtual network and physical network).

5.2.1. Network topology

The Network Topology tab allows you to view the physical network topology.

Procedure

1.
2.

In the left-side navigation pane, choose NOC > Dashboard.

Onthe Network Topology tab, view the physical networktopology of a physical data center.

You canset Topology Type to Standard Topology or Dynamic Topology.

® Note

The colors of connections between network devices indicate the connectivity between the
network devices:

o Green: The link works properly.
o Red: The link has an error.

o Grey: The linkis inactive.
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By default, if Topology Type is set to Standard Topology, the Refresh Alert switch is turned
on. You can turn off Refresh Alert, and then devices or link status in the topology are not
updated after new alerts are triggered.
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3. Inthe topology, double-click a connection between two devices to view the links and alerts
between the two devices.

4. Inthe topology, double-click a physical network device to view the basic information and node
alerts of the device on the right.

5.2.2. Resource management

The Resource Management module is used to manage network-related resources, including the
information of physical network element devices, virtual network products, and IP addresses.

5.2.2.1. Device management

The Device Management page displays the basic information, running status, traffic monitoring, and
logs of physical network element devices, and allows you to configure the collection settings of
network devices.

5.2.2.1.1. View the network monitoring information

The Network Monitoring tab allows you to view the basic information, running status, and traffic
monitoring of Apsara Stack physical network devices and check the health status of network devices in
a timely manner.

Procedure

1. Inthe left-side navigation pane, choose NOC > Resource Management > Network Elements.

2. Inthe Device Management page, clickthe Network Monitoring tab.
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3. Performthe following operations:

o View the basic information, ping status, and SNMP status of physical network devices in Apsara
Stack.

@ Note You can also click Export to CSV to export network device information to your
local computer.

If a device has a business connectivity or gateway connectivity problem, the value in the Ping
Status column or SNMP Status column turns from green to red. The operations personnel are
required to troubleshoot the problem.

o Inthe search box in the upper-right cormner, enter the device name or IP address to search forthe
monitoring information of a specific device.

o View the port information and alert information of a device.
a. Click a device name, or click View in the Det ails column corresponding to a device.

b. View the port list, port working status, and other link information of the device inthe Port
column.

c. View the alert information of the device inthe Alert Info column.

During routine O&M, pay attentionto the alert list of the device. Typically, if no datais
displayed in the Alert Info column, it indicates that the device is operating normally.

If alert events occur, unrecovered alert events are displayed in the list. You must handle
these exceptions in time. After you handle exceptions, the alert events are automatically
cleared fromthe list.

o View the traffic information of a device for a specified port and time range.
a. Click a device name, or click View in the Det ails column corresponding to a device.

b. Search forthe port that you are about to view by using the search box in the upper-right
corner of the Part section. Click View in the Details column corresponding to the port.

Operation Status 2

c. Select atime range on the right, and then click Search to view the traffic in the selected
time range.

You can select 5MIN, 30MIN, T1H, or 6H in the Quick Query section to view the traffic within 5
minutes, 30 minutes, 1 hour, or 6 hours.
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5.2.2.1.2. View logs

The Syslogs tab allows you to view logs of physical network element devices, providing necessary data
forfault location and diagnosis information collection if a fault occurs.

Context

During the daily inspection, you can search for logs generated by a specific network device during a
specific time range on the Syslogs tab.

Procedure

1. Inthe left-side navigation pane, choose NOC > Resource Management > Network Elements.
2. Onthe Device Management page, click the Syslogs tab.

3. Inthe upper-right corner of the tab, select a device name fromthe drop-down list, select a time
range, and then click Search to check whether the device has generated system logs in the
specified time range.

If the device has a configuration exception or does not have any generated logs for the specified
time range, no search results will be returned.

Network Monitoring \ Collection Settings

1302019 21:38:20 - 1l

4. (Optional)You can filter the search results based on the log keyword.

5. (Optional)Click Export to CSV inthe upper-right corner o to export the search results to your local
computer.

5.2.2.1.3. Collection settings

The Collection Settings tab allows you to configure the collection interval of physical network
element devices and manage OOB network segments.

5.2.2.1.3.1. Modify the collection interval

You can modify the collection interval to adjust the time interval of collection.

Procedure

1. Inthe left-side navigation pane, choose NOC > Resource Management > Network Elements.
2. Onthe Device Management page, clickthe Collection Settings tab.

3. Inthe Collection Interval Settings section, modify the values.
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@ Note To cancel your modification before submission, click Reset inthe upper-right
cornerto reset the collection interval to the previous version.

4. Click Submit. One minute later, the modified collection interval of the network device information
takes effect.

5.2.2.1.3.2. Add an O0OB network segment

If this is the first time you are using the Network Elements feature of Network Operation Center (NOC),
you must add the device loopback network segment planned by the current Apsara Stack network
device, which is typically the network segment of the netdev.loopbackfield in the IP address planning
list.

Context

The O0B Network Segments section is used to configure the management scope of a physical network
element device. Typically, operations engineers are required to add the loopback network segment
where the network device to be managed resides.

In the Apsara Stack scenario, a loopback network segment is used to configure the management scope
of a physical network element device. To expand the network and the loopback network segment, you
must add the network segment involved in the expansion to the management scope. The procedure to
add an expanded network segment is the same as that used to add the loopback network segment for
the first time. Then, you can search for the network segment of the managed device on this page.

Procedure

1. Inthe left-side navigation pane, choose NOC > Resource Management > Network Elements.
2. Onthe Device Management page, clickthe Collection Settings tab.

3. Inthe lower part of the 0OB Network Segmentssection, click Add Network Segment.

4

. Inthe Add Network Segment dialog box, enter the network segment that contains the mask
information and subnet mask, and select an IDC.

Add Network Segment

5. Click Submit. The initial data entry is completed.

To modify or delete an O0B network segment, find it in the list, and then click Edit or Delete inthe
Actions column.

5.2.2.1.3.3. View the O0B network segment information

You can search for and view the network segment inf ormation of your managed device.
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Procedure
1. Inthe left-side navigation pane, choose NOC > Resource Management > Network Elements.
2. Onthe Device Management page, clickthe Collection Settings tab.

3. Inthe OOB Network Segments section, click Refresh in the upper-right corner of the section.

OB Network Segments

Q

Management Network Segment Subnet Mask c Created At Modified At

265.255.255.0 Aug 18, 2020, 18:34:13 Aug 18, 2020, 18:34:13

Add Network Segment

4. Inthe list, view the network segment information of your managed device.

@ Note You can searchforthe information of a specific network segment by entering a
keyword in the search box.

5.2.2.2. View the instance monitoring information

The Instance Monitoring tab allows you to view the basic information and water level of aninstance,
including the bps and pps.

Procedure

1. Inthe left-side navigation pane, choose NOC > Resource Management > Server Load
Balancers.

2. Clickthe Instance Monitoring tab.

3. Select the cluster where the target instance resides fromthe cluster drop-down list. Enter the VIP
address that you are about to search forin the field, and then click Search.

4. View the water level data of the VIP address. Select a time range, and then click Search.
Alternatively, select 5MIN, 30MIN, TH, or 6H in the Quick Query section to view the operating water
level graph of the VIP address in a specific time range.

5.2.3. Alert management

The Alert Management module provides you with the real-time alert dashboard, history alert
dashboard, and the alert settings function.

5.2.3.1. View and process current alerts

You can view and process current alerts on the Current Alerts tab.

Procedure
1. Inthe left-side navigation pane, choose NOC > Alert Management > Alert Dashboard.

2. Clickthe Current Alerts tab.

3. Enter a keyword in the search box in the upper-right corner, and then click Search.Alerts that meet
the search conditions are displayed.
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4.
5.

6.

7.

(Optional)You can filter the search results by device name, device IP address, or alert name.

Click Det ails in the Details column corresponding to an alert to view detailed information about
the alert.

Find the reason why the alert is triggered and then process the alert.

o If the alert does not affect the normal operation of the system, you can clickIgnore inthe
Actions columnto ignore the alert.

o If the alert is no longer significant, you can click Delete in the Actions column to delete the
alert.

Afterthe alert is processed, you can search forit onthe History Alerts tab.

(Optional)Click Export to SCV to export the alert information to your local computer.

5.2.3.2. View historical alerts

You can view historical alerts on the History Alerts tab.

Procedure

1.
2.
3.

5.

In the left-side navigation pane, choose NOC > Alert Management > Alert Dashboard.

Clickthe History Alerts tab.

Select Alert Source, Alerting IP Address, Alerting Device, Alert Name, Alert ttem, or Alerting Instance
fromthe drop-down list, and then enter a keyword in the field. Select a time range, and then click
Search.Alerts that meet the search conditions are displayed.

. Click Det ails in the Det ails column corresponding to an alert to view detailed information about

the alert.

(Optional)Click Export to SCV to export the alert information to your local computer.

5.2.3.3. Add a trap

If the initially configured trap subscription does not meet the monitoring requirements, you can add a
trap for monitoring match.

Context

The trap in this topic is the Simple Network Management Protocol (SNMP) trap. SNMP trap is a part of
SNMP and a mechanismthat devices being managed (here refers to network devices such as switches
and routers) send SNMP messages to the NOC monitoring server. If an exception occurs on the side
being monitored, namely the switch monitoring metrics have an exception, the SNMP agent running in a
switch sends an alert event to the NOC monitoring server.

Procedure

1.

In the left-side navigation pane, choose NOC > Resource Management > Alert Configuration.

2. Onthe Alert Settings page, click Configure Trap.

3.

Inthe Configure Trap dialog box, configure the parameters.
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Configure Trap

The following table describes the parameters.
Parameter Description Example

linkdown or BGPneighbor down.

Trap Name The name of the alert event. .
You can customize the value.
.1.3.6.1.4.1.25506.8.35.12.1.12

Trap OID The OID of the alert event. Configure the value based on the
device document. You cannot
customize the value.

Trap Type The type of the alert event. None

The index ID of the alert item.

This value is the KV information in
the trap message, which is used
to identify the alert object.
Trap Index Typically, this value can be an API None
name, protocol ID, or index ID.

Configure the value based on the
device document. You cannot
customize the value.

The message of the alert item.

This value is the KV information in
the trap message, which is used
to identify the alert data.
Typically, this value can be the
additional information of the alert
Trap Msg item, such as a system message None
or a message indicating the
location of the state machine or
the current status.

Configure the value based on the
device document. You cannot
customize the value.
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Parameter Description Example

Specifies whether the alert is of

N
the fault type or the event type. one

Alert Type

Specifies whether the alert has an
event alert.

If Alert Type is set to Fault and
Association the alert has an associated alert, None

set Association to Event Alert and

then add the trap of the

associated alert.

4. ClickSubmit.Afterthe configuration is submitted, the system checks whether the values of Trap
OID and Trap Name are the same as the existing ones. If not, the configuration of the trap is
complete.

Afterthe trap is added, the alert events of the configured Trap OID are monitored and displayed
onthe Current Alerts and Alert History tabs inthe Alert Management module.

5.2.3.4. View traps

You can view traps configured in the current system.

Procedure

1. Inthe left-side navigation pane, choose NOC > Alert Management > Alert Configuration.

2. Enter a keyword in the search box in the upper-right corner, and then click Search.

@ Note Afterthe search results are displayed, you can click Export to CSV inthe upper-
right corner to export the trap information to your local computer.

Alert Settings

Al () By Trap Name () By Trap Type () By OIDD. Enter a keyword

[o} Configure Trap

Trap Name: Trap OID Trap Type Event Alert Alert Type

bopEstablishedNotiication protocol Yes Event Detals  Delete

bgpBackwardTransNetification protocol Yes Detais  Delete

hh3cStackPortLinkStatusChange device Detais  Delete

hh3cl pbkdiTrapLoopbacked other s aul Detals  Delete

3. (Optional)You canfilter the search results by trap name, trap type, or OID.

4. Move the pointer over Det ails in the Actions column corresponding to a trap to view detailed
information about the trap.

@ Note ffa trap is no longer needed, you can click Delete inthe Actions column
corresponding to the trap.
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5.3. Task Management

The system allows you to run operations scripts on the cloud platform, which reduces your actions by
using command lines, lowers misoperations, and improves the security and stability of the cloud
platform.

5.3.1. Overview
The Task Management module has the following functions:

e Supports viewing task overview and creating tasks quickly.

e Supports the following four methods to run tasks: manual execution, scheduled execution, regular
execution, and advanced mode.

e Supports the breakpoint function, which allows a taskto stop between its two scripts and wait for
manual intervention.

e Supports searching for tasks by name, status, and created time.

e Supports uploading the .tar package as the script.

5.3.2. View the task overview

The Task Overview page shows the overall running conditions of tasks in the system. You can also
create ataskon this page.

Procedure
1. Inthe left-side navigation pane, choose Task Management > Task Overview.

The Task Overview page appears.

Tasks To Be Intervensd
Task Name sk n Start Tane

testll test Dec 30. 2019, 10:58:45

Running Stetus in Last 7 Days

Running Tasks(Running fime more than 1 day)

Task Name Task Description Ta

2. You can performthe following operations:

o Inthe Dashboard section, view the number of tasks that are inthe Pending for Intervention,
Running, Failed, or Completed state inthe system.

Click a state or number to view the task list of the corresponding state.

o Inthe Create Task section, clickCreate Task to create an operations task.
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For more information about how to create a task, see Create atask.

o If atask has a breakpoint and reaches the breakpoint, the task stops and waits for manual
confirmation. You can view and process tasks that require manual intervention in the Tasks To
Be Intervened section.

o Inthe Running Status in Last 7 Days section, view the running trend of tasks and whether
tasks are successful within the last seven days.

o Inthe Running Tasks section, view tasks running wit hin the last 24 hours.

5.3.3. Create a task

You can make regular modifications as tasks to runin the ASO console.

Procedure

1. Inthe left-side navigation pane, choose Task Management > Task Management.
2. ClickCreate.

3. Inthe dialog box that appears, configure the parameters.

Create Task

Parameter Description
Task Name The name of the operations task.
Task Description The description of the operations task.
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Parameter Description

The task target. You can use one of the following methods to
configure the target group:

o Select the product, cluster, service, server role, and virtual
machine (VM) or physical machine in sequence.

o Select a product. Enter the VM or physical machine in the field
Target Group and then press the Enter key. You can enter multiple VMs or
physical machines in sequence.

o Click the . icon next to Target Group. In the dialog box that

appears, enter the target group, with one VM or physical machine
in one line. Click OK.

Optional. This option appears after you specify the target group.

If Execution Batch is not specified, Target Group is displayed in
the Target Group column, which can be viewed by choosing Task
Management > Task Management. If you specify Execution
Batch, Batch Execution Policy is displayed in the Target Group
column.

You can set Execution Batch to one of the following values:
o Default Order

By default, if the number of machines is less than or equal to 10,
the machines are allocated to different batches, with one
Execution Batch machine in batch 1, one machine in batch 2, two machines in
batch 3, three machines in batch 4, and the other machines in
batch 5. You can change the number of machines in each batch.

By default, if the number of machines is greater than 10, the
machines are allocated to different batches, with one machine in
batch 1, three machines in batch 2, five machines in batch 3, N/3-
1 (an integer) machines in batch 4, N/3-1 (an integer) machines in
batch 5, until all of the machines are allocated. N is the total
number of servers in the cluster. You can change the number of
machines in each batch.

o Single-Machine Order: By default, each batch has one machine.
You can change the number of machines in each batch.
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Parameter Description

If Execution Batch is specified, Execution Method can only be
set to Manual Execution.

If Execution Batch is not specified, you can select one of the
following execution methods:

o Manual Execution: You must manually start the task. With
Manual Execution specified, you must click Start in the
Execution Method Actions columnto run the task after the task is created.

o Scheduled Execution: Select the execution time. The task
automatically starts when the execution time is reached.

o Regular Execution: Select the time interval and times to run the
task. The task starts again if the execution condition is met.

o Advanced: Configure the command to run the task periodically.

Click Add Script. Select one or more .tar packages to upload the
script file. After the upload, you can delete and re-upload the
script.

Add Script After you upload the script, if Execution Method is set to Manual
Execution, you must specify whether to enable Intervention
Required. If manual intervention is enabled, the task will stop and
wait for manual intervention after you run the script.

4. ClickCreate.

Result

The created task is displayed in the task list.
5.3.4. View the execution status of a task

After ataskstarts, you can view the execution status of the task.

Procedure

1. Inthe left-side navigation pane, choose Task Management > Task Management.

2. (Optional)Enter the task name, select the task status, start date, and end date, and then click
Query to search for tasks.

3. Find the task that you want to view, and then click Target Group orBatch Execution Policy in
the Target Group column.

@ Note If Execution Batch is not selected when you create a task, Target Group is
displayed inthe Target Group column. If you select Execution Batch when you create a
task, Batch Execution Policy is displayed in the Target Group column.
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jow 11, 2018, 14:44:04

4. Inthe dialog box that appears, view the task execution status based on the machine color. Click a
machine to view the execution results of the task.

Batch Execution Policy

Batchl Batch2 Batch3

5.3.5. Start a task

If you select Manual Execution when you create a task, you must manually start the task afterit is
created.

Procedure

1. Inthe left-side navigation pane, choose Task Management > Task Management.

2. (Optional)Enter the task name, select the task status, start date, and end date, and then click
Query to search for tasks.

3. Find the taskthat you are about to start, and then click Start inthe Actions column.
4. Inthe dialog box that appears, select the batches to start, and then click Start.

For a new task, afteryou click Start forthe first time, the systemwill indicate that the task s
started. The virtual machines (VMs) or physical machines in batch 1 start to run the task. Click Start
again and you can select VMs or physical machines in one or more batches to run the task.

If the task has enabled Intervention Required, you must intervene the script after you clickStart.
The Task Status turns to Pending for Intervention, and you can continue to run the task only
by clicking Continue inthe Actions column.
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@Peniing for Inervention

5.3.6. Delete a task

You can delete tasks that are no longer needed.

Procedure

1. Inthe left-side navigation pane, choose Task Management > Task Management.

2. (Optional)Enter the task name, select the task status, start date, and end date, and then click
Query to search forthe task.

3. Find the taskto be deleted, and then click Delete inthe Actions column.

4. Inthe message that appears, click OK.

5.3.7. Process tasks to be intervened

If atask reaches a breakpoint, the task will stop and wait for manual confirmation. The task will
continue only after receiving manual confirmation.
Procedure

1. Inthe left-side navigation pane, choose Task Management > Task Overview.

2. Inthe Tasks To Be Intervened section, find the taskto be intervened, and then click Det ails in
the Actions column.

Tasks To Be Intervened

Task Mame Task Description

testl st Dec 30, 2019, 10:58:45

3. Onthe Task Details tab, check the information and then click Continue to continue to runthe
task.

5.3.8. Configure the XDB backup task

The XDB Backup module allows you to configure the XDB data backup without using command lines.
You can configure and modify the backup task on the XDB Backup page to regularly back up platform
data and back up data in real time.

Procedure

> Document Version: 20210128 95



Operations and Maintenance Guide-
Operations tools

1. Inthe left-side navigation pane, choose Task Management > Commonn Tasks > XDB Backup.

2. Onthe XDB Backup page, configure the XDB backup task information.
Parameter Description

Task Name The name of the XDB backup task. By default, the name is
xdbBackup and cannot be modified.
Task Description The description of the XDB backup task.

Required. The target of the XDB backup task. You can use one of
the following methods to configure the target group:

o Select from the drop-down list by selecting a product, cluster,
service, server role, and virtual machine (VM) or physical
machine.

Target Group © Select a product. Enter the VM or physical machine in the field
and press the Enter key. You can enter multiple VMs or physical
machines in sequence.

o Click the . icon next to Target Group. In the dialog box that

appears, enter the target group, with one VM or physical machine
in one line. Click OK.

Optional. This option appears after you specify the target group.
You can set Execution Batch to one of the following options:
o Default Order

By default, if the number of machines is less than or equal to 10,
the machines are allocated to different batches, with one
machine in batch 1, one machine in batch 2, two machines in
batch 3, three machines in batch 4, and the other machines in
batch 5. You can adjust the batch for machines as needed.

By default, if the number of machines is greater than 10, the
machines are allocated to different batches, with one machine in
batch 1, three machines in batch 2, five machines in batch 3, N/3-

Execution Batch 1 (an integer) machines in batch 4, N/3-1 (an integer) machines in
batch 5, until all of the machines are allocated. N is the total
number of servers in the cluster. You can adjust the batch for
machines as needed.

o Single-Machine Order: By default, each batch has one machine.
You can adjust the batch for machines as needed.

If Execution Batch is not specified, Execution Batch will be
disabled by default. Target Group is displayed inthe Target
Group column in the task list, which can be viewed by choosing
Task Management > Task Management. If Execution Batch is
specified and saved, Execution Batch will be enabled
automatically, and Batch Execution Policy is displayed in the
Target Group column.
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Parameter Description

If Execution Batch is specified, Execution Method can only be
set to Manual Execution.

If Execution Batch is not enabled, you can select one of the
following execution methods:

o Manual Execution: You must manually start the task. With
Manual Execution selected, you must click Start in the Actions
column to run the task after the task is created.

o Scheduled Execution: Select the execution time. The task

Execution Method automatically runs when the execution time is reached.

o Regular Execution: Select the time interval and times to run the
task. If the execution condition is met, the task is run again.

o Advanced: Enter the crontab expression to configure the
command to run the task periodically.

For example, 02020 **? indicates that the task runs at 20:20
every day.

Execution Scripts By default, the system automatically loads the XDB backup script.

3. ClickCreate.

You can view the created XDB task in the task list by choosingT ask Management > Task
Management. The system automatically runs the XDB backup task when the task execution
condition is met. If Execution Method of the XDB backup task is specified as Manual Execution,
start the backup task based on the procedures described in O&M tools > Task management >
Start a task.

@ Note Afterthe XDB backup taskiis created, to modify the information of the backup
task, you can click Modify in the lower part of the XDB Backup page.
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After the XDB backup task is complete, operations engineers can view the backup file of each
instance under the /alidata/xdb-backup/instance name directory on the backup server. The
backup file name is in the format of instance name-timestamp (specific to day).tar. The temporary
backup information under the /alidata/xdb-backup-tmp directory of the temporary backup folder
is deleted automatically.

5.4. Apsara Infrastructure Management
Framework

5.4.1. Old version

5.4.1.1. What is Apsara Infrastructure Management

Framework?

This topic describes what Apsara Infrastructure Management Framework is fromthe aspects of core
functions and basic concepts.

5.4.1.1.1. Overview

Apsara Infrastructure Management Framework is a distributed data center management system, which
manages applications on clusters containing multiple machines and provides the basic functions such as
deployment, upgrade, expansion, contraction, and configuration changes.

Apsara Infrastructure Management Framework also supports monitoring data and analyzing reports,
which facilitates users to perform one-stop Operation & Maintenance (0&M) control. Based on the
Apsara Infrastructure Management Framework services, automated 0&M is implemented in the large-
scale distributed environment, which greatly improves the operations efficiency and enhances the
system availability.

Apsara Infrastructure Management Framework is mainly composed of TianjiMaster and TianjiClient.
Apsara Infrastructure Management Framework installs TianjiClient as the agent on machines it manages.
Then, TianjiMaster accepts and issues the upper-layer instructions to TianjiClient for execution. In the
upper layer, Apsara Infrastructure Management Framework is divided into different components based
on different functions, and then provides APl server and portal for external use.

Core functions

e Networkinitialization in data centers

e Serverinstallation and maintenance process management
e Deployment, expansion, and upgrade of cloud products
e Configuration management of cloud products

e Automatic application for cloud product resources

e Automatic repair of software and hardware faults

e Basic monitoring and business monitoring of software and hardware

5.4.1.1.2. Basic concepts
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Before using Apsara Infrastructure Management Framework, you must know the following basic
concepts for a better understanding.

project

A collection of clusters, which provides service capabilities for external entities.

cluster

A collection of physical machines, which logically provides services and is used to deploy project
software.

e A cluster canonly belong to one project.
e Multiple services can be deployed on a cluster.

service

A set of software, which provides relatively independent functions. A service is composed of one or
more server roles and can be deployed on multiple clusters to form multiple sets of services and provide
the corresponding service capabilities. For example, Apsara Distributed File System, Job Scheduler, and
Apsara Name Service and Distributed Lock Synchronization System are all services.

service instance

A service that is deployed on a cluster.

server role

One or more indivisible deployment units into which a service can be divided based on functions. A
server role is composed of one or more specific applications. If a service is deployed on a cluster, all the
server roles of the service must be deployed to machines of this cluster. Multiple server roles, such as
PanguMaster and TianjiClient, can be deployed on the same server.

server role instance

A server role that is deployed on a machine. A server role can be deployed on multiple machines.

application

Applications correspond to each process-level service component in a server role and each application
works independently. The application is the minimum unit for deployment and upgrade in Apsara

Inf rastructure Management Framework, and can be deployed to each machine. Generally, an application
is an executable software or Docker container.

If a serverrole is deployed on a machine, all applications in the server role must be deployed to this
machine.
rolling

Each time when a user updates configurations, Apsara Infrastructure Management Framework upgrades
services and modifies the cluster configurations based on the updated configurations. T his process is
called rolling.

service configuration template
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Some configurations are the same when services are deployed on clusters. A service configuration
template can be created to quickly write the same configurations to different clusters. The service
configuration template is basically used for large-scale deployment and upgrade.

associated service template

A template.conf file that exists in the configurations. This file declares the service configuration
template and its version, of which the configuration is used by the service instance.

final status

If a clusteris in this status, all hardware and software on each of its machines are normal and all
software are in the target version.

dependency

The dependency between server roles in a service defines that server roles with dependencies run tasks
or are upgraded based on the dependency order. For example, if A depends on B, B is upgraded first. A
starts to be downloaded after B is downloaded successfully, and upgraded after B is successfully
upgraded. (By default, the dependency does not take effect for configuration upgrade.)

upgrade

A way of aligning the current status with the final status of a service. After a user submits the version
change, Apsara Infrast ructure Management Framework upgrades the service version to the target
version. With the server role as the processing unit, upgrade aims to update the versions of all machines
to the target version.

At the beginning, the final status and current status of the cluster are the same. When a user submits
the change, the final status is changed, whereas the current status is not. A rolling task is generated
and has the final status as the target version. During the upgrade, the current status is continuously
approximating to the final status. Finally, the final status and the current status are the same when the
upgrade is finished.

5.4.1.2. Log on to Apsara Infrastructure Management

Framework
This topic describes how to log on to Apsara Infrastructure Management Framework.

Prerequisites

e The URL of the ASO console, and the username and password used for logging onto the console are
obtained fromthe deployment personnel or an administrator.

The URL of the ASO console is in the following format: region-id.aso.intranet-domain-id.com.

e A browser is available. We recommend that you use the Google Chrome browser.

Procedure

1. Open your browser.

2. Inthe address bar, enter the URL region-id.aso.int ranet-domain-id.com and press the Enter key.
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Enter a user name

@ Note Youcanselect a language fromthe drop-down list in the upper-right corner of the
page.

3. Enteryourusername and password.

@ Note Obtain the username and password for logging on to the ASO console fromthe
deployment personnel or an administrator.

When you log onto the ASO console forthe first time, you must change the password of your
username as prompted.

To enhance security, a password must meet the following requirements:
o It must contain uppercase and lowercase letters.
o It must contain digits.

o [t must contain special characters such as exclamation points (1), at signs (@), number signs (#),
dollar signs ($), and percent signs (%).

o It must be 10 to 20 characters in length.
4. ClickLog On to gotothe ASO console.
5. Inthe left-side navigation pane, select Products.

6. Inthe product list, select Apsara Infrastructure Management Framework.

5.4.1.3. Web page introduction

Before performing Operation & Maintenance (O&M) operations on Apsara Infrastruct ure Management
Framework, you must have a general understanding of the Apsara Infrastructure Management
Framework page.

5.4.1.3.1. Introduction on the home page

Afteryou log onto Apsara Infrastructure Management Framework, the home page appears. T his topic
allows you to get a general understanding of the basic operations and functions of Apsara
Infrastructure Management Framework.

Log onto Apsara Infrastructure Management Framework. The home page appears, as shown in Home
page of Apsara Infrastructure Management Framework.

llmitmman immmm ~f A mvn hafunmtb i imd it M mn i mmmam it Fommnaa il
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For more information about the descriptions of functional areas on the home page, see Descriptions of

functional areas.

Descriptions of functional areas

Area

Top
1 navigation
bar

Description

® QOperations: the quick entrance of Operations & Maintenance (0&M)
operations, which allows operations engineers to quickly find the
corresponding operations and operation objects. This menu consists of
the following sections:

o Cluster Operations: performs O&M operations on and manages
clusters with the project permissions, such as viewing the cluster status.

o Service Operations: manages services with the service permissions,
such as viewing the service list information.

©o Machine Operations: maintains and manages all the machines in
Apsara Infrastructure Management Framework, such as viewing the
machine status.

e Tasks: Arolling task is generated after you modify the configurations in

the system. In this menu, you can view running tasks, history tasks, and the
deployment summary of clusters, services, and server roles in all projects.

e Reports: displays the monitoring data in tables and provides the function

of searching for different reports.

® Monitoring: effectively monitors metrics in the process of system

operation and sends alert notifications for abnormal conditions. This menu
includes the functions of displaying alert status, modifying alert rules, and
searching for the alert history.
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Area Description

o@;

o TJDB Synchronization Time: the generated time of the data that is
displayed on the current page.

o Final Status Computing Time: the computing time of the final-
status data that is displayed on the current page.

After data is generated, the system processes the data at maximum

Function speed. As an asynchronous system, Apsara Infrastructure Management
buttons in Framework has some latency. The time helps explain why the current data
2 the upper- results are generated and determine whether the current system has a
right corner problem.
o [=/ USRS In the English environment, click this drop-down list to switch
to another language.
e TR The logon account information. Click this drop-down list and
select Logout to log out of Apsara Infrastructure Management
Framework.
In the left-side navigation pane, you can directly view the logical structure of
Left-side the Apsara Infrastructure Management Framework model.
3 navigation You can view the corresponding detailed data analysis and operations by
pane selecting different levels of nodes in the left-side navigation pane. For more
information, see Introduction on the left-side navigation pane.
Displays the summary of related tasks or information as follows:
e Upgrade Task Summary: the numbers and proportions of running,
rolling back, and paused upgrade tasks.
® Cluster Summary: the numbers of machines, error alerts, operating
4 Home page system errors, and hardware errors for different clusters.
® Error Summary: the metrics for the rate of abnormal machines and the
rate of abnormal server role instances.
® Most-used Reports: links of the most commonly used statistics reports,
which facilitates you to view the report information.
Button
used to
collapse/ex If you are not required to use the left-side navigation pane when performing
5 pand the 0&M operations, click this button to collapse the left-side navigation pane
left-side and increase the space of the content area.
navigation
pane

5.4.1.3.2. Introduction on the left-side navigation pane
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The left-side navigation pane has three common tabs: C (cluster), S (service), and R (report). With some
operations, you can view the related information quickly.

Cluster

Fuzzy search is supported to search forthe clusters in a project, and you can view the cluster status,
cluster operations information, service final status, and logs.

Inthe left-side navigation pane, clickthe C tab. Then, you can:

e Enterthe cluster name in the search box to search for the cluster quickly. Fuzzy search is supported.
e Select a project fromthe Project drop-down list to display all the clusters in the project.

e Move the pointer over [fJ at the right of a cluster and then perform operations on the cluster as

instructed.
e Click a cluster and all the machines and services in this cluster are displayed in the lower-left corner.

Move the pointer over [fj at the right of a machine or service and then perform operations on the

machine or service as instructed.

e Clickthe Machine tab in the lower-left corner. Double-click a machine to view all the server roles in
the machine. Double-click a server role to view the applications and then double-click an application
to view the log files.

e C(Clickthe Service tab inthe lower-left corner. Double-click a service to view all the server roles in the
service. Double-click a server role to view the machines, double-click a machine to view the
applications, and double-click an application to view the log files.

e Double-click a log file. Move the pointer over [fj at the right of the log file and then select
Download to download the log file.
Move the pointer over a log file and then click View at the right of the log file to view the log details
based ontime. Onthe Log Viewer page, enter the keyword to search for logs.

Service

Fuzzy search is supported to search for services and you can view services and service instances.

In the left-side navigation pane, clickthe S tab. Then, you can:

e Enterthe service name in the search box to search for the service quickly. Fuzzy search is supported.

e Move the pointer over [fJ at the right of a service and then perform operations on the service as

instructed.
e C(lick a service and all the service instances in this service are displayed in the lower-left corner. Move

the pointer over [fj at the right of a service instance and then perform operations on the service

instance as instructed.

Report
Fuzzy search is supported to search for reports and you can view the report details.
In the left-side navigation pane, click the R tab. Then, you can:

e Enterthe report name in the search box to search forthe report quickly. Fuzzy search is supported.

e ClickAll Reports or Favorites to display groups of different categories in the lower-left corner.
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Double-click a group to view all the reports in this group. Double-click a report to view the report
details on the right pane.

5.4.1.4. Cluster operations

This topic describes the actions about cluster operations.

5.4.

1.4.1. View cluster configurations

By viewing the cluster configurations, you can view the basic information, deployment plan, and
configurations of a cluster.

Procedure

1. Log onto Apsara Infrastructure Management Framework.

2. Inthe top navigation bar, choose Operations > Cluster Operations.

The Cluster Operations page displays the following information:

(e]

Cluster
The cluster name. Click the cluster name to go to the Cluster Dashboard page.
Scale-Out/Scale-In

The number of machines or server roles that are scaled out orin. Clickthe linkto go to the Cluster
Operation and Maintenance Center page.

Abnormal Machine Count

The statistics of machines whose status is not Good in the cluster. Click the linkto go to the
Cluster Operation and Maintenance Center page.

Final Status of Normal Machines

Displays whet her the cluster reaches the final status. Select Clusters Not Final to display
clusters that do not reach the final status. Click the linkto go to the Service Final Status Query

page.
Rolling

Displays whether the cluster has a running rolling task. Select Rolling Tasks to display clusters
that have rolling tasks. Click the linkto go to the Rolling Task page.

3. (Optional)Select a project fromthe Project drop-down list and/or enter the cluster name in the
Cluster field to search for clusters.

4. Find the cluster whose configurations you are about to view and then click Cluster Configuration
inthe Actions column. The Cluster Configuration page appears.

For more information about the Cluster Configuration page, see Cluster configurations.

Cluster configurations

Category tem Description
Cluster The cluster name.
Project The project to which the cluster belongs.
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Category [tem

Clone Switch

Machines

Basic Information

Security Verification

Cluster Type

Service

Deployment Plan
Dependency Service

Service Information

Service Template

Monitoring Template

Machine Mappings

Software Version

Service Availability
Information Configuration

Deployment Plan

Description

o Mock Clone: The system is not cloned
when a machine is added to the cluster.

o Real Clone: The system is cloned when a
machine is added to the cluster.

The number of machines in the cluster. Click
View Clustering Machines to view the
machine list.

The access control among processes.
Generally, the non-production environment
uses the default configurations and does not
perform the verification. In other cases,
customize the configurations based on actual
requirements to enable or disable the
verification.

°© RDS
© NETFRAME

o T4: aspecial type that is required by the
mixed deployment of e-commerce.

o Default: other conditions.

The service deployed in the cluster.

The service that the current service depends
on.

Select a service from the Service
Information drop-down list and then the
configurations of this service are displayed.
The template used by the service.

The monitoring template used by the service.

The machines included in the server role of
the service.

The software version of the server role in the
service.

The availability configuration percentage of
the server role in the service.

The deployment plan of the server role in the
service.
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Category [tem Description

Configuration

. The configuration file used in the service.
Information

Server roles and the corresponding

Role Attribute
parameters.

5. ClickOperation Logs inthe upper-right cornerto view the release changes. For more information,
see View operation logs.

5.4.1.4.2. View the cluster dashboard

The cluster dashboard allows you to view the basic information and related statistics of a cluster.

Procedure

1. Log onto Apsara Infrastructure Management Framework.

2. You have two ways to go to the Cluster Dashboard page:
o Inthe left-side navigation pane, click the C tab. Move the pointer over [fj at the right of a cluster

and then select Dashboard.

o Inthe top navigation bar, choose Operations > Cluster Operations. On the Cluster
Operations page, clickthe cluster name.

3. Onthe Cluster Dashboard page, you can view the cluster information, including the basic
information, final status information, rolling job information, dependencies, resource information,
virtual machines, and monitoring information. For more information about the descriptions, see the
following table.

ltem Description
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ltem Description

Displays the basic information of the cluster as follows:

o Project Name: the project name.

o Cluster Name: the cluster name.

o IDC: the data center to which the cluster belongs.

o Final Status Version: the latest version of the cluster.

o Cluster in Final Status: whether the cluster reaches the final
status.

o Machines Not In Final Status: the number of machines that do not
reach the final status in the cluster when the cluster does not reach
the final status.

o Real/Pseudo Clone: whether to clone the system when a machine
Basic Cluster is added to the cluster.

Information . . .
o Expected Machines: the number of expected machines in the

cluster.

o Actual Machines: the number of machines in the current
environment.

o Machines Not Good: the number of machines whose status is not
Good in the cluster.

o Actual Services: the number of services that are actually deployed
in the cluster.

o Actual Server Roles: the number of server roles that are actually
deployed in the cluster.

o Cluster Status: whether the cluster is starting or shutting down
machines.

Machine Status Overview The statistical chart of the machine status in the cluster.

The numbers of machines that reach the final status and those that do

Machines in Final Status
not reach the final status in each service of the cluster.

Load-System The system load chart of the cluster.
CPU-System The CPU load chart.

Mem-System The memory load chart.

Disk_usage-System The statistical table of the disk usage.
Traffic-System The system traffic chart.

TCP State-system The TCP request status chart.

TCP Retrans-System The chart of TCP retransmission amount.
Disk_lO-System The statistical table of the disk input and output.
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ltem Description

Displays the service instances deployed in the cluster and the related
final status information.

[e]

[e]

Service Instances °

Service Instance: the service instance deployed in the cluster.
Final Status: whether the service instance reaches the final status.

Expected Server Roles: the number of server roles that the service
instance expects to deploy.

Server Roles In Final Status: the number of server roles that reach
the final status in the service instance.

Server Roles Going Offline: the number of server roles that are
going offline in the service instance.

Actions: Click Details to go to the Service Instance Information
Dashboard page. For more information about the service instance
dashboard, see View the service instance dashboard.

Displays the upgrade tasks related to the cluster.

o

o

Upgrade Tasks

Cluster Resource
Request Status

Cluster Name: the name of the upgrade cluster.

Type: the type of the upgrade task. The options include app (version
upgrade) and config (configuration change).

Git Version: the change version to which the upgrade task belongs.
Description: the description about the change.

Rolling Result: the result of the upgrade task.

Submitted By: the person who submits the change.

Submitted At: the time when the change is submitted.

Start Time: the time to start the rolling.

End Time: the time to finish the upgrade.

Time Used: the time used for the upgrade.

Actions: Click Details to go to the Rolling Task page. For more
information about the rolling task, see View rolling tasks.

Version: the resource request version.

Msg: the exception message.

Begintime: the start time of the resource request analysis.
Endtime: the end time of the resource request analysis.
Build Status: the build status of resources.

Resource Process Status: the resource request status in the
version.
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o Service: the service name.

o Server Role: the server role name.

o App: the application of the server role.

o Name: the resource name.

o Type: the resource type.

o Status: the resource request status.

o Error Msg: the exception message.

o Parameters: the resource parameters.
Cluster Resource

o Result: the resource request result.

o Res: the resource ID.

o Reprocess Status: the status of interaction with Business
Foundation System during the VIP resource request.

o Reprocess Msg: the exception message of interaction with Business
Foundation System during the VIP resource request.

o Reprocess Result: the result of interaction with Business
Foundation System during the VIP resource request.

o Refer Version List: the version that uses the resource.

The information of virtual machines in the cluster. Data is available only
when virtual machines are deployed in the cluster.

o VM: the hostname of the virtual machine.

VM Mappings o Currently Deployed On: the hostname of the physical machine
where the virtual machine is currently deployed.

o Target Deployed On: the hostname of the physical machine where
the virtual machine is expected to be deployed.

The dependencies of service instances and server roles in the cluster,
and the final status information of the dependent service or server role.

o Service: the service name.
o Server Role: the server role name.
o Dependent Service: the service on which the server role depends.

Service Dependencies o Dependent Server Role: the server role on which the server role
depends.

o Dependent Cluster: the cluster to which the dependent server role
belongs.

o Dependency in Final Status: whether the dependent server role
reaches the final status.

5.4.1.4.3. View the cluster operation and maintenance

center
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The cluster operation and maintenance center allows you to view the status or statistics of services or

machines in the cluster.

Procedure

1. Log onto Apsara Infrastructure Management Framework.

2. You have three ways to go to the Cluster Operation and Maintenance Center page:

o Inthe left-side navigation pane, clickthe C tab. Move the pointer over [fJ at the right of a cluster

and then select Cluster Operation and Maintenance Center.

o Inthe top navigation bar, choose Operations > Cluster Operations. Onthe Cluster
Operations page, choose Monitoring > Cluster Operation and Maintenance Center inthe
Actions column at the right of a cluster.

o Inthe top navigation bar, choose Operations > Cluster Operations. Onthe Cluster
Operations page, click a cluster name. On the Cluster Dashboard page, choose Operations
Menu > Cluster Operation and Maintenance Center.

3. View the information on the Cluster Operation and Maintenance Center page.

ltem

SR not in Final
Status

Running Tasks

Head Version
Submitted At

Description

Displays all the server roles that do not reach the final status in the cluster.

Click the number to expand a server role list, and click a server role in the list
to display the information of machines included in the server role.

Displays whether the cluster has running rolling tasks.

Click Rolling to go to the Rolling Task page. For more information about
the rolling task, see View rolling tasks.

The time when the head version is submitted.

Click the time to view the submission details.
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ltem

Head Version
Analysis

Service

Server Role

Total Machines

Scale-in/Scale-out

Abnormal Machines

Description

The head version analysis is the process that Apsara Infrastructure
Management Framework detects the latest cluster version and parses the
version to detailed change contents. The head version analysis has the
following statuses:

o Preparing: No new version is available now.

o Waiting: The latest version is found. The analysis module has not started
up yet.

©o Doing: The module is analyzing the application that requires change.
o done: The head version analysis is successfully completed.

o Failed: The head version analysis failed. The change contents cannot be
parsed.

If the status is not done, Apsara Infrastructure Management Framework
cannot detect the change contents of server roles in the latest version.

Click the status to view the relevant information.

Select a service deployed in the cluster from the drop-down list.

Select a server role of a service in the cluster from the drop-down list.

@ Note After you select the service and server role, the information
of machines related to the service or server role is displayed in the list.

The total number of machines in the cluster, or the total number of
machines included in a specific server role of a specific service.

The number of machines or server roles that are scaled in or out.

The number of abnormal machines that encounter each type of the
following faults.

o Ping Failed: A ping_monitor error is reported, and TianjiMaster cannot
successfully ping the machine.

o No Heartbeat: TianjiClient on the machine does not regularly report
data to indicate the status of this machine, which may be caused by the
TianjiClient problem or network problem.

o Status Error: The machine has an error reported by the monitor or a
fault of the critical or fatal level. Check the alert information and
accordingly solve the issue.
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ltem Description

The number of machines with abnormal services. To determine if a service
reaches the final status, see the following rules:

o The server role on the machine is in the GOOD status.

o Each application of the server role on the machine must keep the actual
Abnormal Services version the same as the head version.

o Before the Image Builder builds an application of the head version, Apsara
Infrastructure Management Framework cannot determine the value of the
head version and the service final status is unknown. This process is called
the change preparation process. The service final status cannot be
determined during the preparation process or upon a preparation failure.

Displays all the machines in the cluster or the machines included in a specific
server role of a specific service.

o Machine search: Click the search box to enter the machine in the displayed
dialog box. Fuzzy or batch search is supported.

o (Click the machine name to view the physical information of the machine in
the displayed Machine Information dialog box. Click DashBoard to go
to the Machine Details page. For more information about the machine
details, see View the machine dashboard.

© Move the pointer over the blank area in the Final Status column or the
Final SR Status column and then click Details to view the machine
status, system service information, server role status on the machine, and
exception message.

o If no service or server role is selected from the drop-down list, move the
pointer over the blank area in the Running Status column and then click
Details to view the running status information or exception message of
the machine.

Machines

If a service and a server role are selected from the corresponding drop-
down lists, move the pointer over the blank area in the SR Running
Status column and then click Details to view the running status
information or exception message of the server role on the machine.

o (Click Error, Warning, or Good in the Monitoring Statistics columnto
view the monitored items of machines and monitored items of server
roles.

o Click Terminal inthe Actions columnto log onto the machine and
perform related operations.

o Click Machine Operation inthe Actions columnto restart, out-of-band
restart, or clone the machine again.

5.4.1.4.4. View the service final status

The Service Final Status Query page allows you to view if a service in a cluster reaches the final
status and the final status information.

Procedure
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1. Log onto Apsara Infrastructure Management Framework.

2. You have two ways to go to the Service Final Status Query page:
o Inthe left-side navigation pane, click the C tab. Move the pointer over [fj at the right of a cluster

and then choose Monitoring > Service Final Status Query.

o Inthe top navigation bar, choose Operations > Cluster Operations. On the Cluster
Operations page, choose Monitoring > Service Final Status Query inthe Actions column at
the right of a cluster.

3. View the information on the Service Final Status Query page.

ltem Description
Project Name The name of the project to which the cluster belongs.
Cluster Name The cluster name.

Head Version

R The time when the head version is submitted.
Submitted At

The head version analysis is the process that Apsara Infrastructure
Management Framework detects the latest cluster version and parses the
version to detailed change contents. The head version analysis has the
following statuses:

o Preparing: No new version is available now.

o Waiting: The latest version is found. The analysis module has not

Head Version Analysis started up yet.

o Doing: The module is analyzing the application that requires change.
o done: The head version analysis is successfully completed.

o Failed: The head version analysis failed. The change contents cannot
be parsed.

If the status is not done, Apsara Infrastructure Management Framework
cannot detect the change contents of server roles in the latest version.

Displays the information of the current rolling task in the cluster, if any.

Rolli
Cluster Rolling Status The rolling task may not be of the head version.

The status of all machines in the cluster. Click View Details to go to the
Cluster Operation and Maintenance Center page and view the
detailed information of all machines. For more information about the
cluster operation and maintenance center, see View the cluster operation
and maintenance center.

Cluster Machine Final
Status Statistics

114 > Document Version: 20210128



Operations and Maintenance Guide-
Operations tools

ltem

Final Status of Cluster
SR Version

Final Status of SR
Version

Description

The final status of cluster service version.

@ Note Take statistics of services that do not reach the final
status, which is caused by version inconsistency or status exceptions.
If services do not reach the final status because of machine problems,
go to Cluster Machine Final Status Statistics to view the
statistics.

The number of machines that do not reach the final status when a server
role has tasks.

5.4.1.4.5. View operation logs

By viewing operation logs, you can obtain the differences between different Git versions.

Procedure

1. Log onto Apsara Infrastructure Management Framework.

2. You have two ways to go to the Cluster Operation Logs page:

o Inthe left-side navigation pane, click the C tab. Move the pointer over [fJ at the right of a cluster

and then choose Monitoring > Operation Logs.

o Inthe top navigation bar, choose Operations > Cluster Operations. Onthe Cluster
Operations page, choose Monitoring > Operation Logs inthe Actions column at the right of

acluster.

3. Onthe Cluster Operation Logs page, click Refresh. View the Git version, description, submitter,
submitted time, and task status.

4. (Optional)Complete the following steps to view the differences between versions on the Cluster

Operation Logs page.

i. Find the log inthe operation log list and then click View Release Changes inthe Actions

column.

ii. Onthe Version Difference page, complete the following configurations:

m Select Base Version: Select a base version.

m Configuration Type: Select Extended Configuration or Cluster Configuration.
Extended Configuration displays the configuration differences after the configuration on
the clusteris combined with the configuration in the template. Cluster Configuration
displays the configuration differences on the cluster.

ii. ClickObtain Difference.

The differential file list is displayed.

iv. Click each differential file to view the detailed differences.

5.4.1.5. Service operations
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T his topic describes the actions about service operations.

5.4.1.5.1. View the service list

The service list allows you to view the list of all services and the related information.

Procedure

1.
2.
3.

Log onto Apsara Infrastructure Management Framework.
In the top navigation bar, choose Operations > Service Operations.

View the information on the Service Operations page.

ltem Description
Service The service name.
Service o . .

The number of service instances in the service.
Instances
Service
Configuration The number of service configuration templates.
Templates
Monitorin L

9 The number of monitoring templates.

Templates
Service . . . S

The number of service configuration validation templates.
Schemas
Actions Click Management to view the service instances, service templates, monitoring

templates, monitoring instances, service schemas, and detection scripts.

5.4.1.5.2. View the service instance dashboard

The service instance dashboard allows you to view the basic information and statistics of a service
instance.

Procedure

1.
2.

Log onto Apsara Infrastructure Management Framework.
In the left-side navigation pane, clickthe S tab.

(Optional)Enter the service name in the search box. Services that meet the search condition are
displayed.

. Click a service name and then service instances in the service are displayed in the lower-left corner.

. Move the pointer over [fJ at the right of a service instance and then select Dashboard.

. View the information on the Service Instance Information Dashboard page.
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ltem

Service Instance
Summary

Server Role Statuses

Machine Statuses for
Server Roles

Service Monitoring
Information

Service Alert Status

Description

Displays the basic information of the service instance as follows:

o

Cluster Name: the name of the cluster to which the service instance
belongs.

Service Name: the name of the service to which the service instance
belongs.

Actual Machines: the number of machines in the current
environment.

Expected Machines: the number of machines that the service
instance expects.

Target Total Server Roles: the number of server roles that the
service instance expects.

Actual Server Roles: the number of server roles in the current
environment.

Template Name: the name of the service template used by the
service instance.

Template Version: the version of the service template used by the
service instance.

Schema: the name of the service schema used by the service
instance.

Monitoring System Template: the name of the monitoring system
template used by the service instance.

The statistical chart of the current status of server roles in the service
instance.

The status statistics of machines where server roles are located.

Monitored Item: the name of the monitored item.
Level: the level of the monitored item.
Description: the description of the monitored contents.

Updated At: the time when the data is updated.

Alert Name

Instance Information
Alert Start

Alert End

Alert Duration
Severity Level

Occurrences: the number of times the alert is triggered.
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ltem Description

o Server Role
o Current Status
o Expected Machines
o Machines In Final Status
Server Role List
o Machines Going Offline
o Rolling Task Status
o Time Used: the time used for running the rolling task.

o Actions: Click Details to go to the Server Role Dashboard page.

o Alert Name
o Alert Time

Service Alert History o Instance Information
o Severity Level

o Contact Group

The dependencies of service instances and server roles in the service
instance, and the final status information of the dependent service or
server role.

o Server Role: the server role name.
o Dependent Service: the service on which the server role depends.

Service Dependencies o Dependent Server Role: the server role on which the server role
depends.

o Dependent Cluster: the cluster to which the dependent server role
belongs.

o Dependency in Final Status: whether the dependent server role
reaches the final status.

5.4.1.5.3. View the server role dashboard

The server role dashboard allows you to view the statistics of a serverrole.

Procedure
1. Log onto Apsara Infrastructure Management Framework.
2. Inthe left-side navigation pane, clickthe S tab.
3. (Optional)Enter the service name in the search box. Services that meet the search condition are
displayed.
4. Click a service name and then service instances in the service are displayed in the lower-left corner.
5. Move the pointer over [ at the right of a service instance and then select Dashboard.
6. Inthe Server Role List section of the Service Instance Information Dashboard page, click
Details inthe Actions column.
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7. View the information on the Server Role Dashboard page.

item

Server Role Summary

Machine Final Status
Overview

Server Role Monitoring
Information

Description

Displays the basic information of the server role as follows:

[e]

Project Name: the name of the project to which the server role
belongs.

Cluster Name: the name of the cluster to which the server role
belongs.

Service Instance: the name of the service instance to which the
server role belongs.

Server Role: the server role name.

In Final Status: whether the server role reaches the final status.
Expected Machines: the number of expected machines.
Actual Machines: the number of actual machines.

Machines Not Good: the number of machines whose status is not
Good.

Machines with Role Status Not Good: the number of server roles
whose status is not Good.

Machines Going Offline: the number of machines that are going
offline.

Rolling: whether a running rolling task exists.
Rolling Task Status: the current status of the rolling task.

Time Used: the time used for running the rolling task.

The statistical chart of the current status of the server role.

o

o

o

Updated At: the time when the data is updated.
Monitored Item: the name of the monitored item.
Level: the level of the monitored item.

Description: the description of the monitored item.

> Document Version: 20210128

119



Operations and Maintenance Guide-
Operations tools

ltem Description

o Machine Name: the hostname of the machine.

o IP: the IP address of the machine.

o Machine Status: the machine status.

o Machine Action: the action that the machine is performing.

o Server Role Status: the status of the server role.

o Server Role Action: the action that the server role is performing.

o Current Version: the current version of the server role on the
machine.

o Target Version: the expected version of the server role on the
machine.

Machine Information o Error Message: the exception message.
o Actions:
® (lick Terminal to log on to the machine and perform operations.
® (Click Restart to restart the server roles on the machine.

® (lick Details to go to the Machine Details page. For more
information about the machine details, see View the machine
dashboard.

® (Click Machine System View to go to the Machine Info Report
page. For more information about the machine info report, see
Machine info report.

m (Click Machine Operation to restart, out of band restart, or clone
the machine again.

o Updated At: the time when the data is updated.

o Machine Name: the machine name.
Server Role Monitoring

. R o Monitored Item: the name of the monitored item.
Information of Machines

o Level: the level of the monitored item.

o Description: the description of the monitored item.

The information of virtual machines in the cluster. Data is available only
when virtual machines are deployed in the cluster.

o VM: the hostname of the virtual machine.

VM Mappings o Currently Deployed On: the hostname of the physical machine
where the virtual machine is currently deployed.

o Target Deployed On: the hostname of the physical machine where
the virtual machine is expected to be deployed.
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ltem

Service Dependencies

Description

The dependencies of service instances and server roles in the service
instance, and the final status information of the dependent service or
server role.

o Dependent Service: the service on which the server role depends.

o Dependent Server Role: the server role on which the server role
depends.

o Dependent Cluster: the cluster to which the dependent server role
belongs.

o Dependency in Final Status: whether the dependent server role
reaches the final status.

5.4.1.6. Machine operations

This topic describes the actions about machine operations.

5.4.1.6.1. View the machine dashboard

The machine dashboard allows you to view the statistics of a machine.

Procedure

1.
2.

Log onto Apsara Infrastructure Management Framework.

In the left-side navigation pane, clickthe C tab.

(Optional)On the Machine tab in the lower-left corner, enter the machine name in the search box.
Machines that meet the search condition are displayed.

the following table.
ltem
Load-System
CPU-System
Mem-System
DISK Usage-System
Traffic-System
TCP State-System
TCP Retrans-System

DISK I0-System

. Move the pointer over Jfj at the right of a machine and then select Dashboard.

. Onthe Machine Details page, view all the information of this machine. For more information, see

Description

The system load chart of the cluster.
The CPU load chart.

The memory load chart.

The statistical table of the disk usage.
The system traffic chart.

The TCP request status chart.

The chart of TCP retransmission amount.

The statistical table of the disk input and output.
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ltem Description

o Project Name: the name of the project to which the machine
belongs.

o Cluster Name: the name of the cluster to which the machine
belongs.

o Machine Name: the machine name.
© SN: the serial number of the machine.
o |IP: the IP address of the machine.
o IDC: the data center of the machine.
© Room: the room in the data center where the machine is located.
o Rack: the rack where the machine is located.
o Unit in Rack: the location of the rack.
Machine Summary o Warranty: the warranty of the machine.
o Purchase Date: the date when the machine is purchased.
o Machine Status: the running status of the machine.
o Status: the hardware status of the machine.
o CPUs: the number of CPUs for the machine.
o Disks: the disk size.
o Memory: the memory size.
o Manufacturer: the machine manufacturer.
o Model: the machine model.
o 0s: the operating system of the machine.

o part: the disk partition.

Server Role Status of

. The distribution of the current status of all server roles on the machine.
Machine

o

Monitored Item: the name of the monitored item.

o

Machine Monitoring Level: the level of the monitored item.

Information

o

Description: the description of the monitored contents.

o

Updated At: the time when the monitoring information is updated.
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ltem Description

o Service Instance
o Server Role
o Server Role Status
o Server Role Action
o Error Message
o Target Version
Machine Server Role
Status © Current Version
o Actual Version Update Time
o Actions:

® (lick Details to go to the Server Role Dashboard page. For
more information about the server role dashboard, see View the
server role dashboard.

B (Click Restart to restart the server roles on the machine.

o Application Name: the application name.

o Process Number

o Status: the application status.

o Current Build ID: the ID of the current package version.
o Target Build ID: the ID of the expected package version.

o @it Version
Application Status in
Server Roles

o Start Time
°o End Time

o Interval: the interval between the time when Apsara Infrastructure
Management Framework detects that the process exits and the time
when Apsara Infrastructure Management Framework repairs the
process.

o Information Message: the normal output logs.

o Error Message: the abnormal logs.

5.4.1.7. Monitoring center

You can view the alert status, alert rules, and alert history in the monitoring center.

5.4.1.7.1. Modify an alert rule

You can modify an alert rule based on the actual business requirements.

Procedure

1. Log onto Apsara Infrastructure Management Framework.

2. Inthe top navigation bar, choose Operations > Service Operations.
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(Optional)Enter the service name in the search box.

Find the service and then click Management in the Actions column.

Click the Monitoring Template tab.

Find the monitoring template that you are about to edit and then click Edit in the Actions column.
Configure the monitoring parameters based on actual conditions.

ClickSave Change.

Wait about 10 minutes. The monitoring instance is automatically deployed. If the status becomes
Successful and the deployment time is later than the modified time of the template, the changes
are successfully deployed.

5.4.1.7.2. View the status of a monitoring instance

After a monitoring instance is deployed, you can view the status of the monitoring instance.

Procedure

1.

oA wN

Log onto Apsara Infrastructure Management Framework.

In the top navigation bar, choose Operations > Service Operations.
(Optional)Enter the service name in the search box.

Find the service and then click Management in the Actions column.

Clickthe Monitoring Instance tab. Inthe Status column, view the current status of the
monitoring instance.

5.4.1.7.3. View the alert status

The Alert Status page allows you to view the alerts generated in different services and the
corresponding alert details.

Procedure

1.
2.
3.

Log on to Apsara Infrastructure Management Framework.
In the top navigation bar, choose Monitoring > Alert Status.

(Optional)You can configure the service name, cluster name, alert name, and/or the time range
when the alert is triggered to search for alerts.

. View the alert details onthe Alert Status page. See the following table forthe alert status

descriptions.

ftem Description
Service The service name.
Cluster The name of the cluster where the service is located.

The name of the service instance being monitored.
Instance
Click the instance to view the alert history of this instance.

124

> Document Version: 20210128



Operations and Maintenance Guide-
Operations tools

ltem

Alert Status

Alert Level

Alert Name

Alert Time

Actions

Description
Alerts have two statuses: Restored and Alerting.

Alerts have the following four levels, from high to low, according to the effect
on services.

o P1
o P2
o P3
o P4

The name of the generated alert.

Click the alert name to view the alert rule details.

The time when the alert is triggered and how long the alert has lasted.

Click Show to show the data before and after the alert time.

5.4.1.7.4. View alert rules

The Alert Rules page allows you to view the configured alert rules.

Log onto Apsara Infrastructure Management Framework.

In the top navigation bar, choose Monitoring > Alert Rules.

(Optional)You can configure the service name, cluster name, and/or alert name to search for alert

Procedure
1.
2.
3.
rules.
4

descriptions.
ltem
Service
Cluster
Alert Name
Alert Conditions
Periods

Alert Contact

. View the detailed alert rules on the Alert Rules page. See the following table forthe alert rule

Description

The service name.

The name of the cluster where the service is located.
The name of the generated alert.

The conditions met when the alert is triggered.

The frequency (in seconds) with which an alert rule is run.

The groups and members that are notified when an alert is triggered.
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ltem Description

The current status of the alert rule.
Status © Running: Click to stop this alert rule.

o Stopped: Click to runthis alert rule.

5.4.1.7.5. View the alert history

The Alert History page allows you to view all the history alerts generated in different services and the
corresponding alert details.

Procedure

1. Log onto Apsara Infrastructure Management Framework.
2. Inthe top navigation bar, choose Monitoring > Alert History.

3. (Optional)You can configure the service name, cluster name, time range, and/or period to search
foralerts.

4. View the history alerts onthe Alert History page. See the following table for the history alert
descriptions.

ltem Description

Service The name of the service to which the alert belongs.
Cluster The name of the cluster where the service is located.
Alert Instance The name of the resource where the alert is triggered.
Status Alerts have two statuses: Restored and Alerting.

Alerts have the following four levels, from high to low, according to the effect
on services.

o P1
Alert Level o P2

o P3
o P4

The name of the generated alert.

Alert Name
Click the alert name to view the alert rule details.
Alert Time The time when the alert is triggered.
Alert Contact The groups and members that are notified when an alert is triggered.
Actions Click Show to show the data before and after the alert time.
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5.4.1.8. Tasks and deployment summary

This topic describes how to view rolling tasks, running tasks, history tasks, and deployment summary on
Apsara Infrastructure Management Framework.

5.4.1.8.1. View rolling tasks

You can view running rolling tasks and the corresponding status.

Procedure

1. Log onto Apsara Infrastructure Management Framework.
In the top navigation bar, choose Operations > Cluster Operations.
Select Rolling T asks to display clusters with rolling tasks.

In the search results, clickrolling in the Rolling column.

ok wnN

On the displayed Rolling T ask page, view the information in the Change T ask list and Change
Det ails list.

Change Task list
ltem Description
Change Version The version that triggers the change of the rolling task.

Description The description about the change.

The head version analysis is the process that Apsara Infrastructure Management
Framework detects the latest cluster version and parses the version to detailed
change contents. The head version analysis has the following statuses:

o Preparing: No new version is available now.

o Waiting: The latest version is found. The analysis module has not started up

Head Version yet.

Analysis o Doing: The module is analyzing the application that requires change.
o done: The head version analysis is successfully completed.

o Failed: The head version analysis failed. The change contents cannot be
parsed.

If the status is not done, Apsara Infrastructure Management Framework cannot
detect the change contents of server roles in the latest version.

Blocked Server Server roles blocked in the rolling task. Generally, server roles are blocked because
Role of dependencies.

Submitter The person who submits the change.

Submitted At The time when the change is submitted.
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ltem Description

Click View Difference to go to the Version Difference page. For more
information, see View operation logs.

Acti
ctions Click Stop to stop the rolling task.

Click Pause to pause the rolling task.

Change Details list

ltem Description

Service Name The name of the service where a change occurs.

The current status of the service. The rolling
status of the service is an aggregated result,
which is calculated based on the rolling status of

the server role.
Status

o succeeded: The task is successfully run.
o blocked: The taskis blocked.

o failed: The task failed.

The server role status. Click > at the left of the
service name to expand and display the rolling
task status of each server role in the service.
Server roles have the following statuses:

Server Role Status ) o
o Downloading: The task is being downloaded.
o Rolling: The rolling task is running.

o RollingBack: The rolling task failed and is
rolling back.

The services that this service depends on or server

D
epend On roles that this server role depends on.
Click Stop to stop the change of the server role.
Actions Click Pause to pause the change of the server

role.

5.4.1.8.2. View running tasks
By viewing running tasks, you can know the information of all the running tasks.

Procedure

1. Log onto Apsara Infrastructure Management Framework.

2. Inthe top navigation bar, choose Tasks > Running T asks.
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3. (Optional)You can configure the cluster name, role name, task status, task submitter, Git version,
and/orthe start time and end time of the task to search for running tasks.

4. Find the task that you are about to view the details and then click View T asks in the Rolling T ask
Status column. The Rolling Task page appears. For more information about the rolling task, see
View rolling tasks.

5.4.1.8.3. View history tasks

You can view the historical running conditions of completed tasks.

Procedure

1. Log onto Apsara Infrastructure Management Framework.
2. Inthe top navigation bar, choose T asks > History Tasks.

3. (Optional)You can configure the cluster name, Git version, task submitter, and/or the start time and
end time of the taskto search for history tasks.

4. Find the taskthat you are about to view the details and then click Det ails in the Actions column.
The Rolling Task page appears. For more information about the rolling task, see View rolling tasks.

5.4.1.8.4. View the deployment summary

On the Deployment Summary page, you can view the deployment conditions of clusters, services, and
server roles in all projects on Apsara Infrast ructure Management Framework.

Procedure

1. Log onto Apsara Infrastructure Management Framework.
2. Inthe top navigation bar, choose T asks > Deployment Summary.
o View the deployment status and the duration of a certain status for each project.

m Gray: wait to be deployed. It indicates that some services of the project depend on server
roles or service instances that are being deployed, and other service instances or server roles in
the project have already been deployed.

m Blue: being deployed. It indicates that the project has not reached the final status for one
time yet.

m Green: has reached the final status. It indicates that all clusters in the project have reached the
final status.

m Orange: not reaches the final status. It indicates that a server role does not reach the final
status for some reason after the project reaches the final status for the first time.
o Configure the global clone switch.
= normal: Clone is allowed.

m block: Clone is forbidden.

o Configure the global dependency switch.
m normal: All configured dependencies are checked.

m ignore: The dependency is not checked.
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m ignore_service: None of the service-level dependencies, including the server role
dependencies across services, are checked, and only the server role-level dependencies are
checked.

3. Clickthe Deployment Details tab to view the deployment details.

For more information, see the following table.

ltem Description

The general statistics of deployment conditions, including the total number of
projects that are currently available. Click each status to display the projects in
the corresponding status in the list. The projects have five deployment
statuses:

o Final: All the clusters in the project have reached the final status.
o Deploying: The project has not reached the final status for one time yet.

Status statistics o Waiting: Some services of the project depend on server roles or service
instances that are being deployed, and other service instances or server roles
in the project have already been deployed.

o Non-final: A server role does not reach the final status for some reason
after the project reaches the final status for the first time.

o Inspector Warning: An error is detected on service instances in the project
during the inspection.

The time when Apsara Infrastructure Management Framework starts the

Start Time
deployment.
Proaress The proportion of server roles that reach the final status to all the server roles
9 in the current environment.
The time indicates the deployment duration for the following statuses: Final,
Deploying, Waiting, and Inspector Warning.
Deployment N . . .
Staptu: The time indicates the duration before the final status is reached for the Non-
final status.
Click the time to view the details.
The proportion of clusters, services, and server roles that reach the final status
to the total clusters, services, and server roles in the project.
Deployment Move the pointer over the blank area at the right of the data of roles and then
Progress click Details to view the deployment statuses of clusters, services, and server

roles. The deployment statuses are indicated by icons, which are the same as
those used for status statistics.
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ltem

Resource
Application
Progress

Inspector Error

Monitoring
Information

Dependency

Description

Total indicates the total number of resources related to the project.
o Done: the number of resources that have been successfully applied for.

o Doing: the number of resources that are being applied for and retried. The
number of retries (if any) is displayed next to the number of resources.

o Block: the number of resources whose applications are blocked by other
resources.

o Failed: the number of resources whose applications failed.

The number of inspection alerts for the current project.

The number of alerts generated for the machine monitor and the machine
server role monitor in the current project.

Click the icon to view the project services that depend on other services, and
the current deployment status of the services that are depended on.

5.4.1.9. Reports

The system allows you to search for and view reports based on your business needs, and add
commonly used reports to your favorites.

5.4.1.9.1. View reports

The Reports menu allows you to view the statistical data.

Context

You can view the following reports on Apsara Infrastructure Management Framework.

e Systemreports: default and common reports in the system.

e Allreports: includes the systemreports and customreports.

Procedure

1. Log onto Apsara Infrastructure Management Framework.

2. Youcango to the report list in the following three ways:

o Inthe top navigation bar, choose Reports > System Reports.

o Inthe top navigation bar, choose Reports > All Reports.

o Inthe left-side navigation pane, click the R tab. Move the pointer over [fj at the right of All

Reports and then select View.

See the following table for the report descriptions.

ltem

Description
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ltem

Report

Group

Status

Public

Created By

Published At

Actions

Description

The report name.

Move the pointer over [z next to Report to search for reports by report name.

The group to which the report belongs.

Move the pointer over [z next to Group to filter reports by group name.

Indicates whether the report is published.

Indicates whether the report is public.

The person who creates the report.

The published time and created time of the report.

Click Add to Favorites to add this report to your favorites. Then, you can view
the report by choosing Reports > Favorites in the top navigation bar or moving

the pointer over [fJ at the right of Favorites on the R tab in the left-side

navigation pane and then selecting View.

3. (Optional)Enter the name of the report that you are about to view in the search box.

4. Clickthe report name to go to the corresponding report details page. For more information about
the reports, see Appendix.

5.4.1.9.2. Add a report to favorites

You can add common reports to favorites. Then, find them quickly on the Favorites page.

Procedure

1.
2.

S Ut~ W

Log onto Apsara Infrastructure Management Framework.

You can go to the report list in the following three ways:

o Inthe top navigation bar, choose Reports > System Reports.

o Inthe top navigation bar, choose Reports > All Reports.

o Inthe left-side navigation pane, clickthe R tab. Move the pointer over [ at the right of All

Reports and then select View.

. (Optional)Enter the name of the report that you are about to add to favorites in the search box.
. At the right of the report, click Add to Favorites inthe Actions column.

. Inthe displayed Add to Favorites dialog box, entertags forthe report.

. ClickAdd to Favorites.

5.4.1.10. Metadata operations
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In this version, you can use only command lines to perform metadata operations.

5.4.1.10.1. Common parameters

Common parameters consist of the common request parameters and the common response
parameters.

Common request parameters

Common request parameters are request parameters that you must use when you call each APL.

Parameter descriptions
Name Type Required Description

The APl name. For more
information about the
valid values, see APIs on
the control side and
APIs on the deployment
side.

Action String Yes

Common response parameters

Each time you send a request to call an API, the system returns a unique identifier, regardless of
whether the call is successful.

Parameter descriptions
Name Type Required Description

The request ID.

The request ID is

RequestID String Yes returned, regardless of
whether the API call is
successful.

Code String No The error code.

The reason of failure,
Message String No which appears when the
API call fails.

The type varies with the

request, which is The request result,

Result subject to the returned No which appears when the
result of the specific API call is successful.
API.
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@ Note
e [f the APIcallis successful, RequestID is returned and the HTTP return code is 200.

e [f the APIcall fails, RequestID, Code, and Message are returned and the HTTP return code is
4XX Or 5xX.

Instance types
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"rds.mys2.small":{
"cpu":2,
"memory":4096,
"disk":51200,
"max_connections":60

b

"rds.mys2.mid":{

"cpu":4,
"memory":4096,
"disk":51200,
"max_connections":150

b

"rds.mys2.standard":{
"cpu":6,
"memory":4096,
"disk":51200,
"max_connections":300

b

"rds.mys2.large":{
"cpu":8,
"memory":7200,
"disk":102400,
"max_connections":600

b

"rds.mys2.xlarge":{
"cpu™:9,
"memory":12000,
"disk":204800,
"max_connections":1500

b

"rds.mys2.2xlarge":{
"cpu":10,
"memory":20000,
"disk":512000,

"max_connections":2000
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5.4.1.10.2. Access APIs

T his topic describes how to connect to control-side and deployment-side APl operations.

Procedure
1. Log onto Apsara Infrastructure Management Framework.
2. Inthe left-side navigation pane, choose Operations > Machine Operations.

3. Select a project fromthe drop-down list or enter a cluster or machine name to search forthe
target machine.

4. Connect to APl operations.
o Connect to control-side APl operations
a. Find the target machine and click Terminal in the Actions column to log on to the machine.

b. Onthe command line, enter the following command and press the Enter key to obtain the
value of intranet-domain.
grep 'intranet-domain' /cloud/app/tianji/TianjiClient#/service_manager/current/conf.global/kv.j

son

termenal service to reflect shell to web

~  kBs-A-2162

TSl "] amtest?FD)

¢. Use one of the following methods to connect to control-side APl operations. ListInstance is
used in the example.

m GET request

curl 'xdb-master.xdb.{intranet-domain}:15678? Action=ListInstance'

m POST request
curl 'xdb-master.xdb.{intranet-domain}:15678' -X POST -d '{"Action":"ListInstance"}'
o Connect to deployment-side APl operations

a. Find the target machine and record the IP address in the Hostname column.

b. Use one of the following methods to connect to deployment-side APl operations.
CheckState is used in the example.

Assume that the IP address of the target machine is 127.0.XX.XX.

m GET request
curl'127.0.XX.XX:18765? Action=CheckState&Port=3606'
m POST request

curl'127.0.XX.XX:18765' -X POST -d '{"Action":"CheckState","Port":3606}'
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5.4.1.10.3. APIs on the control side
5.4.1.10.4. APIs on the deployment side

5.4.1.11. Appendix
5.4.1.11.1. IP list

This report displays the IP addresses of physical machines and Docker applications.

IP List of Physical Machines

ltem Description

Project The project name.

Cluster The cluster name.

Machine Name The hostname of the machine.
P The IP address of the machine.

IP List of Docker Applications

ltem Description

Project The project name.

Cluster The cluster name.

Service The service name.

Server Role The server role name.
Machine Name The hostname of the machine.
Docker Host The Docker hostname.
Docker IP The Docker IP address.

5.4.1.11.2. Project component info report

This report displays the name and status for each type of project components, including services, server
roles, and machines.

ltem Description

Project The project name.
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item

Cluster

Service

Server Role

Server Role
Status

Server Role
Action

Machine Name

IP

Machine Status

Machine Action

Description
The name of a cluster in the project.
The name of a service in the cluster.

The name of a server role in the service.

The running status of the server role on the machine.

The action that the server role performs on the machine. Data is available only when
Apsara Infrastructure Management Framework asks the server role to perform certain
actions, such as rolling and restart actions.

The hostname of the machine.

The IP address of the machine.

The running status of the machine.

The action that Apsara Infrastructure Management Framework asks the machine to
perform, such as the clone action.

5.4.1.11.3. Machine info report

This report displays the statuses of machines and server roles on the machines.

Machine Status

Displays all the machines currently managed by Apsara Infrastructure Management Framework and their
corresponding statuses. In the Global Filter section at the top of the page, select the project, cluster,
and machine fromthe project, cluster, and machine drop-down lists, and then click Filter on the

right to filter the data.

ltem

Machine Name

IP

Machine Status

Machine Action

Machine Action
Status

Status Description

Description

The machine name.

The IP address of the machine.
The machine status.

The action currently performed by the machine.

The action status.

The description about the machine status.

Expected Server Role List

Select arow inthe Machine Status section to display the corresponding information in this list.
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ltem Description
Machine Name The machine name.
Server Role The name of the expected server role on the machine.

Abnormal Monitoring Status

Select a row in the Machine Status section to display the corresponding information in this list.

ltem Description

Machine Name The machine name.

Monitored Item The name of the monitored item.

Level The level of the monitored item.

Description The description of the monitored item contents.
Updated At The updated time of the monitored item.

Server Role Version and Status on Machine

Select arow in the Machine Status section to display the corresponding information in this list.

ltem Description

Machine Name The machine name.

Server Role The server role name.

Server Role Status The status of the server role.

Target Version The expected version of the server role on the machine.
Current Version The current version of the server role on the machine.

Status Description The description about the status.

Error Message The exception message of the server role.

Monitoring Status

Select arow in the Machine Status section to display the corresponding information in this list.

ltem Description

Machine Name The machine name.

Server Role The server role name.
Monitored ltem The name of the monitored item.
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ltem Description

Level The level of the monitored item.

Description The description of the monitored item contents.
Updated At The updated time of the monitored item.

5.4.1.11.4. Rolling info report

This report displays the running and completed rolling tasks and the task-related status.

Choose a rolling action

This list only displays the running rolling tasks. If no rolling task is running, no data is available in the list.

ltem Description

Cluster The cluster name.

Git Version The version of change that triggers the rolling task.

Description The description about the change entered by a user when the user submits the change.
Start Time The start time of the rolling task.

End Time The end time of the rolling task.

Submitted

By The ID of the user who submits the change.

Rolling Task

The current status of the rolling task.
Status

Submitted

At The time when the change is submitted.

Server Role in Job

Select arolling taskin the Choose a rolling action section to display the rolling status of server roles
related to the selected task. If no rolling task is selected, the server role statuses of all historical rolling
tasks are displayed.

ltem Description
Server Role The server role name.

Server Role .

The rolling status of the server role.
Status

Error

The exception message of the rolling task.
Message P 9 9
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ltem

Git Version

Start Time

End Time

Approve
Rate

Failure Rate

Success Rate

Description
The version of change to which the rolling task belongs.
The start time of the rolling task.

The end time of the rolling task.

The proportion of machines that have the rolling task approved by the decider.

The proportion of machines that have the rolling task failed.

The proportion of machines that have the rolling task succeeded.

Server Role Rolling Build Information

The source version and target version of each application under the server role in the rolling process.

ltem

App

Server Role

From Build

To Build

Description

The name of the application that requires rolling in the server role.
The server role to which the application belongs.

The version before the upgrade.

The version after the upgrade.

Server Role Statuses on Machines

Select a serverrole inthe Server Role in Job section to display the deployment status of this server
role on the machine.

ltem Description
Machine . ) .
Name The name of the machine on which the server role is deployed.
Expected ) .

P . The target version of the rolling.
Version
Actual .

. The current version.

Version
State The status of the server role.

Action Name

Action
Status

The Apsara Infrastructure Management Framework action currently performed by the
server role.

The action status.
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5.4.1.11.5. Machine RMA approval pending list

Some Apsara Infrastructure Management Framewaork actions (such as restart) on machines and server
roles can be triggered by users, but this type of actions must be reviewed and approved. T his report is
used to process the actions that must be reviewed and approved.

Machine

Displays the basic information of pending approval machines.

ltem

Project
Cluster
Hostname

P

State

Action Name
Action Status

Actions

Machine Serverrole

Description

The project name.

The cluster name.

The hostname of the machine.

The IP address of the machine.

The running status of the machine.

The action on the machine.

The status of the action on the machine.

The approval button.

Displays the information of server roles on the pending approval machines.

ftem

Project
Cluster
Hostname

P

Serverrole
State

Action Name
Action Status

Actions

Machine Component

Description

The project name.

The cluster name.

The hostname of the machine.

The IP address of the machine.

The server role name.

The running status of the server role.

The action on the server role.

The status of the action on the server role.

The approval button.
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Displays the hard disk information of pending approval machines.

ltem Description

Project The project name.

Cluster The cluster name.

Hostname The hostname of the machine.
Component The hard disk on the machine.

State The running status of the hard disk.
Action Name The action on the hard disk.

Action Status The status of the action on the hard disk.
Actions The approval button.

5.4.1.11.6. Registration vars of services

This report displays values of all service registration variables.

ltem Description
Service The service name.
Service

- . The service registration variable.
Registration

Cluster The cluster name.

Update Time The updated time.

5.4.1.11.7. Virtual machine mappings

Use the globalfilter to display the virtual machines of a specific cluster.

Displays the information of virtual machines in the cluster. Data is available only when virtual machines
are deployed in the cluster.

ltem Description

Project The project name.

Cluster The cluster name.

VM The hostname of the virtual machine.

The hostname of the physical machine on which the virtual machine is

Currently Deployed On currently deployed.
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item

Target Deployed On

Description

The hostname of the physical machine on which the virtual machine is

expected to be deployed.

5.4.1.11.8. Service inspector report

Use the globalfilter to display the service inspection reports of a specific cluster.

Service Inspector: Data is available only for services with inspection configured.

item

Project

Cluster

Service

Description

Level

5.4.1.11.9. Resource application report

Description

The project name.

The cluster name.

The service name.

The contents of the inspection report.

The level of the inspection report.

Inthe Global Filter section, select the project, cluster, and machine fromthe project, cluster, and
machine drop-down lists and then click Filter on the right to display the corresponding resource

application data.

Change Mappings

ftem

Project

Cluster

Version

Resource Process
Status

Msg

Begintime

Endtime

Description
The project name.
The cluster name.

The version where the change occurs.

The resource application status in the version.

The exception message.
The start time of the change analysis.

The end time of the change analysis.

Changed Resource List
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item

Res

Type

Name

Owner

Parameters

Ins

Instance ID

Description

The resource ID.

The resource type.

The resource name.

The application to which the resource belongs.

The resource parameters.

The resource instance name.

The resource instance ID.

Resource Status

ltem

Project

Cluster

Service

Server Role

APP

Name

Type

Status

Parameters

Result

Res

Reprocess Status

Reprocess Msg

Reprocess Result

Refer Version
List

Description

The project name.

The cluster name.

The service name.

The server role name.

The application of the server role.

The resource name.

The resource type.

The resource application status.

The resource parameters.

The resource application result.

The resource ID.

The status of the interaction with Business Foundation System during the VIP

resource application.

The error message of the interaction with Business Foundation System during the VIP

resource application.

The result of the interaction with Business Foundation System during the VIP resource

application.

The version that uses the resource.
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ltem Description

Error Msg The exception message.

5.4.1.11.10. Statuses of project components

This report displays the status of all server roles in an abnormal status on machines of the project, and
the monitoring information (alert information reported by the server role to Apsara Infrastructure
Management Framework monitor) of server roles and machines.

Error State Component Table

Only displays the information of server roles that are not in GOOD status and server roles to be
upgraded.

ltem Description

Project The project name.

Cluster The cluster name.

Service The service name.

Server Role The server role name.

Machine Name The machine name.

Need Upgrade Whether the current version reaches the final status.
Server Role Status The current status of the server role.

Machine Status The current status of the machine.

Server Role Alert Information

Select arow inthe Error State Component Table section to display the corresponding information in
the list.

ltem Description

Cluster The cluster name.

Service The service name.

Server Role The server role name.

Machine Name The machine name.

Monitored Item The monitored item name of the server role.
Level The alert level.
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ftem
Description

Updated At

Description
The description about the alert contents.

The updated time of the alert information.

Machine Alert Information

Select arow inthe Error State Component Table section to display the corresponding information in

the list.
ftem
Cluster
Machine Name
Monitored ltem
Level
Description

Updated At

Description

The cluster name.

The machine name.

The monitored item name of the server role.
The alert level.

The description about the alert contents.

The updated time of the alert information.

Service Inspector Information

Select arow inthe Error State Component Table section to display the corresponding information in

the list.
ltem
Cluster
Service
Server Role
Monitored ltem
Level
Description

Updated At

Description

The cluster name.

The service name.

The server role name.

The monitored item name of the server role.
The alert level.

The description about the alert contents.

The updated time of the alert information.

5.4.1.11.11. Relationship of service dependency

This report displays the dependencies among server roles. Use the global filter to display the data of a

specific clusterin the list.
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ltem Description

Project The project name.

Cluster The cluster name.

Service The service name.

Server Role The server role name.

Ezz:?ssent The service on which the server role depends.

Dependent

The server role on which the server role depends.
Server Role

Dependent

The cluster to which the dependent server role belongs.
Cluster

Dependency in

. Whether the dependent server role reaches the final status.
Final Status

5.4.1.11.12. Check report of network topology

This report checks if network devices and machines have wirecheck alerts.

Check Report of Network Topology

Checks if network devices have wirecheck alerts.

ltem Description

Cluster The cluster name.

Network Instance The name of the network device.

Level The alert level.

Description The description about the alert information.

Check Report of Server Topology

Checks if servers (machines) have wirecheck alerts.

ltem Description

Cluster The cluster name.

Machine Name The server (machine) name.

Level The alert level.

Description The description about the alert information.
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5.4.1.11.13. Clone report of machines

This report displays the clone progress and status of machines.

Clone Progress of Machines

ltem Description

Project The project name.

Cluster The cluster name.

Machine Name The machine name.

Machine Status The running status of the machine.

Clone Progress The progress of the current clone process.

Clone Status of Machines

ltem Description

Project The project name.

Cluster The cluster name.

Machine Name The machine name.

Machine Action The action performed by the machine, such as the clone action.

Machine Action . .
The status of the action performed by the machine.

Status

Machine Status The running status of the machine.

Level Whether the clone action performed by the machine is normal.
Clone Status The current status of the clone action performed by the machine.

5.4.1.11.14. Auto healing/install approval pending report

The list structure is the same as the machine RMA approval pending list, whereas t his view is used for
the approval during the installation. For more information, see Machine RMA approval pending list.

5.4.1.11.15. Machine power on or off statuses of

clusters

After a cluster starts or shuts down machines, you can view the related information in this report.

Cluster Running Statuses
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If a clusteris starting or shutting down machines, the corresponding data is available in this list. No data
indicates that no cluster has machines shut down.

ltem

Project

Cluster

Action Name

Action Status

Description

The project name.

The cluster name.

The startup or shutdown action that is being performed by the cluster.

The status of the action.

Server Role Power On or Off Statuses

Displays the power on or off statuses of server roles in the cluster selected in the Cluster Running

Statuses section.

Select a row in the Cluster Running Statuses section to display the information of the corresponding

clusterinthe list.

ltem

Cluster

Server Role

Action Name

Action Status

Description
The cluster name.
The server role name.

The startup or shutdown action that is being performed by the server
role.

The status of the action.

Statuses on Machines

Displays the running status of the selected server role on machines.

Select arow inthe Server Role Power On or Off Statuses section to display the information of the
corresponding server role in the list.

ltem

Cluster

Server Role

Machine Name

Server Role Status

Server Role Action

Server Role Action
Status

Error Message

Description

The cluster name.

The server role name.

The machine name.

The running status of the server role.

The action currently performed by the server role.

The status of the action.

The exception message.
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ltem Description

Machine Statuses

Displays the running statuses of machines in the selected cluster.

Select a row inthe Statuses on Machines section to display the information of the corresponding
machine in the list.

ltem Description

Cluster The cluster name.

Machine Name The machine name.

P The IP address of the machine.

Machine Status The running status of the machine.

Machine Action The action currently performed by the machine.
Machine Action Status The action status of the machine.

Error Message The exception message.

5.4.2. New version

5.4.2.1. What is Apsara Infrastructure Management

Framework?

This topic describes what Apsara Infrastructure Management Framework is fromthe aspects of core
functions and basic concepts.

5.4.2.1.1. Introduction

Apsara Infrastructure Management Framework is a distributed data center management system, which
manages applications on clusters containing multiple machines and provides the basic functions such as
deployment, upgrade, expansion, contraction, and configuration changes.

Overview

Apsara Infrastructure Management Framework also supports monitoring data and analyzing reports,
which facilitates users to perform one-stop Operation & Maintenance (0&M) control. Based on the
Apsara Infrastructure Management Framework services, automated 0&M is implemented in the large-
scale distributed environment, which greatly improves the operations efficiency and enhances the
system availability.
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Apsara Infrastructure Management Framework is mainly composed of TianjiMaster and TianjiClient.
Apsara Infrastructure Management Framework installs TianjiClient as the agent on machines it manages.
Then, TianjiMaster accepts and issues the upper-layer instructions to TianjiClient for execution. Inthe
upper layer, Apsara Infrastructure Management Framework is divided into different components based
on different functions, and then provides API server and portal for external use.

Core functions

o Network initialization in data centers

e Serverinstallation and maintenance process management
e Deployment, expansion, and upgrade of cloud products
e Configuration management of cloud products

e Automatic application for cloud product resources

e Automatic repair of software and hardware faults

e Basic monitoring and business monitoring of software and hardware

5.4.2.1.2. Basic concepts

Before using Apsara Infrastructure Management Framework, you must know the following basic
concepts for a better understanding.

project
A collection of clusters, which provides service capabilities for external entities.

cluster

A collection of physical machines, which logically provides services and is used to deploy project
software.

e A cluster canonly belong to one project.
e Multiple services can be deployed on a cluster.
service

A set of software, which provides relatively independent functions. A service is composed of one or
more server roles and can be deployed on multiple clusters to form multiple sets of services and provide
the corresponding service capabilities. For example, Apsara Distributed File System, Job Scheduler, and
Apsara Name Service and Distributed Lock Synchronization System are all services.

service instance

A service that is deployed on a cluster.

server role

One or more indivisible deployment units into which a service can be divided based on functions. A
server role is composed of one or more specific applications. If a service is deployed on a cluster, all the
server roles of the service must be deployed to machines of this cluster. Multiple server roles, such as
PanguMaster and TianjiClient, can be deployed on the same server.

server role instance

A server role that is deployed on a machine. A server role can be deployed on multiple machines.
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application

Applications correspond to each process-level service component in a server role and each application
works independently. The application is the minimum unit for deployment and upgrade in Apsara
Infrastructure Management Framework, and can be deployed to each machine. Generally, an application
is an executable software or Docker container.

If a serverrole is deployed on a machine, all applications in the server role must be deployed to this
machine.

rolling

Each time when a user updates configurations, Apsara Infrastructure Management Framework upgrades
services and modifies the cluster configurations based on the updated configurations. T his process is
called rolling.

service configuration template

Some configurations are the same when services are deployed on clusters. A service configuration
template can be created to quickly write the same configurations to different clusters. The service
configuration template is basically used for large-scale deployment and upgrade.

associated service template

A template.conf file that exists in the configurations. This file declares the service configuration
template and its version, of which the configuration is used by the service instance.

desired state

If a clusteris in this state, all hardware and software on each of its machines are normal and all
software are in the target version.

dependency

The dependency between server roles in a service defines that server roles with dependencies run tasks
or are upgraded based on the dependency order. For example, if A depends on B, B is upgraded first. A
starts to be downloaded after B is downloaded successfully, and upgraded after B is successf ully
upgraded. (By default, the dependency does not take effect for configuration upgrade.)

upgrade

A way of aligning the current state with the desired state of a service. After a user submits the version
change, Apsara Infrastructure Management Framework upgrades the service version to the target
version. With the server role as the processing unit, upgrade aims to update the versions of all machines
to the target version.

At the beginning, the desired state and current state of the cluster are the same. When a user submits
the change, the desired state is changed, whereas the current state is not. A rolling task is generated
and has the desired state as the target version. During the upgrade, the current state is continuously
approximating to the desired state. Finally, the desired state and the current state are the same when
the upgrade is finished.

5.4.2.2. Log on to the Apsara Infrastructure Management

Framework console
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This topic describes how to log on to the Apsara Infrastructure Management Framework console.

Prerequisites

e The URL of the ASO console, and the username and password used for logging on to the console are
obtained fromthe deployment personnel or an administrator.

The URL of the ASO console is in the following format: region-id.aso.intranet-domain-id.com.

e A browser is available. We recommend that you use the Google Chrome browser.

Procedure
1. Open your browser.

2. Inthe address bar, enter the URL region-id.aso.intranet-domain-id.com and press the Enter key.

@ Note Youcanselect a language fromthe drop-down list in the upper-right corner of the
page.

3. Enteryour username and password.

@ Note Obtainthe username and password for logging on to the ASO console fromthe
deployment personnel or an administrator.

When you log on to the ASO console forthe first time, you must change the password of your
username as prompted.

To enhance security, a password must meet the following requirements:
o It must contain uppercase and lowercase letters.
o It must contain digits.

o It must contain special characters such as exclamation points (1), at signs (@), number signs (#),
dollar signs ($), and percent signs (%).

o It must be 10to 20 characters in length.
4. ClickLog Ontogotothe ASO console.
5. Inthe left-side navigation pane, choose Products > Product List.

6. Inthe Apsara Stack O&M section, choose Basic 0&M > Apsara Infrastructure Management
Framework.
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5.4.2.3. Instructions for the homepage

Afteryou log onto the Apsara Infrastructure Management Framework console, the homepage appears.
This topic describes the basic operations and functions on the homepage.

Log onto Apsara Infrastructure Management Framework. The homepage appears, as shown in the

following figure.

Homepage of the Apsara Infrastructure Management Framework console

Q| 1722 Backto Old Version English (US) « . M

Monitoring

& Tools

@ Clusters e Instances Machines
7 8571« 1 151 98.68. 2 23 100.00- O
Clusters Desired State  Abnormal Instances Desired State  Abnormal Machines Normal Abnormal
My Tasks | Tasks in Last Week: 27 o Quick Actions e
o Failed: 3 o In Progress: 1  Preparing: 2 @
- - § _— i Project OAM Permission  Monitoring
= EmONS commit by tianji importer AOS-NUWA: update the glob... Operations  Management  System Resource
Statistic
Status:  In Progress Status Status

Continued: an hour
Details >

Continued: an hour
Details >

Continued: an hour

Details >

The following table describes the functional sections on the homepage.

Description of functional sections

Section

Description
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Section Description

e QOperations: the quick entrance to operations & maintenance (0&M)
operations, which allows you to find operations and their objects. This
menu consists of the following submenus:

o Project Operations: allows you to use the project permissions to
manage projects.

o Cluster Operations: allows you to use the project permissions to
perform O&M and management operations on clusters. For example,
you can view the cluster status.

o Service Operations: allows you to use the service permissions to
manage services. For example, you can view the service list.

Left-side o Machine Operations: allows you to perform 0&M and management
©) navigation operations on machines. For example, you can view the machine status.
pane

e Tasks: Rolling tasks are generated after you modify the configurations in
the system. This menu allows you to view the running tasks, task history,
and deployment of clusters, services, and server roles in all projects.

e Reports: allows you to view monitoring data in tables and find specific
reports by using fuzzy search.

® Monitoring: monitors metrics during system operations and sends alert
notifications for abnormal conditions. This menu allows you to view the
alert status, modify alert rules, and search alert history.

® Tools: provides tools such as machine 0&M, IDC shutdown, and clone
progress.

® Search box: supports global search. You can enter a keyword in the search
box to search for clusters, services, and machines.

e The following information is displayed when you move the pointer over
the time:

o TJDB Sync Time: the time when the data on the current page is
generated.

o Desired State Calc Time: the time when the desired-state data on
the current page is calculated.

Top
) navigation The system processes data as fast as it can after the data is generated.
bar Latency exists because Apsara Infrastructure Management Framework is an

asynchronous system. Time information helps explain why data on the
current page is generated and determine whether the system is faulty.

e Back to Old Version: allows you to return to the old version of the
Apsara Infrastructure Management Framework console.

e English (US): the current display language of the console. You can select
another language from the drop-down list.

e profile picture: allows you to select Exit from the drop-down list to log
out of your account.
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Section Description

Displays the overview of global resources.

e (Clusters: displays the total number of clusters, the percentage of
clusters that have reached the desired state, and the number of abnormal
clusters.

Status bar e Instances: displays the total number of instances, the percentage of
) of global instances that have reached the desired state, and the number of

resources abnormal instances.

e Machines: displays the total number of machines, the percentage of
machines in the Normal state, and the number of abnormal machines.

You can move the pointer over each section and then click Details to go to
the Cluster Operations, Service Operations, or Machine Operations page.

Displays the information of tasks submitted in the last week. You can click
the number next to a task state to go to the My Tasks page and view the
Task status task details.

bar The top 5 latest tasks are displayed in the lower part of the section. You can

click Details corresponding to each task to view the task details.

Displays links of the following common quick actions:
® Project Operations: allows you to go to the Project Operation page.

e OAM Permission Management: allows you to go to the Operation
Administrator Manager (OAM) console. OAM is a centralized permission
management platform in the ASO console.

® Quick ® Monitoring System Resource Statistic: allows youto go to the
actions Grafana console of Monitoring System. The Grafana console displays the
running data of Monitoring System and facilitates your O&M operations.

@ Note Monitoring System Resource Statistic is displayed
only when Monitoring System is deployed in the environment.

Show/hide If you do not need to use the left-side navigation pane, click this button to
button hide the pane and enlarge the workspace.

5.4.2.4. Project operations
The Project Operations module allows you to search for and view details of a project.

Procedure

1. Log onto Apsara Infrastructure Management Framework.

2. Inthe left-side navigation pane, choose Operations > Project Operations.
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= ! Project Operations

| Project Status Statistics

amtest72 '

I Project Status
I

® Desired State 43 Projects

Net Dasired St

Alerting 2

Alerting 2

stz 19 Proiects

Alerting 16

Alerting 2

Deplay Dats

IDC Topalogical Graph | | amtestza

I ecs Alerting 20

I drds Alerting 2 Progress 0 Not Desirad State
3. Onthis page, you can:
o Search for a project

Click the drop-down list in the upper-right corner of the Project Status section. Enter a project
name in the search box, and then select the name to search for the project. You can view the
numbers of alerts and running tasks for the project and whether the project reaches the desired
state.

o View the details of a project

m Find the project whose details you are about to view. Click the number at the right of
Alerting. In the displayed Alert Information dialog box, view the specific monitoring metrics,
monitoring types, and alert sources. Click the value in the Alert Source column to view the
service details.

m Find the project whose details you are about to view. Click the number at the right of In
Progress. In the displayed T asks dialog box, view the details of Upgrade Service and Machine
Change.

5.4.2.5. Cluster operations

This topic describes the actions about cluster operations.

5.4.2.5.1. View the cluster list

This topic describes how to view all clusters and their information.

Procedure

1. Log onto Apsara Infrastructure Management Framework.
2. Use one of the following methods to go to the cluster list:

o Onthe Homepage page, move the pointer over the Clusters section and click Details in the
upper-right corner.

o Inthe left-side navigation pane, choose Operations > Cluster Operations.

| Clusters

IDC | amtest73 Project | All Clusters

Clusters Region Status Server Role Status Task Status Actions
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The following table describes the information displayed in the cluster list.

Parameter Description
Clusters The name of the cluster. Click the cluster name to view the cluster details.
Region The region where the cluster is deployed.

Specifies whether the cluster reaches the desired state. Click the | 7|icon to

filter clusters.

o Desired State: The cluster has reached the desired state.

Status
o Not Desired State: The cluster has reached the desired state for the first

time but a server role has not reached the desired state due to undefined
reasons.

The number of machines within the cluster and the machine status. Click the

Machine Status . . )
machine status to go to the Machines tab of the Cluster Details page.
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Parameter Description

The number of server roles within the cluster and the server role status. Click
a server role status to go to the Services tab of the Cluster Details page.
Click Abnormal in the Server Role Status column to view all the abnormal
server roles in the cluster in the displayed dialog box. Click View Details in
the upper-right corner of the dialog box to go to the Services tab of the
Cluster Details page.

Server Role Status Task Status 7
Tin Tota | Sucoessfu
3ginTotal | Apnermal: 20 Failed
Abnermal Server Roles View Details

33 in Total |

Server Role
38 inTotal |

tianji. TianjiCliznts Wachine Ermc
B5 in Tots | tianji-sshiunnel-cliznt. 35H7 Wachine Errc

Server Role Status
. nuwa.MuwaConfig Miachine Erro

B in Tota |

nuwa. MuwaProgs

58 in Total |

EcsTde Tdc# Wiachine Erro
11 in Total

EcsMbd Mbd= Wiachine Erro
4 in Total

ers-hrlanznsr NeMmenbd arhina Errn

Top 20

The status of the task related to the cluster. Click the |7 icon to filter
Task Status

clusters. Click the task status to view the task details.

5.4.2.5.2. View details of a cluster

This topic describes how to view details of a cluster.

Procedure

1. Log onto Apsara Infrastructure Management Framework.
2. Inthe left-side navigation pane, choose Operations > Cluster Operations.

3. (Optional)Select a project fromthe drop-down list or enter a cluster name to search for the cluster.
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4. Clickthe cluster name or click Operations inthe Actions column to go to the Cluster Details

page.
| Clusters [ i . E0b EditAG | Shennong View  Cluster Start/Shutdown
Status:  Not Desired State o Project: tianji Region: en-qd-hyq-d01
Included Server Roles: 159 Included Machines: 10 Task Status: Successful View
Clone Mode: Real Clone System Configuration: default Git Version: 5ac2b1c8¢17ad5b607781f732e608f19cbf42cdf
Security Authentication: Disable Type: Ordinary Cluster
Collapse a
Services Machines Cluster Configuration Operation Log Cluster Resource Service Inspection
All:32 | Normal (31) Abnormal (1) Reset e
Services Owner Status Server Role Service Template Actions
hermes baseSeniceAll Normal AinTotal | Normal None Details | Upgrade | Unpublish
hids-client tianji Normal 1in Total | Normal None Details | Upgrade | Unpublish
kube-base tianji Normal 7inTotal | Normal default Details Details | Upgrade | Unpublish
kube-register tianji Normal 1inTotal | Normal default Details Details | Upgrade | Unpublish
logsenicelite-Kafka lagsenvicelite Normal 2inTotal | Normal None Details | Upgrade | Unpublish
Section Parameter Description
o Desired State: All clusters in a project have reached the
desired state.
Status o Not Desired State: A project has reached the desired
state for the first time but a server role has not reached
the desired state due to undefined reasons.
Project The project to which the cluster belongs.
Region The region where the cluster is deployed.
Included Server . .
The number of server roles included in the cluster.

Roles

Included . . )

. The number of machines included in the cluster.

Machines
The status of the task. Click View to view the task details.
o Successful: The task is successful.
o Preparing: Data is being synchronized and the task is not

started.
Task Status o In Progress: The cluster has a changing task.
o Paused: The task is paused.
o Failed: This task failed.
o Terminated: The task is manually terminated.
o Pseudo-clone: The system is not cloned when a
machine is added to the cluster.
©) Clone Mode

o Real Clone: The system is cloned when a machine is
added to the cluster.
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Section Parameter Description
System The name of the system service template used by the
Configuration cluster.
Git Version The change version to which the cluster belongs.

The access control among processes. By default, security
Security authentication is disabled in non-production environments.
Authentication You can enable or disable security authentication based on
your business requirements.

o Ordinary Cluster: an operations unit of machine groups,
where multiple services can be deployed.

o Virtual Cluster: an operations unit of services, which can
manage versions of software on machines within several
physical clusters in a centralized manner.

o RDS: atype of cluster that renders special cgroup

Type configurations based on certain rules.

o NETFRAME: a type of cluster that renders special
configurations for special scenarios of Server Load
Balancer (SLB).

© T4: atype of cluster that renders special configurations
for the mixed deployment of e-commerce.

Apsara Stack provides only ordinary clusters.

The status of each service in the cluster. You can also
upgrade or unpublish a service.

o Normal: The service works normally.
o Not Deployed: No machine is deployed on the service.
o Changing: Some server roles in the service are changing.

o Operating: No server role is changing, but a server role is
performing operations and maintenance (0&M)
operations.

Services

o Abnormal: No server role is changing or the machines
where server roles are deployed are not performing O&M
operations. However, the server role status is not good
or the version that the service runs on the machines is
different from the desired state configuration.

o The running status and monitoring status of each machine in
Machines the cluster. You can also view details of server roles that are
deployed on each machine.

Cluster . . ) .
. . The configuration file used in the cluster.
Configuration
The operation logs. You can also view the version

Operation Log differences
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Section Parameter Description
Cluster
The details of resources that can be filtered.
Resource
Service . L . -
. The inspection information of each service in the cluster.
Inspection

5.4.2.5.3. View configuration information of a cluster

This topic describes how to view configuration files and folders of a cluster.

Procedure

1. Log onto Apsara Infrastructure Management Framework.

2. Use one of the following methods to go to the Cluster Configuration tab to view configuration

files and folders.

o Enter a cluster name in the search box in the upper-right corner of the page. Click Operations
next to the found cluster. On the Cluster Details page, click the Cluster Configuration tab.

o Inthe left-side navigation pane, choose Operations > Cluster Operations. On the Cluster
Operations page, find a cluster and click Operations inthe Actions column. On the Cluster
Details page, clickthe Cluster Configuration tab.

Services Machines

(W Clust.. J [ W Templa... 4

Search B

+ Add File

I cluster.cont
B kv.conf

B machine_group.cont

I plan.conf
M [ services

B shutdown_dependence json

I tag cont

Cluster Configuration

Operation Log Cluster Resource Service Inspection

I cluster.conf | Cluster File

CloneTemplateBasis: MachineGroup
Group: tianji

Legacy: "False"

Machines:

Name: tianji-paas-A-666b
Project: tianji
Region: regionl

The following table describes configuration files and folders of a cluster.

Parameter

cluster.conf

kv.conf

machine_group.conf

Description

The configuration file of the cluster, including the cluster name,
cluster type, and machines.

The file that stores the values used to replace template
placeholders when configurations are rendered.

The file that stores information of machine groups in a cluster.
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Parameter Description

The file that defines dependencies between services and

plan.conf . .
configuration upgrade parameters.
services The folder that stores configurations of each service.
shutdown_dependence.json The shutdown dependency file.
The file that stores the tags used to calculate tag expressions
tag.conf

when configurations are rendered.

5.4.2.5.4. View operations logs

This

topic describes how to view differences between Git versions from operation logs.

Procedure

1.
2.

3.

Log onto Apsara Infrastructure Management Framework.
Use one of the following methods to go to the operation logs of a cluster:

o Enter a cluster name in the search box in the upper-right corner of the page. Click Operations
next to the found cluster. On the Cluster Details page, click the Operation Log tab.

o Inthe left-side navigation pane, choose Operations > Cluster Operations. Onthe Cluster
Operations page, find a cluster and click Operations inthe Actions column. On the Cluster
Details page, clickthe Operation Log tab.

achines Cluster Configuratio Operation Log

Submission Time | 12/04/18 2M118 Submitter | Please input Senvices | All Refresh

Deseription Operation Type Status Submitter Actions

commit by tianjiimporar

View the version differences on the Operation Log tab.
i. Find the operation log that you want to view and click View Version Differences inthe
Actions column.

i. Onthe Version Differences page, set Configuration Type to Extend Configuration or
Cluster Configuration.

m Extend Configuration: displays the cluster configuration merged with the template
configuration.
m Cluster Configuration: displays the cluster configuration.
m Cluster configuration description: Each cluster contains its dedicated configurations, such
as the list of machines.

m Template configuration description: A template that has the same configurations can be
used to deploy a service to multiple clusters.

iii. Select a basic version below Configuration Type. Then, a difference file is displayed in the
lower part of the page.
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iv. Select a difference file fromthe Different File drop-down list to view the content of each
difference file.

5.4.2.6. Service operations

5.4.2.6.1. View the service list

T his topic describes how to view all services and their information.

Procedure

1. Log onto Apsara Infrastructure Management Framework.
2. Use one of the following methods to go to the service list:

o Onthe Homepage page, move the pointer over the Instances section and click Details in the
upper-right corner.

o Inthe left-side navigation pane, choose Operations > Service Operations.

Service Operation:

| Services

Services | Enter a service name
Services Description Clusters Included Service Templates Actions

tinTotal | Desired Stater 1

3inTotsl | Dasired Stae: 3

5 in Tota!

3in Tota:

tinTotal | Desired State: 1

in Tota

5 in Tota!

5 in Tota!

The following table describes the information displayed in the service list.

Parameter Description
Services The name of the service. Click the service name to view the service details.
Clusters The number of clusters where the service is deployed and the cluster status.

Included Service

The number of service templates that are included in the service.
Templates

Actions Click Operations to go to the Service Details page.

3. (Optional)Enter a service name in the search box to search for the service.

5.4.2.6.2. View details of a server role

This topic describes how to view details of a server role.

Procedure
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1. Log onto Apsara Infrastructure Management Framework.
In the left-side navigation pane, choose Operations > Service Operations.

(Optional)Enter a service name in the search box to search for the service.

A w N

Click the service name or click Operations inthe Actions column.

Operations / Service Operations / Service Details

| Services Ali-tianji-machine-decider

Included Clusters: 2 included Server Roles: 1 Included Service Templates: 0

Service Template  Clusters

Template | Please input Group | Al + Add Template

Template Type Description Group Last Update 1 References || Actions

5. Onthe Clusters tab, click a status in the Server Role Status column to view the server roles
included in a cluster.

| Service Details | ECS-108-A-081a / EbsTankMaster
Refresh

Server Role | Enter a server role

@ EbsTankMasterTankMaster# | | @ EbsTankMaster TankMasterDBManagers

Al:3 | ) Nomal(3) | Reset

Machines | Enter one of more hostnames/IP addresses

Machines Server Role Status Metric Actions

Terminal
Normal  Details View
o ’ | Restart Server Role

Terminal
Normal ~ Details
Normal | Restart Server Role

Terminal
Nomal  Details View
| Restart Server Role

total 3 items 10 itemPage Goto | 1 | Page

6. Enter a keyword in the search box to search for a server role. Then, the details of the server role are
displayed in the list.

Parameter Description

The machine to which the server role belongs. Click the machine name to

Machines
view the machine details.

The status of the server role. Click Details to view the basic information,
Server Role Status application version information, application process information, and
resources of the server role.

Metric Click View to view the server role and machine metrics.

o Click Terminal to log onto the machine and perform operations.

Actions
o C(Click Restart Server Role to restart the server role.

5.4.2.7. Machine Operations

This topic describes how to view the statistics of all machines.

Procedure

1. Log onto Apsara Infrastructure Management Framework.
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2. Use one of the following methods to go to the machine list:

o Onthe Homepage page, move the pointer over the Machines section and click Details in the
upper-right corner.
o Inthe left-side navigation pane, choose Operations > Machine Operations.

Opesstions | Mackine Operations
| Machines

Project Al Clusters | Enter a cluster name Machines | Enter one or more hostnames/P addresses

Hostname Clusters Project Region Status 7 Machine Metrics. Actions

st rds cn 1 Normal ~ Details View Operations | Terminal | Machine Management v
amit 300 tianji c 1 MNormal ~ Details View Operations | Terminal | Machine Management
amit 500 tianji o o Normal ~ Details View Operations | Terminal | Machine Management
el 0 tianji ¢ ol Normal ~ Details View Operations | Terminal | Machine Management
am11 .

0 tianji ! a1 Normal  Details View Operations | Terminal | Machine Management v
amtt . ,
500 tianji S ol Normal ~ Details View Operations | Terminal | Machine Management
amtt ;
60> tianji c 1 Normal ~ Details View Operations | Terminal | Machine Management v
56309010.cloud. a09.am11
et Db tianj-psas-A- 8500 tianji cn-gethyq-dot Normal  Details View Operations | Terminal | Machine Management v

3. (Optional)Select a project fromthe drop-down list or enter a cluster or machine name to search for
the machine.

Parameter Description

Hostname Click a hostname to go to the Machine Details page.

Stat The status of a machine. Click the |7/ icon to filter machines. Click Det ails.
atus

Then, the Status Details of Machine dialog box appears.

Click View. Then, the Metrics dialog box appears.
Metrics x

Server Role Metric

Al 103 | 00d (103) [ Reser Server Role | Enter a server role Metric | Enter a metric name

Alert Status

Dec 1. 2010, 14:42:45

Dec 11, 2010, 14:4245

Dec 11, 2010, 14:42:45

Dec 11, 2010, 13122

Machine Metrics

Metrics are displayed on the Server Role Metric and Machine Metrics
tabs. You can view the status and update time of each metric.

Enter a keyword in one of the search boxes in the upper-right corner to
search for a server role or metric. You can also select the status in the upper-
left corner to filter metrics.
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Parameter Description

o Click Operations to go to the Machine Details page.

o Click Terminal to log onto the machine and perform operations. You can
select multiple machines and then click Batch Terminal in the upper-right

Actions . . .
corner to log on to multiple machines at a time.

o (Click Machine Management to perform an out-of-band restart operation
on the machine.

5.4.2.8. Monitoring center

You can view the alert status, alert rules, and alert history in the monitoring center.

5.4.2.8.1. View the status of a metric

This topic describes how to view the status of a metric.

Procedure

1. Log onto Apsara Infrastructure Management Framework.
In the left-side navigation pane, choose Operations > Service Operations.
(Optional)Enter a service name in the search box to search for the service.

Click Operations inthe Actions column.

ok wonN

Onthe Clusters tab, use filter conditions to find a cluster. Click Operations in the Actions column
corresponding to the cluster.

6. Onthe Cluster Details page, select a server role and click View in the Metric column
corresponding to a machine to view the server role and machine metrics.

Services Aachines

Server Role | Enter a server role Refresh

‘o EcsRiver RiverCluster#| | e EcsRiver RiverClusterDBManager# | | e EcsRiver RiverSenver#

Diagnostic Mode:
A3 | Mormal (3) | Reset
Machines | Enter one or more hostnames/IP addresses

Machines Server Role Status Metric Actions

5.4.2.8.2. View the alert status

This topic describes how to view the alerts related to different services and the alert details.

Procedure

1. Log onto Apsara Infrastructure Management Framework.

2. Inthe left-side navigation pane, click Monitoring. On the Monitoring page, click Go to go to the
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Alert Status page.
3. Inthe top navigation bar, choose Monitoring > Alert Status.

| Alert Status

Serice Al - Cluster Al - Enter an alert name ime Rang

20:10:00 Search

tianji shhCluster-A- cluster=slbCiuster-A-20191030-2355 host=a

tianji sIbCluster-A... cluster=slbChuster-A-20191030-2565,host=a... — mema_cluster_host

tanji mongods-A- cluster=mongodh-A-20181030-288a host=35 memo_cluster_host

tianji mongods-A-.. cluster=mongodb-A-20181030-28a nost=5.. mema_cluster_host

s 7 Hours & Minutes 35 Seco

4. (Optional)Search for an alert by service name, cluster name, alert name, or alert time range.

5. View alert details onthe Alert Status page. The following table describes the related

parameters.
Parameter Description
Service The name of the service.
Cluster The name of the cluster where the service is deployed.
The name of the monitored instance.
Instance
Click the name of an instance to view the alert history of the instance.
Alert Status Two alert states are available, which are Normal and Alerting.

Alerts are divided into five levels in descending order of severity:
o PO: an alert that has been cleared
o P1: anurgent alert
Alert Level o P2: a major alert
o P3: aminor alert

o P4: areminder alert

The name of the alert.

Alert Name

Click the name of an alert to view alert rule details.
Alert Time The time when the alert is triggered and how long the alert lasts.
Actions Click Show to view the data before and after the alert time.

5.4.2.8.3. View alert rules

This topic describes how to view alert rules.

Procedure
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1. Log onto Apsara Infrastructure Management Framework.

2. Inthe left-side navigation pane, click Monitoring. On the Monitoring page, click Go to goto the
Alert Status page.

3. Inthe top navigation bar, choose Monitoring > Alert Rules.

| Alert Rules

Senice Al - Cluster Al

yundun-semawaf

yundun-semaws

Sra_avg>5001Skoss_max>60:$na_sug=400$ioss_ma6l

leount=0

yundun-co _sss_openapi Stotakount-d

yundun-consoleservice check_segis_openspi Stotakountd

=]

B OB B B B B B B B e

4. (Optional)Search for alert rules by service name, cluster name, or alert name.

5. View alert rules onthe Alert Rules page. The following table describes the related parameters.

Parameter Description

Service The name of the service.

Cluster The name of the cluster where the service is deployed.

Alert Name The name of the alert.

Alert Conditions The conditions that trigger the alert.

Periods The frequency at which the alert rule is executed.

Alert Contact The groups and members to notify when the alert is triggered.

The status of the alert rule.
Status © Running: Click it to stop the alert rule.

o Stopped: Click it to execute the alert rule.

5.4.2.8.4. View the alert history

This topic describes how to view the historical alerts related to different services and the alert details.

Procedure

1. Log onto Apsara Infrastructure Management Framework.

2. Inthe left-side navigation pane, click Monitoring. On the Monitoring page, click Go to go to the
Alert Status page.

3. Inthe top navigation bar, choose Monitoring > Alert History.
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| Alert History\ Notifications H Suppressions

Service Al ~

1 Hour 12 Hours 1 Day

Service Cluster

ark-aiops

ark-aiops

ark-aiops

default

4. (Optional)Search for an alert by service name, cluster name, or alert time range.

5. View the alert history onthe Alert History page. The following table describes the related

parameters.
Parameter
Service
Cluster
Alert Instance

Status

Alert Level

Alert Name

Alert Time
Alert Contact

Actions

Cluster

1 Week

Al ~

1 Month 3 Months

Alert Instance

app=

seve

app=

seve

criti

erit..

Description

Status

@Restored

©Restored

Alert Level

[ Restorea |

P3

Alert Name

KonglngressSucces
sRate

HighContainerCPUL
oad

SeedArgoWfSucces
sRate

AggregatedAPIError
s

Custom  10/25/20, 15:27:00 ~ 10/26/20, 15:27:00

Alert Time

Oct 25, 2020, 15:31:15

Oct 25, 2020, 15:31:15

Oct 25, 2020, 15:31:23

Oct 25, 2020, 15:31:37

The name of the service to which the alert belongs.

The name of the cluster where the service is deployed.

The name of the instance where the alert is triggered.

Alert Contact

Two alert states are available, which are Normal and Alerting.

Alerts are divided into five levels in descending order of severity:

o PO: an alert that has been cleared

o P1: anurgent alert
o P2: amajor alert
© P3: aminor alert

o P4: areminder alert

The name of the alert.

Click the name of an alert to view alert rule details.

The time when the alert is triggered.

The groups and members to notify when the alert is triggered.

Click Show to view the data before and after the alert time.

5.4.2.9. View tasks

This topic describes how to view the submitted tasks and their status.

Procedure

Actions

Show
Show
Show

Show
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1. Log onto Apsara Infrastructure Management Framework.
2. Use one of the following methods to go to the task list:
o Inthe left-side navigation pane, choose Tasks > My T asks.

o Inthe left-side navigation pane, choose Tasks > Related T asks.

3. Clickthe v iconinthe Status columnto filtertasks.

4. Find the task that you want to view and click the task name or Det ails in the Actions column.

5. View the status and progress of each cluster and server role on the Task Det ails page.

sion Time: Oct 23, 2020, 1049:56. Submitter:  aliyuntest

Task Description: commit by tianji importer

ServerRole | Al

(B Included Clusters progress: em— 10 ()

Clusters Region T Status Progress Start Time At

@ change Details | Clu 0b Service Upgrade (2)

Server Role Services

5.4.2.10. Reports

5.4.2.10.1. View reports

T his topic describes how to view report data.

Context

The following reports are available in the Apsara Infrastructure Management Framework console:
e Systemreports: default and common reports in the system.

e Allreports: includes system reports and custom reports.

Procedure

1. Log onto Apsara Infrastructure Management Framework.

2. Inthe left-side navigation pane, clickReports. On the Reports page, click Go to go to the All
Reports page.

| All Reports | Favorites

The following table describes information about reports.
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Parameter

Report

Group

Status

Public

Created By

Published At

Actions

Description

The name of the report.

Move the pointer over the down arrow next to Report and search by report
name.

The group to which the report belongs.

Move the pointer over the down arrow next to Group and search by group name.

Specifies whether the report is published.
© Published
© Not Published

Specifies whether the report is public.
o Public: visible to all logon users.

o Private: visible only to the current logon user.

The person who creates the report.
The time when the report is created and published.

Click Add to Favorites to add the report to your favorites. Then, you can view
the report by choosing Reports > Favorites in the top navigation bar.

3. (Optional)Enter a report name in the search box to search for the report.

4. Clickthe report name to go to the corresponding report details page. For more information about

reports, see Appendix.

5.4.2.10.2. Add a report to favorites

This topic describes how to add frequently used reports to favorites. Then, you can find themon the

Home or Favorites page.

Procedure

1.

U

5.4.2.11. Tools

Log on to Apsara Infrastructure Management Framework.

In the left-side navigation pane, click Reports. On the Reports page, click Go to go to the All

Reports page.

(Optional)Search for a report in the search box.

Click Add to Favorites inthe Actions column corresponding to the report.

Inthe Add to Favorites dialog box, entertags for the report.

Click Add to Favorites.
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5.4.2.11.1. Machine tools

The Machine Tools module guides operations personnel to perform Operation & Maintenance (O&M)

operations in common scenarios.

Procedure

1. Log onto Apsara Infrastructure Management Framework.

2. Inthe left-side navigation pane, choose Tools > Operation Tools > Machine Tools. Onthe
Machine Tools page, click Go to open the target page.

3. Select the operation scene according to actual situations.

Operation scene

Scene 1: NC Scale-out (with
existing machines)

Scene 2: Host Scale-out (with
existing machines)

Scene 3: NC Scale-in

Scene 4: Host Scale-in

Description

Scales out an SRG of the worker
type.

Scales out the
DockerHost#Buffer of an
Apsara Infrastructure
Management Framework
cluster.

Scales in an SRG of the worker
type.

Scales in the DockerHost#Buffer
of an Apsara Infrastructure
Management Framework
cluster.

Action

Select a target cluster and a
target SRG. Select the machines
to be scaled out in the left-side
section and then click Select>
to add them to the right-side
section. Click Submit and then
click Confirm in the displayed
dialog box.

Select a target cluster. Select
the machines to be scaled out
in the left-side section and then
click Select> to add them to
the right-side section. Click
Submit and then click Confirm
in the displayed dialog box.

Select a target cluster and a
target SRG. Select the machines
to be scaled inin the left-side
section and then click Select>
to add them to the right-side
section. Click Submit and then
click Confirm in the displayed
dialog box.

Select a target cluster. Select
the machines to be scaled inin
the left-side section and then
click Select> to add them to
the right-side section. Click
Submit and then click Confirm
in the displayed dialog box.
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Operation scene

Scene 5: VM Migration

Scene 6: Host Switching

Description

Migrates virtual machines (VMs)
from a host to another host.

Switches from a standby host
to a primary host.

5.4.2.11.2. IDC shutdown

Action

Select a source host and a
destination host. Select the
VMs to be migrated in the left-
side section and then click
Select> to add them to the
right-side section. Click Submit
and then click Confirm in the
displayed dialog box.

Select a source host and a
destination host. Click Submit
and then click Confirm in the
displayed dialog box.

In some scenarios such as vehicle-mounted ones, you can shut down all machines of all clusters within

an IDC with one click.

Prerequisites

The total number of machines of all clusters within an IDC is not more than 25.

Context

When you perform IDC shutdown, business clusters are shut down first, and then the base cluster is shut

down.

Procedure

1. Log onto Apsara Infrastructure Management Framework.

2. Inthe left-side navigation pane, choose Tools > IDC Shutdown. In the right-side workspace, click

Go.

3. Onthe IDC Shutdown page, click Start Shutdown. Inthe Confirm Operation message, enter SH

UTDOWN.

warning The IDC shutdown operation will shut down all services and machines and thus

cause business interruption.
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4,

5.

Confirm Operation

Shutdown operation will cause all clusters shut down step by step. Confirm to
start shutdown.

Enter "SHUTDOWN" to confirm the operation.

SHUTDOWN

If you are sure that you want to perform IDC shutdown, click Confirm.

Warning Backend services need to communicate with the frontend shutdown page
during the IDC shutdown process. Do not close the shutdown page until the shutdown is
complete.

View the IDC shutdown progress and the status of clusters, machines, and server roles.

10C Shutdown T

it takes a long time to shut down all clusters and machines within an environment. You can view the
shutdown progress on the IDC Shutdown page. The following states are available for clusters,
machines, and server roles:

o normal: A cluster, machine, or server role is running normally.

o shutdown: A cluster, machine, or server role is shut down.

o shutdowning: A cluster, machine, or server role is being shut down.

o timeoutShutdown: The shutdown of a cluster, machine, or server role timed out.
o nearShutdown: A cluster, machine, or server role is about to be shut down.

o error: An error occurred during the shutdown of a cluster, machine, or server role.

You can performthe following operations:
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o View the IDC shutdown progress: In the upper part of the IDC Shutdown page, view the IDC
shutdown progress.

o View the cluster status: Inthe Cluster List section, view the status of each cluster, the total
number of machines in each cluster, and the number of machines in each state.

o View the machine status: Inthe Cluster List section, click a status corresponding to a cluster. In
the Machine List section, view all machines in the corresponding state in the cluster, the total
number of server roles on each machine, and the number of server roles in each state.

o View the server role status: Inthe Machine List section, click a status corresponding to a

machine. In the SR List --xxx message, view all server roles in the corresponding state onthe
machine.

SR List -- Srars i | p =l

Server Role Status Y

tianji. TianjiClient#

@ Note

In the left-side navigation pane, click Go. On the All Reports page, enter the entire or a part
of Machine Power On or Off Statuses of Clusters inthe Fuzzy Search search box. In
the search results, clickMachine Power On or Off Statuses of Clusters to view the
status of each serverrole.

o Filter clusters or machines: In the Cluster List or Machine List section, clickthe filtericoninthe
Status column and select a status to filter all clusters or machines in the corresponding state.

o Refresh data: ClickRefresh in the upper-right corner to refresh data.

If the status of all clusters in the Cluster List section is shutdown, the IDC shutdown operation
succeeds. After the base clusteris shut down, the OPS1 server is also shut down. Then, the Apsara
Infrastructure Management Framework console is inaccessible.

6. After all base machines are shut down and become inaccessible, go to the IDC and confirmthat all
machines are powered off.

What's next

If you want to use the machines in the future, power on all machines one by one in the IDC and wait
until all services reach the desired state.

5.4.2.11.3. View the clone progress
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This topic describes how to go to the OS Provision console (Corner Stone) by using Apsara
Inf rastruct ure Management Framework, which allows you to know the progress, status, and errors of
the machine installation.

Prerequisites

You have obtained the username and password of the OS Provision console fromthe delivery
personnel.

Context

Apsara Infrast ructure Management Framework provides a quick entry of the QS Provision console, which
allows you to view the machine installation details. The OS Provision console allows you to view the

machine clone details and then you can know the progress and status of the machine installation and
locate the installation faults.

Procedure

1. Log onto Apsara Infrastructure Management Framework.
2. Inthe left-side navigation pane, choose Tools > Clone Progress.

3. Onthe logon page of the Corner Stone, enter the Username and Password, and then click
Submit.

5.4.2.12. Metadata operations

In this version, you can use only command lines to perform metadata operations.

5.4.2.12.1. Common parameters

Common parameters consist of the common request parameters and the common response
parameters.

Common request parameters
Common request parameters are request parameters that you must use when you call each API.

Parameter descriptions

Name Type Required Description

The APl name. For more
information about the
valid values, see APIs on
the control side and
APIs on the deployment
side.

Action String Yes

Common response parameters

Each time you send a request to call an APJ, the system returns a unique identifier, regardless of
whether the call is successful.

Parameter descriptions
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Name Type Required Description

The request ID.

The request ID is

RequestID String Yes returned, regardless of
whether the API call is
successful.

Code String No The error code.

The reason of failure,
Message String No which appears when the
API call fails.

The type varies with the

request, which is The request result,

Result subject to the returned No which appears when the
result of the specific API call is successful.
API.

@ Note
e |f the APIcallis successful, RequestID is returned and the HTTP return code is 200.

e If the APIcall fails, RequestID, Code, and Message are returned and the HTTP return code is
4XX Or 5xX.

Instance types
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"rds.mys2.small":{
"cpu":2,
"memory":4096,
"disk":51200,
"max_connections":60

b

"rds.mys2.mid":{

"cpu":4,
"memory":4096,
"disk":51200,
"max_connections":150

b

"rds.mys2.standard":{
"cpu":6,
"memory":4096,
"disk":51200,
"max_connections":300

b

"rds.mys2.large":{
"cpu":8,
"memory":7200,
"disk":102400,
"max_connections":600

b

"rds.mys2.xlarge":{
"cpu™:9,
"memory":12000,
"disk":204800,
"max_connections":1500

b

"rds.mys2.2xlarge":{
"cpu":10,
"memory":20000,
"disk":512000,

"max_connections":2000
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5.4.2.12.2. Connect to APl operations

T his topic describes how to connect to control-side and deployment-side APl operations.

Procedure
1. Log onto Apsara Infrastructure Management Framework.
2. Inthe left-side navigation pane, choose Operations > Machine Operations.

3. Select a project fromthe drop-down list or enter a cluster or machine name to search forthe
target machine.

4. Connect to APl operations.
o Connect to control-side APl operations
a. Find the target machine and click Terminal in the Actions column to log on to the machine.

b. Onthe command line, enter the following command and press the Enter key to obtain the
value of intranet-domain.
grep 'intranet-domain' /cloud/app/tianji/TianjiClient#/service_manager/current/conf.global/kv.j

son

termenal service to reflect shell to web

~  kBs-A-2162

TSl "] amtest?FD)

¢. Use one of the following methods to connect to control-side APl operations. ListInstance is
used in the example.

m GET request

curl 'xdb-master.xdb.{intranet-domain}:15678? Action=ListInstance'

m POST request
curl 'xdb-master.xdb.{intranet-domain}:15678' -X POST -d '{"Action":"ListInstance"}'
o Connect to deployment-side APl operations

a. Find the target machine and record the IP address in the Hostname column.

b. Use one of the following methods to connect to deployment-side APl operations.
CheckState is used in the example.

Assume that the IP address of the target machine is 127.0.XX.XX.

m GET request
curl'127.0.XX.XX:18765? Action=CheckState&Port=3606'
m POST request

curl'127.0.XX.XX:18765' -X POST -d '{"Action":"CheckState","Port":3606}'
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5.4.2.12.3. APIs on the control side

5.4.2.12.4. APIs on the deployment side

5.4.2.13. Appendix

5.4.2.13.1. Project component info report

This report displays the name and status for each type of project components, including services, server

roles, and machines.

ftem

Project

Cluster

Service

Server Role

Server Role
Status

Server Role
Action

Machine Name

IP

Machine Status

Machine Action

Description

The project name.

The name of a cluster in the project.
The name of a service in the cluster.

The name of a server role in the service.

The running status of the server role on the machine.

The action that the server role performs on the machine. Data is available only when
Apsara Infrastructure Management Framework asks the server role to perform certain
actions, such as rolling and restart actions.

The hostname of the machine.

The IP address of the machine.

The running status of the machine.

The action that Apsara Infrastructure Management Framework asks the machine to
perform, such as the clone action.

5.4.2.13.2. IP list

This report displays the IP addresses of physical machines and Docker applications.

IP List of Physical Machines

ltem

Project

Cluster

Description

The project name.

The cluster name.
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item

Machine Name

IP

Description

The hostname of the machine.

The IP address of the machine.

IP List of Docker Applications

ltem

Project

Cluster

Service

Server Role

Machine Name

Docker Host

Docker IP

Description

The project name.

The cluster name.

The service name.

The server role name.

The hostname of the machine.

The Docker hostname.

The Docker IP address.

5.4.2.13.3. Machine info report

This report displays the statuses of machines and server roles on the machines.

Machine Status

Displays all the machines currently managed by Apsara Infrastructure Management Framework and their
corresponding statuses. In the Global Filter section at the top of the page, select the project, cluster,
and machine fromthe project, cluster, and machine drop-down lists, and then click Filter on the

right to filter the data.

ltem

Machine Name

IP

Machine Status

Machine Action

Machine Action
Status

Status Description

Description

The machine name.

The IP address of the machine.

The machine status.

The action currently performed by the machine.

The action status.

The description about the machine status.

Expected Server Role List
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Select a row in the Machine Status section to display the corresponding information in this list.

ltem Description
Machine Name The machine name.
Server Role The name of the expected server role on the machine.

Abnormal Monitoring Status

Select a row in the Machine Status section to display the corresponding information in this list.

ltem Description

Machine Name The machine name.

Monitored Item The name of the monitored item.

Level The level of the monitored item.

Description The description of the monitored item contents.
Updated At The updated time of the monitored item.

Server Role Version and Status on Machine

Select arow inthe Machine Status section to display the corresponding information in this list.

ltem Description

Machine Name The machine name.

Server Role The server role name.

Server Role Status The status of the server role.

Target Version The expected version of the server role on the machine.
Current Version The current version of the server role on the machine.

Status Description The description about the status.

Error Message The exception message of the server role.

Monitoring Status

Select arow in the Machine Status section to display the corresponding information in this list.

ltem Description
Machine Name The machine name.
Server Role The server role name.
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ltem Description

Monitored ltem The name of the monitored item.

Level The level of the monitored item.

Description The description of the monitored item contents.
Updated At The updated time of the monitored item.

5.4.2.13.4. Rolling info report

This report displays the running and completed rolling tasks and the task-related status.

Choose a rolling action

This list only displays the running rolling tasks. If no rolling task is running, no data is available in the list.

ltem Description

Cluster The cluster name.

Git Version The version of change that triggers the rolling task.

Description The description about the change entered by a user when the user submits the change.
Start Time The start time of the rolling task.

End Time The end time of the rolling task.

:;lbmitted The ID of the user who submits the change.

Rolling Task

The current status of the rolling task.
Status

Submitted

At The time when the change is submitted.

Server Role in Job

Select arolling taskin the Choose a rolling action section to display the rolling status of server roles
related to the selected task. If no rolling task is selected, the server role statuses of all historical rolling
tasks are displayed.

ltem Description
Server Role The server role name.

Server Role

The rolling status of the server role.
Status
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ltem

Error
Message

Git Version

Start Time

End Time

Approve
Rate

Failure Rate

Success Rate

Description

The exception message of the rolling task.

The version of change to which the rolling task belongs.
The start time of the rolling task.

The end time of the rolling task.

The proportion of machines that have the rolling task approved by the decider.

The proportion of machines that have the rolling task failed.

The proportion of machines that have the rolling task succeeded.

Server Role Rolling Build Information

The source version and target version of each application under the server role in the rolling process.

ltem

App

Server Role

From Build

To Build

Description

The name of the application that requires rolling in the server role.
The server role to which the application belongs.

The version before the upgrade.

The version after the upgrade.

Server Role Statuses on Machines

Select a server role inthe Server Role in Job section to display the deployment status of this server
role on the machine.

ltem

Machine
Name

Expected
Version

Actual
Version

State

Action Name

Description

The name of the machine on which the server role is deployed.

The target version of the rolling.

The current version.

The status of the server role.

The Apsara Infrastructure Management Framework action currently performed by the
server role.
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ltem Description

Action

The action status.

Status

5.4.2.13.5. Machine RMA approval pending list

Some Apsara Infrastructure Management Framewaork actions (such as restart) on machines and server
roles can be triggered by users, but this type of actions must be reviewed and approved. T his report is

used to process the actions that must be reviewed and approved.

Machine

Displays the basic information of pending approval machines.

Item

Project
Cluster
Hostname

P

State

Action Name
Action Status

Actions

Machine Serverrole

Description

The project name.

The cluster name.

The hostname of the machine.
The IP address of the machine.

The running status of the machine.

The action on the machine.

The status of the action on the machine.

The approval button.

Displays the information of server roles on the pending approval machines.

ltem

Project

Cluster

Hostname

IP

Serverrole

State

Action Name

Description
The project name.

The cluster name.

The hostname of the machine.

The IP address of the machine.

The server role name.

The running status of the server role.

The action on the server role.
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ltem Description
Action Status The status of the action on the server role.
Actions The approval button.

Machine Component

Displays the hard disk information of pending approval machines.

ltem Description

Project The project name.

Cluster The cluster name.

Hostname The hostname of the machine.
Component The hard disk on the machine.

State The running status of the hard disk.
Action Name The action on the hard disk.

Action Status The status of the action on the hard disk.
Actions The approval button.

5.4.2.13.6. Registration vars of services

This report displays values of all service registration variables.

ltem Description
Service The service name.
Service

. . The service registration variable.
Registration

Cluster The cluster name.

Update Time The updated time.

5.4.2.13.7. Virtual machine mappings

Use the globalfilter to display the virtual machines of a specific cluster.

Displays the information of virtual machines in the cluster. Data is available only when virtual machines
are deployed in the cluster.
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ltem Description

Project The project name.

Cluster The cluster name.

VM The hostname of the virtual machine.

The hostname of the physical machine on which the virtual machine is

Currently Deployed On currently deployed.

The hostname of the physical machine on which the virtual machine is

Target Deployed On expected to be deployed.

5.4.2.13.8. Service inspector report

Use the globalfilterto display the service inspection reports of a specific cluster.

Service Inspector: Data is available only for services with inspection configured.

ltem Description

Project The project name.

Cluster The cluster name.

Service The service name.

Description The contents of the inspection report.
Level The level of the inspection report.

5.4.2.13.9. Resource application report

In the Global Filter section, select the project, cluster, and machine fromthe project, cluster, and
machine drop-down lists and then click Filter on the right to display the corresponding resource
application data.

Change Mappings

ltem Description

Project The project name.

Cluster The cluster name.

Version The version where the change occurs.

Resource Process

The resource application status in the version.
Status

Msg The exception message.
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ltem Description
Begintime The start time of the change analysis.
Endtime The end time of the change analysis.

Changed Resource List

ltem Description

Res The resource ID.

Type The resource type.

Name The resource name.

Owner The application to which the resource belongs.
Parameters The resource parameters.

Ins The resource instance name.

Instance ID The resource instance ID.

Resource Status

ltem Description

Project The project name.

Cluster The cluster name.

Service The service name.

Server Role The server role name.

APP The application of the server role.
Name The resource name.

Type The resource type.

Status The resource application status.
Parameters The resource parameters.
Result The resource application result.
Res The resource ID.

The status of the interaction with Business Foundation System during the VIP

Reprocess Status L
resource application.
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ltem

Reprocess Msg

Reprocess Result

Refer Version
List

Error Msg

Description

The error message of the interaction with Business Foundation System during the VIP
resource application.

The result of the interaction with Business Foundation System during the VIP resource
application.

The version that uses the resource.

The exception message.

5.4.2.13.10. Statuses of project components

This report displays the status of all server roles in an abnormal status on machines of the project, and
the monitoring information (alert information reported by the server role to Apsara Infrastructure
Management Framework monitor) of server roles and machines.

Error State Component Table

Only displays the information of server roles that are not in GOOD status and server roles to be

upgraded.
ltem
Project
Cluster
Service
Server Role
Machine Name
Need Upgrade
Server Role Status

Machine Status

Description

The project name.

The cluster name.

The service name.

The server role name.

The machine name.

Whether the current version reaches the final status.

The current status of the server role.

The current status of the machine.

Server Role Alert Information

Select arow inthe Error State Component Table section to display the corresponding information in

the list.

ltem

Cluster

Service

Description

The cluster name.

The service name.
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item

Server Role

Machine Name

Monitored Item

Level

Description

Updated At

Description

The server role name.

The machine name.

The monitored item name of the server role.
The alert level.

The description about the alert contents.

The updated time of the alert information.

Machine Alert Information

Select arow inthe Error State Component Table section to display the corresponding information in

the list.

ltem

Cluster

Machine Name

Monitored Item

Level

Description

Updated At

Description

The cluster name.

The machine name.

The monitored item name of the server role.
The alert level.

The description about the alert contents.

The updated time of the alert information.

Service Inspector Information

Select arow inthe Error State Component Table section to display the corresponding information in

the list.

ltem

Cluster

Service

Server Role

Monitored Item

Level

Description

Updated At

Description

The cluster name.

The service name.

The server role name.

The monitored item name of the server role.
The alert level.

The description about the alert contents.

The updated time of the alert information.
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5.4.2.13.11. Relationship of service dependency

This report displays the dependencies among server roles. Use the global filter to display the data of a
specific clusterin the list.

ltem Description

Project The project name.

Cluster The cluster name.

Service The service name.

Server Role The server role name.

E:sia::ent The service on which the server role depends.
Dependent

The server role on which the server role depends.
Server Role

Dependent

The cluster to which the dependent server role belongs.
Cluster

Dependency in

. Whether the dependent server role reaches the final status.
Final Status

5.4.2.13.12. Check report of network topology

This report checks if network devices and machines have wirecheck alerts.

Check Report of Network Topology

Checks if network devices have wirecheck alerts.

ltem Description

Cluster The cluster name.

Network Instance The name of the network device.

Level The alert level.

Description The description about the alert information.

Check Report of Server Topology

Checks if servers (machines) have wirecheck alerts.
ltem Description

Cluster The cluster name.
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item

Machine Name

Level

Description

Description
The server (machine) name.
The alert level.

The description about the alert information.

5.4.2.13.13. Clone report of machines

This report displays the clone progress and status of machines.

Clone Progress of Machines

ltem

Project

Cluster

Machine Name

Machine Status

Clone Progress

Description

The project name.

The cluster name.

The machine name.

The running status of the machine.

The progress of the current clone process.

Clone Status of Machines

ltem

Project

Cluster

Machine Name

Machine Action

Machine Action
Status

Machine Status

Level

Clone Status

Description

The project name.
The cluster name.
The machine name.

The action performed by the machine, such as the clone action.

The status of the action performed by the machine.

The running status of the machine.
Whether the clone action performed by the machine is normal.

The current status of the clone action performed by the machine.

5.4.2.13.14. Auto healing/install approval pending report

The list structure is the same as the machine RMA approval pending list, whereas t his view is used for
the approval during the installation. For more information, see Machine RMA approval pending list.
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5.4.2.13.15. Machine power on or off statuses of

clusters

After a cluster starts or shuts down machines, you can view the related information in this report.

Cluster Running Statuses

If a clusteris starting or shutting down machines, the corresponding data is available in this list. No data
indicates that no cluster has machines shut down.

ltem Description

Project The project name.

Cluster The cluster name.

Action Name The startup or shutdown action that is being performed by the cluster.
Action Status The status of the action.

Server Role Power On or Off Statuses

Displays the power on or off statuses of serverroles in the cluster selected in the Cluster Running
Statuses section.

Select arow inthe Cluster Running Statuses section to display the information of the corresponding
clusterinthe list.

ltem Description
Cluster The cluster name.
Server Role The server role name.

The startup or shutdown action that is being performed by the server

Action Name
role.

Action Status The status of the action.

Statuses on Machines
Displays the running status of the selected server role on machines.

Select arow inthe Server Role Power On or Off Statuses section to display the information of the
corresponding server role in the list.

ltem Description
Cluster The cluster name.
Server Role The server role name.
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ltem Description

Machine Name The machine name.

Server Role Status The running status of the server role.

Server Role Action The action currently performed by the server role.

Server Role Action
Status

The status of the action.

Error Message The exception message.

Machine Statuses

Displays the running statuses of machines in the selected cluster.

Select arow inthe Statuses on Machines section to display the information of the corresponding
machine in the list.

ltem Description

Cluster The cluster name.

Machine Name The machine name.

P The IP address of the machine.

Machine Status The running status of the machine.

Machine Action The action currently performed by the machine.
Machine Action Status The action status of the machine.

Error Message The exception message.
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6.Log O&M

6.1. Overview of the Kibana log 0&M
platform

Kibana is an open source analytics and visualization platform. Logs for Apsara Stack Agility services such
as ApsaraDB RDS, Xnet 2, Asapi, and POP are accessible to Elasticsearch, Logstash, and Kibana (ELK). You
can use Kibana to view and retrieve related logs.

For more information about how to use Kibana 7.2, see Kibana Guide.

6.2. Log on to the Kibana log O&M platform

This topic describes how to log on to the Kibana log O&M platform.

Prerequisites

e ASO access address in the format of http://region-id.aso.intranet-domain-id.com.

e Google Chrome browser (recommended).

Procedure

1. Open your browser.

2. Inthe address bar, enter the URL region-id.aso.int ranet-domain-id.com and press the Enter key.

Enter a uszer name

Enter the pa:

Log On

@ Note Youcanselect a language fromthe drop-down list in the upper-right corner of the
page.

3. Enteryour username and password.

(® Note Obtain the username and password for logging onto the ASO console fromthe
deployment personnel or an administrator.

When you log onto the ASO console for the first time, you must change the password of your
username as prompted.
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To enhance security, a password must meet the following requirements:
o It must contain uppercase and lowercase letters.
o It must contain digits.

o It must contain special characters such as exclamation points (1), at signs (@), number signs (#),
dollar signs ($), and percent signs (%).

o It must be 10to 20 characters in length.
. ClickLog Onto gotothe ASO console.
. Inthe left-side navigation pane, choose Product Management > Products.

. Inthe Apsara Stack > Basic 0&M section, clickKibana Log Management.

N O o b

. Inthe dialog box that appears, enter the username and password for the Kibana log 0&M
platform, and then click LOG IN.

@ Note I you log onto the Kibana log O&M platformforthe first time, you must enterthe
username and password.
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7.Paas operations and
maintenance

7.1. PaaS console

7.1.1. PaaS console overview

The Paas console is designed based on the platform and products. The console is mainly used to view,
manage, and upgrade the products deployed in the PaaS console. The PaaS console also provides task
management capabilities to support orchestration, 0&M, and custom extension.

7.1.2. Log on to the PaaS console

T his topic describes how to log on to the PaaS console.

Prerequisites

e The URL of the ASO console, and the username and password used for logging onto the console are
obtained fromthe deployment personnel or an administrator.

The URL of the ASO console is in the following format: region-id.aso.intranet-domain-id.com.

e A browser is available. We recommend that you use the Google Chrome browser.

Procedure

1. Open your browser.

2. Inthe address bar, enter the URL region-id.aso.int ranet-domain-id.com and press the Enter key.

Enter a uzer name

Enter the pa

Log On

@ Note Youcanselect a language fromthe drop-down list in the upper-right corner of the
page.

3. Enteryour username and password.

@ Note Obtainthe username and password for logging on to the ASO console fromthe
deployment personnel or an administrator.
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When you log onto the ASO console forthe first time, you must change the password of your
username as prompted.

To enhance security, a password must meet the following requirements:
o It must contain uppercase and lowercase letters.
o It must contain digits.

o It must contain special characters such as exclamation points (1), at signs (@), number signs (#),
dollar signs ($), and percent signs (%).

o It must be 10 to 20 characters in length.
4. ClickLog Ontogotothe ASO console.
5. Inthe left-side navigation pane, choose Products > Product List.

6. Inthe Apsara Stack O&M > Basic 0&M section, clickPaaS Console.

7.1.3. Overview

The Overview module provides you with brief information about the health status of Apsara Stack
Aqility PaaS OM Platform.

7.1.3.1. Health Panorama

The Health Panorama module provides the overall system health status, including cluster health,
product health, and release link health. 0&M engineers can identify issues by analyzing the system
health status.

7.1.3.1.1. View cluster health

The Cluster Health tab provides the health status of nodes in a cluster. You can go to the homepage of
the Grafana service fromthis tab.

Procedure

1. Inthe left-side navigation pane of the Apsara Stack Agility PaaS console, choose Overview >
Health Panorama.

The Cluster Health tab is displayed.
2. Onthe Cluster Health tab, view details of cluster health, node health, and cluster events.
o Cluster health details

You can view cluster health details such as the total nodes, health score, and health status.

Total Nodes: 8lndividual
Health Score: 100/100 4 0% No Problems Found

tianji—paas—a—660b Health Status: healt

o Node health details

You can view node health details such as the health status of each node and the cluster
topology.
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Node Health Details Monitor The Market Analysis Details m =

State Health Resource Name Health Score CPU Memory Disk
v ab6 i... 100 96 377.31GB 0
v ab6 ... 100 96 377.31GB 0
v ab6 A... 100 96 377.31GB 0
v ab6 a... 100 40 251.39GB 0

m Clickthe buttonto go to the Nodes page and view the details of nodes.

m Clickthe G buttonto view the latest node data.

m Clickthe button to view the cluster topology and analysis results of the health

status. You can also provide feedback about the accuracy of the analysis results.

® Note

m [f the health score is lower than 100, the Analysis Results section displays warning
information of each unhealthy node and its child nodes.

= When you move the pointer over a node of the Release Link Topology, the
indicator information of the node is displayed.

ClustersTopology Analysis Results

Heahh‘.Wammg‘ Not Ready: o 100 | Analysis Completed, tianji-paas-a-660bThe Health Score100

£ duster

) rode

Dangerous Information >

Warning Information >

Feedback Information

W # Degree: Accurate Inaccurate
5

* Details

Feedback

o Clusterevents
You can view all event parsing logs of a cluster.

m Click Original Alarm Information 10 Article to view original alerts that are triggered by
cluster events.

m |nthe upper-right corner of the Cluster event section, click the More buttonto goto the
Cluster event page and view all event information of a cluster.
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7.1.3.1.2. View product health

The Product Health tab provides the health status of products that are deployed in a cluster. You can
go to the homepage of the Grafana service fromthis tab.
Procedure

1. Inthe left-side navigation pane of the Apsara Stack Agility PaaS console, choose Overview >
Health Panorama.

The Cluster Health tab is displayed.
2. Clickthe Product Health tab to view details of product health.
o Overall status of product health

You can view the number, ready status, and risks of products in a cluster.

Total Products:  29Individual
0.0% 0.0% [Risk1]

tianji-paas-a-660b

o Product health details

You can view the health status of a product.

Product Health Details El Monitor The Market m ®]

Deployment

Product Name Health Score Feature Status Actions
Status
o aegis-0 0 standard-3K Not Ready UnknownR... Details
@ arms-0 0 itsm-small Not Ready Unknowns... Details
o agility- . .
© cluster-init 0 Not Ready Unknowns... Details
standard
o dts-0 0 dts_migrati... Not Ready Unknowns... Details

m Clickthe [J¥# button to go to the Products page and view the details of products.

m Clickthe ¢ buttonto view the latest product data.
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m Find the product that you want to view, and click Det ails in the Actions column. On the
details page, view the product topology and analysis results of the health status. You can
also provide feedback about the accuracy of the analysis results.

@ Note When you move the pointer over a node of the Product Topology, the
indicator information of the node is displayed.

ProductTopology Analysis Results

Heatth: @ Warring: @ Not Ready: @ 0 | Analysis Completed, tianjimon-OThe Health Scored

appset .

« Dangerous Information >
fiE appinstance

&) workload o

Warning Information >
(]

Feedback Information

* Degree: Accurate Inaccurate

* Details:

o Clusterevents
You can view all event parsing logs of a cluster.

m Click Original Alarm Information 10 Article to view original alerts that are triggered by
cluster events.

m |nthe upper-right corner of the Cluster event section, click the More buttonto goto the
Cluster event page and view all event information of a cluster.

7.1.3.1.3. View release link health

The Release Link Health tab provides the health status of release link components. This helps you
better understand the overall health status of a cluster. You can go to the homepage of the Grafana
service from this tab.

Procedure

1. Inthe left-side navigation pane of the Apsara Stack Agility PaaS console, choose Overview >
Health Panorama.The Cluster Health tab is displayed.

2. Clickthe Release Link Health tab to view the health status of the release link.
o Overall status of release link health

You can view the number of components, health score, and health status of the cluster release
link.

Total Component: 12Individual
Health Score: 100/100 No Problems Found

tianji—paas—a—660b Health Status: healt

o Details of release link health
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You can view the health scores of release link components, donut chart of component
distribution, and release link topology.

Release Link Details Monitor The Market Analysis Details =

Deployment Platform
Health Score

Name
+ app-definition 100
v app-instance 100
v app-set 100
v argo 100

m Inthe upper-right corner of the Release Link Det ails section, clickthe = buttonto view the

latest component data.

m Inthe Release Link Det ails section, clickthe button to view the release link

topology and analysis results of the health status. You can also provide feedback about the
accuracy of the analysis results.

® Note

m [f the health score is lower than 100, the Analysis Results section displays warning
information of each unhealthy node and its child nodes.

= When you move the pointer over a node of the Release Link Topology, the
indicator information of the node is displayed.

Release LinkTopology Analysis Results
Health:.Waming: Not Ready:. " 100 Analysis Completed, deploymentPlatformThe Health

" Score100
workload core

Dangerous Information >
pcd
deploymentPlatform g 5

Q et Warning Information >

E?E deployPlatformComponent

Feedback Information

5
* Degree: Accurate Inaccurate
[ .| CElE e & S e £
5 I 5 5
== [a===n] . EEEER = B % Details:

Feedback

o Clusterevents

You can view all event parsing logs of a cluster.
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m Click Original Alarm Information 10 Article to view original alerts that are triggered by
cluster events.

= Inthe upper-right corner of the Cluster event section, click the More buttonto gotothe
Cluster event page and view all event information of a cluster.

7.1.3.2. Alert events

The Alert Events page displays all alert events and all aggregated alert events by alert or product
name.

7.1.3.2.1. View aggregated alert events by alert name

You can view aggregated alert events by alert name on the Alert Aggregation tab.

Procedure

1. Inthe left-side navigation pane of the PaaS console, select Alert Events fromthe Alerts drop-
down list.
The Alert Aggregation tab is displayed by default.

2. Inthe upper part of the page, select the target cluster fromthe drop-down list. By default, all
alert events that are aggregated by alert name are displayed.

3. Inthe alert name view, the Alert Aggregation tab displays all aggregated alert events by alert
name. The aggregated alert event list includes the following columns: Alert Name, Details, Total
Alerts, Severity, and Actions.

| Alert Events kubernetes

Alert Aggregation All Events Aggregate View m}

Cluster has overcommitted CPU resource requests for Pod Warning
Pod default/ahas-hbase-0 has been in a non-ready state f.. 12 Critical
T IP usage is already greater than 80% Critical
sStuckAboutEted Velero backup is stuck about etcd Errar

4. (Optional)in the search box at the top of the tab, set Product, Service, Severity, and Start Date,
and then click Search to query aggregated alert events that meet the conditions.

5. Find the target aggregated alert events. Click the name in the Alert Name column and the number
inthe Total Alerts column, or click View in the Actions column to view details of individual alert
event within the aggregated alert events.

The alert details include the following columns: Status, Start Time, End Time, Update Time, and
Label.
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| Alert Details

alertname: KubeCPUQOvercommit

product: acs

service: ack-prometheus-operator

metrict kube_pod_container_rescurce_requests_cpu_cores + node_num_cpu

message: Cluster has overcommitted CPU resource requests for Pods and cannot tolerate node failure.

Active Apr 22, 2020, 14:55:53 Apr 23, 2020, 13:34:53 Apr 23, 2020, 13:31:53 alertname... promethe.. severityw..

7.1.3.2.2. View aggregated alert events by product

name

You can view aggregated alert events by product name on the Alert Aggregation tab.

Procedure

1. Inthe left-side navigation pane of the PaaS console, select Alert Events fromthe Alerts drop-
down list.
The Alert Aggregation tab is displayed by default.

2. Inthe upper part of the page, select the target cluster fromthe drop-down list. By default, all
alert events that are aggregated by alert name are displayed.

3. Turn off the Aggregate View to switch to the product name view.
In the product name view, the Alert Aggregation tab displays all aggregated alert events by
product name.

| Alert Events kubernetes

Alert Aggregation All Events Aggregate View m:

Cluster has overcommitted CPU resource requests for Pod... 1 Warning
Pod default/ahas-hbase-0 has been in a non-ready state f... 12 Critical
TerwayNetworklPUsage IP usage is already greater than 90% 1 Critical

4. (Optional)in the search box at the top of the tab, set Product, Service, Severity, and Start Date,
and then click Search to query aggregated alert events that meet the conditions.

5. Find the target aggregated alert events. Click the name in the Alert Name column and the number
inthe Total Alerts column, or click View in the Actions column to view details of individual alert
events within the aggregated alert events. The alert details include the following columns: Status,
Start Time, End Time, Update Time, and Label.

7.1.3.2.3. View all alert events

Onthe All Events tab, you can view all alert events generated in the PaaS console.
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Procedure

1. Inthe left-side navigation pane of the PaaS console, select Alert Events fromthe Alerts drop-
down list.

2. Clickthe All Events tab.

3. All alert events are displayed on the tab. The alert event list includes the following columns: Alert
Name, Start Time, End Time, Update Time, Status, Details, Severity, and Label.

7.1.3.3. Environment model

The Environment Model module displays the logical relationships among the region, zone, environment,
and data center subsets in the Apsara Stack Agility PaaS console.

Procedure

1. Inthe left-side navigation pane of the Apsara Stack Agility PaaS console, choose Overview >
Environment model.

2. Onthe Environment model page, view the logical relationships among the region, zone,
environment, and data center subsets in the Apsara Stack Agility PaaS console.

| Environment model

Region:er §7 B 101

7.1.4. Clusters

7.1.4.1. View the cluster list

On the Clusters page, you can view the status and kubeconfig connection information of the Paas-
managed clusters.

Procedure
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1. Inthe left-side navigation pane of the Apsara Stack Agility PaaS console, choose Clusters >
Clusters.

2. Onthe Clusters page, view all clusters that are managed by Paas.
| Clusters

Name Status Registration Time Actions

[ ] * Available Sep 10, 2020, 10:06:32 View

Entries per Page: 10 v Total Entries: 1 -

3. Find a cluster, and click View in the Actions column to view the kubeconfig connection information
of the cluster.

7.1.4.2. Node management

You can add node tags or taints for clusters to manage scheduling policies.

7.1.4.2.1. Add tags

You can add tags to nodes for subsequent cluster scheduling, configuration, and behavior
customization.

Procedure

1. Inthe left-side navigation pane of the PaaS console, select Nodes fromthe Clusters drop-down
list.

2. (Optional)in the upper-left corner of the Nodes page, select the target cluster fromthe drop-
down list.

3. Select one or more nodes to which you want to add a tag. Click Add Label in the lower-left
corner.

4. Performthe following operations:
o Add a built-intag

Inthe Add Label to Node dialog box, click a tag in the Built-in Labels field. The tag name is
automatically filled into the Key field. Set Value and then click OK.

Add Label to Node X
| |
Value | |

The following table describes the parameters.
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Parameter

Built-in Labels

Key

Value

o Add acustomtag

Description

Existing tags in the system. Valid values:

® Hypervisor failure-domain: During output virtualization,
virtual machines are distributed across different physical
machines. This tag can be used to distribute pods to different
physical machines.

m Zone failure-domain: distributes Kubernetes nodes to
different zones.

m Region failure-domain: distributes Kubernetes nodes to
different regions.

After you click a tag in the Built-in Labels field, the tag name is
automatically filled into the Key field. You can also set Key to
specify a custom tag.

The custom tag value.

Inthe Add Label to Node dialog box, set Key and Value, and then click OK.

7.1.4.2.2. Add taints

You can add taints to nodes for subsequent pod scheduling.

Procedure

1. Inthe left-side navigation pane of the PaaS console, select Nodes fromthe Clusters drop-down

list.

2. (Optional)in the upper-left corner of the Nodes page, select the target cluster fromthe drop-

down list.

3. Select one or more nodes to which you want to add a taint. Click Add Taint in the lower-left

corner.

4. Performthe following operations:

o Add a built-in taint

Inthe Add Taint dialog box, click a taint in the Built-in Taints field. The taint name is
automatically filled into the Key field. Specify Value and Effect, and then click OK.

The following table describes the parameters.

Parameter

Built-in Taints

Key

Value

Description

Existing taints in the system.

After you click a taint in the Built-in Taints field, the taint name is
automatically filled into the Key field. You can also set Key to

specify a custom taint.

The custom taint value.

> Document Version: 20210128

209



Operations and Maintenance Guide-
PaaSs operations and maintenance

Parameter Description

The effects of the taint. Valid values:

= preferNoSchedule: indicates that if possible, pods will not
schedule the node.

Effect = NoSchedule: indicates that pods will not be allowed to
schedule the node.

® NoExecute: indicates that pods will not be allowed to
schedule the node and that pods that are running on the node
will be evicted.

o Create a customtaint

Inthe Add T aint dialog box, specify Key, Value, and Effect, and then click OK.

Add Taint
Built-in Taints
o |
Value ‘ ‘

Effect PreferdoSchedule @ MNoScheduls MoExecute

m Cancel
7.1.4.2.3. Query nodes by tag

You canfilter nodes by tag to find nodes that have a specified tag.

Procedure
1. Inthe left-side navigation pane of the PaaS console, select Nodes fromthe Clusters drop-down
list.

2. (Optional)in the upper-left corner of the Nodes page, select the target cluster fromthe drop-
down list.

3. Inthe upper-right corner of the page, enter atag name or specify a tag in the key=value format in
the search box and then click the Search icon.
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| Modes

kubernetes

CentOS Linux
® Ready warker 7 (Core) 24
docker//18.9.9

CentO5 Linux

® Ready worker 7 (Core) 24
docker://18.9.9

7.1.4.2.4. Delete a tag or taint

04.23GE Null 0 e

04.23GE Null ] e

You can delete built-in or customtags or taints from nodes. Kubernetes-defined tags of nodes cannot

be deleted.

Procedure

1. Inthe left-side navigation pane of the PaaS console, select Nodes fromthe Clusters drop-down

list.

2. (Optional)in the upper-left corner of the Nodes page, select the target cluster fromthe drop-

down list.

3. Find the target node and the target tag, and then click View in the Actions column.

4. Inthe dialog box that appears, move the pointer over the target tag ortaint, and then click

Delete.

5. Inthe message that appears, click OK.

7.1.4.3. Query event details

On the Cluster event page, you can view all event parsing logs of clusters that are deployed inthe

Apsara Stack Agility PaaS console.

Procedure

1. Inthe left-side navigation pane of the Apsara Stack Agility PaaS console, choose Clusters >

Events.

2. Inthe upper-left corner of the page, filter events by cluster name, namespace, and log type to

view details of event logs.
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| Cluster eventl tianji-paas-a-660b

|| All

Refresh

o -]

Namespace Type Obj

Pod

acs-check Warning
khcheck-dns-1603689226
Pod

acs-check Warning
khcheck-dns-1603689226
Pod

acs-check Warning
khcheck-dns-1603689226
Pod

acs-check Warning
khcheck-dns-1603689226
Pod

acs-check Warning
khcheck-dns-1603689226
Pod

acs-check Warning
khcheck-dns-1603689226
Pod

acs-check Warning

khcheck-podstatus- 1603689226

® Note

Event information

Failed create pod sandbox: rpc error: code = Unknown

desc = failed to set up sandbox container "55e52231...

Failed create pod sandbos: rpc error: code = Unknown

desc = failed to set up sandbox container "9fa2636d...

Failed create pod sandbox: rpc error: code = Unknown

desc = failed to set up sandbox container "52982835...

Failed create pod sandbox: rpc error: code = Unknown

desc = failed to set up sandbox container "3df3a3bl..

Failed create pod sandbos: rpc error: code = Unknown

desc = failed to set up sandbox container "TedbSbb2..

Failed create pod sandbox: rpc error: code = Unknown

desc = failed to set up sandbox container "0c523b79...

Failed create pod sandbox: rpc error: code = Unknown

FailedCreatePodSandBox

FailedCreatePodSandBox

FailedCreatePodSandBox

FailedCreatePodSandBox

FailedCreatePodSandBox

FailedCreatePodSandBox

FailedCreatePodSandBox

me

Oct 26, 2020, 13:13:54

Qct 26, 2020, 13:13:57

Qct 26, 2020, 13:13:59

QOct 26, 2020, 13:14:02

Qct 26, 2020, 13:14:05

Qct 26, 2020, 13:14:08

Oct 26, 2020, 13:13:54

desc = failed to set up sandbox container "b1730f703...

In the upper-right corner of the page, you can view the latest information of event

logs by clicking the Refresh button.

The following table describes relevant fields in the event list.

Field

Namespace

Type

Object

Reason

Time

Description

The namespace associated with the event.

The event type.

The Kubernetes object that corresponds to the event.
The reason why the event was triggered.

The time when the event was triggered.

7.1.5. Product center

7.1.5.1. Product list

The product list displays the information about all products deployed in the PaaS console, including
their names and versions. In the product list, you can perform O&M operations and view product
resources or register variables. You can also remove products that are no longer needed.

7.1.5.1.1. View product details

You can view the details of products that are deployed in the Apsara Stack Agility PaaS console,
including their names, versions, and components.

Procedure

1. Inthe left-side navigation pane of the Apsara Stack Agility PaaS console, choose Product Center

> Products.

2. Onthe Products page, find the product that you want to view and click Det ails in the Actions

column.
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| Products
Deployment Status Status
Succeeded * Ready
Succeeded * Ready
Succeeded * Ready
Succeeded * Ready
Succeeded * Ready

Product Name

apsarabase
location-service

apsarabase
jmenyv

apsarabase
ram

apsarabase
aas

apsarabase
tag-service

Product version / Branch

Unknown
Ark-v1.9xR

Unknown
Ark-v1.9xR

Unknown
Ark-v1.9xR

Unknown
Ark-w1.9xR

Unknown
Ark-v1.9xR

Refresh
Build version Actions Version change
1lkhul5jouu7drd6ad4iteiflg. 172224 Details Version Information
1lkhulsjouu7drd6ad4iteiflg.172224 Details Version Information
1lkhul5jouu7drd6additeiflg.172224 Details Version Information
1lkhul5jouu7drd6a4d4iteiflg. 172224 Details Version Information
1lkhulsjouu7drd6ad4iteiflg.172224 Details Version Information

3. Onthe Overview page, view the name, version information, components, and release status of the

product.

ahas - standard

ahas - standard

‘ Product Name
100%
Product Version: unknown

| Product Components
Name
ahas.ahasservice.ahas-sentinel
ahas.ahasservice.ahas-gateway

ahas.ahasservice.ahas-hbase

Version Cluster

0.1.0-505112¢ k8s-a-e5a7

0.1.0-261721d k8s-a-e5a7

0.1.0-226197a k8s-a-e5a7

Components: 3

Post status: Running

Build version: 2907a449-2fd4-4b8c- Upgrade strategy: No partial

8bf4-2590c4d546ae.123456

Namespace

default

default

default

Status

* Ready

* Ready

* Ready

7.1.5.1.2. View product versions

Refresh

Post status Actions
Upgrade | Running Details Details Deployment Progress
Upgrade | Succeeded Details Details Deployment Progress
Install | Succeeded Details Details Deployment Progress

Entries per Page: 10 v Total Entries: 3

You can view versions of products that are deployed in the Apsara Stack Agility PaaS console.

Procedure

1. Inthe left-side navigation pane of the Apsara Stack Agility PaaS console, choose Product Center

> Products.

2. Onthe Products page, find the product that you want to view and click Version Information in
the Version change column.

| Products
Deployment Status Status
Succeeded * Ready
Succeeded * Ready
Succeeded * Ready
Succeeded * Ready
Succeeded * Ready

Product Name

apsarabase
location-service

apsarabase
jmeny

apsarabase
ram

apsarabase
aas

apsarabase
tag-service

Product version / Branch

Unknown
Ark-v1.9xR

Unknown
Ark-v1.9xR

Unknown
Ark-v1.9xR

Unknown
Ark-w1.9xR

Unknown
Ark-v1.9xR

Refresh

Build version Actions Version change

1lkhulsjouu7drd6ad4iteiflg.172224 Details

1lkhulsjouu7drd6ad4iteiflg.172224 Details Version Information
1lkhul5jouu7drd6additeiflg.172224 Details Version Information
1lkhul5jouu7drd6a4d4iteiflg. 172224 Details Version Information
1lkhul5jouu7drd6ad4iteiflg.172224 Details Version Information

3. Inthe Version Information dialog box, view the version information of the product.
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apsarabase-0Version Information X
Product version / Branch Build version Select
_____ rinowARCIOR | ksewTddsseio ez @

Publish

@ Note Inthe lower-right corner of the dialog box, you can clickthe Publish buttonto go
to the Deploy&Upgrade page. For more information about how to deploy and upgrade
products, see Deployment and upgrade.

7.1.5.1.3. View component information

You can view the component details in the Product Components section of the Overview page of a
product.

Procedure

1. Inthe left-side navigation pane of the PaaS console, select Products fromthe Product Center
drop-down list.

2. Inthe product list, find the target product and click Details in the Actions column.

3. Inthe Product Components section of the Overview page, view the deployment information of
components, such as the deployment status, component status, cluster, namespace, component
name, and component version.

4. Find a component and click Det ails in the Actions column to view details of the component.
5. The Component Details page contains the following tabs: StatefulSets, Deployments,
DaemonSets, Jobs, Services, and Persistence Volume Claims.

Component: middleware.zookeeper.zk

| Lists

Deployments aemonSets Jobs Services Persistent Volume Claims
Name Namespace Desired Count Current Count Ready Count Creation Time Actions
zk-middleware default 3 3 3 Mar 31, 2020, 11:38:55 Start Termina

7.1.5.1.4. View the release status of a product

component

You can view release status details of a product component.
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Procedure

1. Inthe left-side navigation pane of the Apsara Stack Agility PaaS console, choose Product Center
> Products.

2. Onthe Products page, find the product that you want to view and click Det ails in the Actions
column.

3. Inthe Product Components section of the Overview page, find the component that you want to
view and click Det ails in the Post status column.

4. Inthe Details dialog box, move the pointer over the component to view tasks. Move the pointer
over each task to view subtasks. Move the pointer over each subtask to view details of the subtask.

Details X
https-proxy-cloudops.httpsproxy PostTraits o CheckAppinstanceStatus o Name: CheckAppinstanceStatus
PreTraits o status: Succeeded
endTime: Oct 22, 2020, 07:02:31
Publish (]
message: complate succeeded
Complete o

complate succeeded

7.1.5.1.5. View the deployment progress of product

components

You can view the deployment progress of product components.

Procedure

1. Inthe left-side navigation pane of the PaaS console, select Products fromthe Product Center
drop-down list.

2. Inthe product list, find the target product and click Details in the Actions column.
3. Inthe Product Components section of the Overview page, find the target component and click
Deployment Progress inthe Actions column.

zookeeper - standard

| Product Components Refresh

nent Status ce Name Version ons
nstall | Succeeded * Ready tianji-paas-a-097 default middlewarezookeeper.zk 0.1.0-4244bd6 Details

4. Onthe Product Component Deployment Progress page, click the deployment nodes in
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sequence to view the deployment progress and logs of the current component.

@ Note You can clickLOGS inthe lower-left corner of the Summary tab to view the
deployment logs.

| Product Component Deployment Progress

IMAGE
inst-middleware-zook...
cn-

inc.com/alibaba_apsara_paas/ark-workflow:v1.0.4-reserve-ip

AnalyseContext
COMMAND

python

L4 GenerateResources
ARGS

Jark-argo-workflow/scripts/context_analysis.py

{{workflow.parameters.contextName}} {{workflow.parameters.contextNS}}
L CheckDependency kflow.parameters.option}} {{workflow.parameters.cmdbNSH

7.1.5.1.6. Log on to a web terminal

The StatefulSets and Deployments tabs of the Component Details page list available terminals.
Browser-based terminals are used for 0&M management and troubleshooting.

Procedure

1. Inthe left-side navigation pane of the PaaS console, select Products fromthe Product Center
drop-down list.

2. Inthe product list, find the target product and click Det ails in the Actions column.

3. Inthe Product Components section of the Overview page, find the target component and click
Details inthe Actions column.

4. Onthe Component Details page, clickthe StatefulSets or Deployments tab.

5. Find the target component, and then click Start Terminal in the Actions column. Available
containers that are based on the number of replicas are displayed in the pane.

| Lists

Deployments DaemonSets Jobs Services Persistent Volume Claims
Name Namespace Desired Count Current Count Ready Count Creation Time Actions
zk-middleware default 3 3 3 Mar 31, 2020, 13:38:59

6. Select the target container and then click OK to start the terminal process.

7.1.5.1.7. Perform O&M operations

The O&M Actions page displays the 0&M operations that are available to a product. You can also
perform O&M operations on this page.
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Procedure

1. Inthe left-side navigation pane of the PaaS console, select Products fromthe Product Center
drop-down list.

2. Inthe product list, find the target product and click Det ails in the Actions column.
3. Inthe left-side navigation pane, click O&M Actions.

4. Perform O&M operations that are available to the product.

7.1.5.1.8. View a resource report

The Resource Report page displays the information of all resources that a product has requested from
the PaasS console. The resource type can be cni(ip), db, vip, dns, and accesskey.

Procedure

1. Inthe left-side navigation pane of the PaaS console, select Products fromthe Product Center
drop-down list.

2. Inthe product list, find the target product and click Det ails in the Actions column.

3. Inthe left-side navigation pane, clickResource Report.

| Resource Report

esource Owner | ? ] .
edas.edasservice.cai-fs cn cni.cai_fs.ip_list
edas.edasservice.cai-fs db db.efs.host db.ac
edas.edasservice.cai-fs db db.efs.name efs
edas.edasservice.cai-fs db db.efs.password
edas.edasservice.cai-fs db db.efs.port 3306

4. View the information of resources.

By default, all resources are displayed. You can click the up and down arrows next to Resource
Owner to sort resources. You can also clickthe v icon next to Type to filter resources.

Field Description

Resource Owner The name of the component to which the resource belongs.
Type The type of the resource.

Key The attribute name of the resource.

Value The attribute value of the resource.

7.1.5.1.9. View service registration variables
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The Service Registration Variables page displays the values of all service registration variables. You can
view the service registration variables of a product. The service registration variables report for a
product lists the variables that the product can deliver to other products or components.

Procedure

1. Inthe left-side navigation pane of the PaaS console, select Products fromthe Product Center
drop-down list.

2. Inthe product list, find the target product and click Det ails inthe Actions column.
3. Inthe left-side navigation pane, click Service Registration Variables.

| Service Registration Variables

Resource Owner i 7 Key alue
edas.edasservice cai-fs edas_cai_fs_db_host db.a
edas.edasservice.cai-fs edas_cai_fz_db_name efs
edas.edasservice.cai-fs edas_cai_fs_db_password
edas.edasservice.cai-fs edas_cai_fs_db_port 3308
edas.edaszervice.cai-fs edas_cai_fz_db_user efs
edas.edasservice.cai-fs edas_cai_fz_domain filzzerve

4. View the information of service registration variables.

By default, all service registration variables are displayed. You can click the up and down arrows
next to Resource Owner to sort service registration variables. You can also click the = icon next to

Resource Owner to filter service registration variables.

The following table describes the fields for service regist ration variables.
Field Description
Resource Owner The name of the component to which the resource belongs.

The variable name that is registered on CMDB and can be used by

Ke .
y this product or other product components.

Value The variable value that is registered on CMDB.

7.1.5.2. Deployment and upgrade

This topic describes how to perform batch upgrade and incremental deployment. You can customize
product features when you deploy a product. If the product supports custom configuration, the
system goes to the custom configuration page.

Prerequisites

The deployment and upgrade packages are imported to the Apsara Stack Agility PaaS console. To
import the deployment and upgrade packages, performthe following operations:

1. Upload the installation disk used for deployment and upgrade to the bootstrap node in the onsite
environment.

2. Logonto the bootstrap node over SSH.
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3. Runthe following command to import deployment packages and generate a deployment package
list:
sh upgrade.sh {packages -pathj.iso

Replace {packages -pat hj.iso with the actual storage path of the .iso file on the installation disk.

Procedure

1. Inthe left-side navigation pane of the Apsara Stack Agility PaaS console, choose Product Center
> Deploy&Upgrade.The System Packages page displays the deployment packages that have
been imported to the Apsara Stack Agility PaaS console.

2. Onthe System Packages page, find the deployment package that you want to upgrade.

@ Note I multiple deployment and upgrade packages exist, you can enter a system ID in
the search box to search for deployment packages by system ID.

| System Packages Filter by system 1D Q
System ID Build Time Import Time Actions
eb L} Nov 18, 2020, 12:23:09 Nov 18, 2020, 12:24:02 Publish
m Nov 17, 2020, 16:40:06 Nov 17, 2020, 16:41:30 Publish
15¢ LI | Nov 16, 2020, 20:34:39 Nov 16, 2020, 20:35:09 Publish
Tg=m L m = = = Nov 16, 2020, 19:42:18 Nov 16, 2020, 19:42:38 Publish
8d Nov 16, 2020, 19:21:38 Nov 16, 2020, 19:24:33 Publish

3. Click Publish inthe Actions column to start the deployment or upgrade process.

4. (Optional)inthe Select Products step, clickthe numberin the Components columnto view the
components and versions of the current product. Select the required features and click Next.

Select Products } Customize Configurations ui.menu.platform.step.model Node Planning Preview

| System ID: 1li= om ] 4 Automatic Dependency Processing
Product & Feature Description Components

apsarabase - (Ark-v1.9xR@3e0c9480c963ca9119b6dasec9ad3bae43badsd)

aas 6]
diamond I 2
dubbo L

https-proxy 2
jmenv I 1
location-service 3_

Selected Products: 0, Total Components: 0
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9.

7.

@ Note The system can parse dependencies among products. When the Automatic
Dependency Processing check box is selected, the system checks whether dependencies exist
between the deployed products and the products that you want to deploy. Then, the system
selects the products that have dependencies with the products that you want to deploy. If
you want to manually select the products to be deployed, you can clear the Automatic
Dependency Processing check box. If you select products that have been deployed, the
system upgrades these products. If you select products that have not been deployed, the
system deploys these products incrementally.

If the custom configuration feature is enabled for a selected product, the Customize
Configurations step is displayed. Otherwise, the Preview step is displayed.

. Inthe Customize Configurations step, configure the parameters and click Save. Then, click

Next.

. Inthe Resource Planning step, click Edit in the upper-left cornerto configure project parameters.

ClickSave, and then click Next.

. Inthe Node Planning step, verify that the node planning is correct and click Next.

@ Note If you want to modify the node planning, clickthe Reselect button.

. Inthe Preview step, check the information of the products to be deployed.

A type of iconto the left of each iteminthe Product & Feature columnindicates a type of
deployment state of the product:

o i indicates that the product is to be deployed.
o [ indicates that the product has been deployed and does not need to be upgraded.

o 4: indicates that the product is to be upgraded. You can click the @ iconto checkthe

differences.

Notic

e: Welco perations console.
Select Products } Customize Configurations } ui.menu.platform.step.model } Node Planning

You will submit the deploy or upgrade operation. Confirm the information to be submitted carefully, including the System ID of the deployment package and the affected products. If the information is

ome to the Apsara Agility PaaS O

correct, click Submit to submit the information. If modification is required, click Previous to modify the information.
Product & Feature Description Deployment Model Components Upgrade strategy
apsarabase - (Ark-v1.9xR@3e0c9480c963ca9119b6da8eclad3b2ae43badsd)

ﬂ diamond u | e b | = Hybrid 2 Not Applicable

m

Click Submit to start the deployment or upgrade process.

After the deployment or upgrade process starts, you can view the progress on the Task Instances
page. To view the progress, choose Task Center > Task Instances.

1.6. Task center

The Task Center module provides general task management capabilities. You can view and run task
templates, and view, suspend, resume, terminate, and delete tasks.
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7.1.6.1. Task templates

The Task Templates page lists all tasktemplates, both imported and preset.

7.1.6.1.1. View a task template

You can view information of all tasktemplates on the Task Templates page, such as the name,

description, parameters, and workflow definition.

Procedure

1. Inthe left-side navigation pane of the PaaS console, select Task Templates fromthe Task

Center drop-down list.
2. Find the target tasktemplate. Click View in the Actions column.
| Task Templates

Name Jescription

app-instance-workflow-cm ] Mar 29, 2020, 18:44:10

cluster-init-workflow b T Mar 29, 2020, 18:42:45

3. Inthe pane that appears, view the name, description, parameters, and workflow definition of the

tasktemplate.
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View Task Template Definition X
Task Template Name
app-instance-workflow-cm

Task Functionality

Parameters

Parameter Default Value
contextMame NotNull
contextNS ark-system
option MNotMull
cmdbNS ark-system

Task Workflow Definition

Back

7.1.6.1.2. Run a task

You canrun atask onthe Task Templates page.

Procedure

1. Inthe left-side navigation pane of the PaaS console, select Task Templates fromthe Task
Center drop-down list.

2. Find the target task template. ClickRun in the Actions column.

3. Inthe pane that appears, set Task Instance Name and Action Parameters.

@ Note If the taskinstance name is not specified, the system automatically generates a
task instance name. We recommend that you enter a recognizable name for easy query.
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Run Task Immediately X

Task Template Name

app-instance-workflow-cm

Task Functionality

Task Instance Name

Action Parameters

Parameter Value
contextName NotNull
contextMs ark-system
option NotMull
cmdbNS ark-system

OK Cancel

4. Click OK.

7.1.6.2. Task instances

The Task Instances page displays information of all tasks. On this page, you can view, suspend, resume,
terminate, retry, and delete tasks.

7.1.6.2.1. View task details

Afteryou run a task, you can view the progress, logs, and parameters of the task on the Task Instances
page.
Procedure

1. Inthe left-side navigation pane of the PaaS console, select Task Instances fromthe Task Center
drop-down list.

2. Inthe taskinstance list, view the status of all tasks.
Valid values of the task status:

o Succeeded: indicates that the task has been executed.

o

Running: indicates that the taskis being executed.

Running (Suspended): indicates that the task has been suspended.

o

Failed: indicates that the task has failed.

o

Failed (Terminated): indicates that the task has been terminated.

o

3. Find the target task. Click View in the Actions column. Then, you are redirected to the Task
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Instance Details page.

| Task Instances
Name Status
upg-drds-console-service-tast-j99nr Succeeded

ark-fb349068-14ee-4968-b37e-

5 ded
a957dd80a786.123456 uccesqae

inst-drds-console-drds-console-9k8mg Succeeded

Start Time

Mar 30, 2020,
22:27:43

Mar 30, 2020,
22:27:13

Mar 30, 2020,
21:48:11

Refresh

End Time Actions

Mar 30, 2020,
22:28:28 T

Mar 30, 2020,
22:27:56

Mar 30, 2020,
21:55:47

4. Onthe TaskInstance Details page, clickthe task nodes in sequence to view the information and

logs of the current task.

@ Note You can clickLOGS inthe lower-left comer of the Summary tab to view task logs.

| Task Instance Details

Upg-amas-ams-consale.

CheckDependency

BrocessDNSRegister DeleteResources

7.1.6.2.2. Suspend a task

SUMMARY CONTAINERS ARTIFACTS

NAME
main

IMAGE

en-qd-agility40-d01-reg docker.envAd.qd-inc.com/alibaba_apsara_paas/ark-
workilow:v1.0.4-check-hybrid

COMMAND

python

-workflow/scripts/context_analysis.py

ters contextNamel) {{workflow parameters contextNs)
rameters.option}} fiwerkflow parameters.cmdbNs)

You can suspend a task in the Running state. Then, the task status becomes Running (Suspended).

Prerequisites

The taskis in the Running state.

Procedure

1. Inthe left-side navigation pane of the PaaS console, select Task Instances fromthe Task Center

drop-down list.

2. Inthe taskinstance list, find the task in the Running state that you want to suspend. Click
Suspend inthe Actions column. After a successful operation, the task status changes from
Running to Running (Suspend) inthe Status column.

7.1.6.2.3. Resume a task

224

> Document Version: 20210128



Operations and Maintenance Guide-
PaaS operations and maintenance

After ataskis suspended, the taskis in the Running (Suspended) state. Then, you can click Resume in
the Actions column to resume the task.

Procedure

1. Inthe left-side navigation pane of the PaaS console, select Task Instances fromthe Task Center
drop-down list.

2. Inthe taskinstance list, find the task in the Running (Suspended) state that you want to resume.
ClickResume inthe Actions column. After a successful operation, the task status changes from
Running (Suspend) to Running inthe Status column.

| Task Instances Refresh
Name Status Start Time End Time Actions
Runnin Mar 31,
test (Sus er?ded‘l 2020, View op Delete
P b 140047
upg-drds-console-service UETEL LT
1;? 199 Succesded 2020, 2020, View Delete
1 22:27:43 22:28:28

7.1.6.2.4. Terminate a task

You can terminate a task in the Running (Suspended) or Running state.

Prerequisites

The taskis in the Running (Suspended) or Running state.

Procedure

1. Inthe left-side navigation pane of the PaaS console, select Task Instances fromthe Task Center
drop-down list.

2. Inthe taskinstance list, find a task in the Running (Suspended) or Running state. ClickStop in
the Actions column. For a task in the Running the system immediately terminates the task and the
task status becomes Failed (T erminated). For a task whose Status is Running (Suspended),
the systemimmediately terminates the task when the task status becomes Running again. Then the
task status becomes Failed (T erminated).

| Task Instances Refresh
Mame Status Start Time End Time Actions
Runnin Mar 31,
test Sus Er?ded\ 2020, View esume op | Delete
P 1 140047
upg-drds-console-service LT LETEL
155? o Succeeded 2020, 2020, View Delete
] 22:27:43 22:28:28
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7.1.6.2.5. Retry a task

You canretry ataskin the Failed or Failed (Terminated) state. When a task is retried, the task restarts

fromthe failed orterminated task node.

Procedure

1. Inthe left-side navigation pane of the PaaS console, select Task Instances fromthe Task Center

drop-down list.

2. Inthe taskinstance list, find a task in the Failed or Failed (Terminated) state. ClickRetry inthe

7.1.6.2.6. Delete a task

Actions column.

inst-drds-console-drds-logger-hpfbk

inst-drds-conscle-drds-manager-smwéx

inst-drds-console-jingwei-console-xSkwb

inst-drds-console-rtools-zw2eb

inst-drds-console-service-test-pwin9

inst-middleware-zookeeper-zk-wglh

ark-3k3]j0kn82rjt63arvafSemvg). 123456

Succeeded

Succesded

Succeeded

Succesded

Succeeded

Succesded

Failed

Mar 30, 2020,

21:48:11

Mar 30, 2020,

21:48:11

Mar 30, 2020,

21:48:11

Mar 30, 2020,

21:48:11

Mar 30, 2020,

21:48:11

Mar 30, 2020,

21:48:11

Mar 30, 2020,

214741

Mar 30, 2020,
21:59:58

[
m
m
m

Mar 30, 2020,
21:53:39

[ ]
m
1]
[1+]

Mar 30, 2020,
22:02:23

[
m
m
m

Mar 30, 2020,
21:51:42

[ ]
[17]
1]
[1+]

Mar 30, 2020,
22:03:55

[
m
m
m

Mar 30, 2020,
21:4%:23

m
i)
m

Mar 30, 2020,
22:04:19

elete |Retry

You can delete ataskin any state. If ataskis in the Running state, this operation enables the systemto
immediately terminate the task and delete the task record. If ataskis in a state other than Running, this

operation enables the systemto immediately delete the task record.

Procedure

1. Inthe left-side navigation pane of the PaaS console, select Task Instances fromthe Task Center

drop-down list.

2. Inthe taskinstance list, find the target task. Click Delete inthe Actions column.

7.1.7. Platform diagnostics

The PaaS console provides platform-level diagnostics. This module collects information about the
console and products deployed in the console, presents summary diagnostic results, and allows you to
download detailed diagnostic results. The module aims to improve user experience of diagnostics.
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7.1.7.1. Diagnostic items

The Diagnostic items page displays all diagnostic items in the PaaS console. On this page, you can view,
execute, and delete diagnostic items.

7.1.7.1.1. View a diagnostic item

You can view details about the current diagnostic item, such as the name, type, description, start time,
deletion protection, and definition.

Procedure

1. Inthe left-side navigation pane of the PaasS console, select Diagnostic ltems fromthe Platform
Diagnostics drop-down list.

2. Find the target diagnostic item. Click View in the Actions column.

3. Inthe pane that appears, view details of the diagnostic item.

View Diagnostic ltem

Start Time
Mar 29, 2020, 18:55:54

Deletion Protection

Yes

Definition

7.1.7.1.2. Execute diagnostic items
You can execute diagnostic items on the Diagnostic ltems page.

Procedure

1. Inthe left-side navigation pane of the PaaS console, select Diagnostic Items fromthe Platform
Diagnostics drop-down list.

2. Select one or more diagnostic items and click Submit Diagnosis.
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base_logs_flaws_pods Job Mar 29, 2020, 18:55:54 u View
base_service_basic DaemonSet Mar 29, 2020, 18:55:54 — View
base_service_inner_db Job Mar 29, 2020, 18:55:54 View
base_service_inner_coredns Job Mar 29, 2020, 18:55:54 View

=]
Av4

Submit Diagnosis Entries per Page: 10 Total Entries: 15 - 2

3. Inthe message that appears, click OK.

7.1.7.1.3. Delete a diagnostic item

You can delete a diagnostic item. You can only delete imported diagnostic items, but not the
diagnostic items preset by the system.

Procedure

1. Inthe left-side navigation pane of the PaaS console, select Diagnostic ltems fromthe Platform
Diagnostics drop-down list.

2. Find the target diagnostic item. Click Delete in the Actions column.

3. Inthe message that appears, click OK.

7.1.7.2. Diagnostic tasks

The Diagnostic Tasks page displays all diagnostic tasks. On this page, you can view diagnostic progress,
view diagnostic reports, download diagnostic reports, terminate diagnostic tasks, and delete
diagnostic tasks.

7.1.7.2.1. View diagnostic progress

Afteryou start a diagnostic task, you can view its diagnostic progress on the Diagnostic Tasks page.

Procedure

1. Inthe left-side navigation pane of the PaaS console, select Diagnostic Tasks fromthe Platform
Diagnostics drop-down list.

2. Find the target diagnostic task. Click Diagnostic Progress inthe Actions column.

3. Onthe Diagnostic Progress page, clickthe task nodes in sequence to view the diagnostic
progress and logs of the current diagnostic task.
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| Diagnostic Progress Details

FHASE

@ Succeeded

ark-diagnose-jycpi

START TIME

Apr 22, 2020, 14:37:03
Generateltems

END TIME

Apr 22, 2020, 14:37:20
Runningltems

DURATION

17 Seconds

7.1.7.2.2. View a diagnostic report
After a diagnostic taskis complete, you can view its diagnostic report.

Prerequisites

You can view the diagnostic report only for a diagnostic taskin the Succeeded state.

Procedure

1. Inthe left-side navigation pane of the PaaS console, select Diagnostic Tasks fromthe Platform
Diagnostics drop-down list.

2. Find the target diagnostic task. Click View Report inthe Actions column.

3. Inthe pane that appears, view the diagnostic results, such as the name, status, and details.

7.1.7.2.3. Download a diagnostic report

After a diagnostic task is complete, you can download its diagnostic report to your on-premises
machine for offline query and analysis.

Prerequisites

You can download the diagnostic report only for a diagnostic task in the Succeeded state.

Procedure

1. Inthe left-side navigation pane of the PaaS console, select Diagnostic Tasks fromthe Platform
Diagnostics drop-down list.

2. Find the target diagnostic task. ClickDownload in the Actions column.

7.1.7.2.4. Terminate a diagnostic task

You can terminate a diagnostic task in the Running state.
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Procedure

1. Inthe left-side navigation pane of the PaaS console, select Diagnostic Tasks fromthe Platform
Diagnostics drop-down list.

2. Find the target diagnostic task. Choose More > Terminate in the Actions column.

3. Inthe message that appears, click OK.

7.1.7.2.5. Delete a diagnostic task

You can delete a diagnostic task that is no longer needed.

Procedure

1. Inthe left-side navigation pane of the PaaS console, select Diagnostic Tasks fromthe Platform
Diagnostics drop-down list.

2. Find the target diagnostic task. Choose More > Delete inthe Actions column.

3. Inthe message that appears, click OK.

7.1.8. Alerts

The Alerts module implements unified management of alerts in the PaaS console. You can view alert
rules, notification channels, and alert events. You can also configure alert rules and notification
channels inthe Alerts module.

7.1.8.1. Alert rule groups

An alert rule must belong to an alert rule group. You can create alert rule groups and add alert rules to
alert rule groups.

7.1.8.1.1. Create an alert rule group

You can create an alert rule group. When you create an alert rule group, you must add an alert rule to
the group.

Procedure

1. Inthe left-side navigation pane of the PaaS console, select Alert Groups fromthe Alerts drop-
down list.

2. Inthe upper part of the page, select the target cluster fromthe drop-down list.
3. Inthe upper-right corner of the page, click Create Rule Group.

4. Inthe Create Rule Group dialog box, configure the parameters.
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Create Rule Group X

Rule Group Name

Alert Group Name

TTL 0 o m A
Rule Mame
Level Select e
Massage
Expression
Operator e Aggregate Operz ™ Built-in Function e
Parameter Description
Rule Group Name The globally unique name of the alert rule group.

The globally unique name of the alert group. An alert rule group

Alert Group Name
must have an alert group.

Specifies the time period that an error lasts for before an alert is

sent.
TTL o h: indicates hours.

© m: indicates minutes.

o s: indicates seconds.
Rule Name The globally unique name of the alert rule.

The severity of the alert. Valid values:
Level © Warning: indicates a warning alert.

o (Critical: indicates a critical alert.
Message The description of the alert.

The criteria to trigger the alert.
Expression @ Note We recommend that you select operators,

aggregate operations, or built-in functions from the drop-
down lists if you need to use them in the expression.
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5. Click Submit.

7.1.8.1.2. Create an alert rule

Afteryou create an alert rule group, you can add an alert rule to the group.

Prerequisites

An alert rule group is created. For more information about how to create an alert rule group, see Create
an alert rule group.

Procedure

1. Inthe left-side navigation pane of the PaaS console, select Alert Groups fromthe Alerts drop-
down list.

2. Inthe upper part of the page, select the target cluster fromthe drop-down list.

3. Find the target rule group. Click Modify Rule inthe Actions column.
The Rules page is displayed. You can view all alert rules in the alert rule group.

| Rules Create Rule
Rule Name TTL Label Annctations Expressicn A
AlertmanagerConfiginconsistent 5m fi??c'arf: meszage: The configuration of the ... count_values("config_hash", alertma... Jodify Delete
AlertmanagerFailedReload 10m ':f;;':il:i:: meszage: Reloading Alertmanager’... alertmanager_config_last_reload_su... Viodify Delete
. = severity:
AlertmanagerMembersinconsistent  om Sy

critical message: Alertmanager has not fo... alertmanager_cluster_members{job... Vodify Delet

4. Inthe upper-right corner of the page, click Create Rule.

5. Inthe Create Rule dialog box, configure the parameters.

Create Rule

TTL 0 4+ m
Rule Mame

Level Select

Message
Expression
i Opera Aggregate Built-in i
Parameter Description
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Parameter Description

Specifies the time period that an error lasts for before an alert is

sent.
TTL o h: indicates hours.

© m: indicates minutes.

o s: indicates seconds.
Rule Name The globally unique name of the alert rule.

The severity of the alert. Valid values:
Level © Warning: indicates a warning alert.

o Critical: indicates a critical alert.
Message The description of the alert.

The criteria to trigger the alert.
Expression @ Note We recommend that you select operators,

aggregate operations, or built-in functions from the drop-
down lists if you need to use them in the expression.

6. ClickSubmit.

7.1.8.1.3. Modify an alert rule

You can modify an alert rule.

Procedure

1. Inthe left-side navigation pane of the PaaS console, select Alert Groups fromthe Alerts drop-
down list.

In the upper part of the page, select the target cluster fromthe drop-down list.
Onthe Rule Groups page, view all alert rule groups defined in the system.

Find the rule group for the target rule. Click Modify Rule inthe Actions column.
On the Rules page, view all alert rules in the rule group.

Find the target rule. Click Modify in the Actions column.

N o v M w N

Modify the TTL, Level, Message, and Expression parameter settings of the alert rule.

Parameter Description
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Parameter Description

Specifies the time period that an error lasts for before an alert is
sent.

TTL o h: indicates hours.

© m: indicates minutes.

o s:indicates seconds.

The severity of the alert. Valid values:
Level © Warning: indicates a warning alert.

o (Critical: indicates a critical alert.
Message The description of the alert.

The criteria to trigger the alert.

Expression @ Note We recommend that you select operators,
aggregate operations, or built-in functions from the drop-
down lists if you need to use them in the expression.

8. ClickSubmit.

7.1.8.1.4. Delete an alert rule

You can delete an alert rule that is no longer needed from an alert rule group.

Procedure

1. Inthe left-side navigation pane of the PaaS console, select Alert Groups fromthe Alerts drop-
down list.

In the upper part of the page, select the target cluster fromthe drop-down list.
On the Rule Groups page, view all alert rule groups defined in the system.

Find the rule group for the target rule. Click Modify Rule inthe Actions column.
On the Rules page, view all alert rules in the rule group.

Find the target rule. Click Delete inthe Actions column.

N oouv b~ w N

In the message that appears, click OK.

7.1.8.1.5. Delete an alert rule group

You can delete an alert rule group that is no longer needed.

Procedure

1. Inthe left-side navigation pane of the PaaS console, select Alert Groups fromthe Alerts drop-
down list. The Rule Groups page is displayed.

2. Inthe upper part of the page, select the target cluster fromthe drop-down list.
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3. Find the target rule group. Click Delete inthe Actions column.

4. Inthe message that appears, click OK.

7.1.8.2. Notification channels

You can view and modify notification channel settings on the Notification Channels page.

7.1.8.2.1. View notification channel settings
You can view the current notification channel settings.

Procedure

1. Inthe left-side navigation pane of the PaaS console, select Notification Channels fromthe
Alerts drop-down list.

2. Inthe upper part of the page, select the target cluster fromthe drop-down list.

3. Inthe Global Settings, Routing, and Receiver sections, view the relevant information.

7.1.8.2.2. Modify notification channel settings

You can modify notification channel settings such as global settings, routing, and receivers.

7.1.8.2.2.1. Modify global settings

You can modify global settings, such as the resolve_timeout, smtp_info, and notifications settings.

Procedure

1. Inthe left-side navigation pane of the PaasS console, select Notification Channels fromthe
Alerts drop-down list.

2. Inthe upper part of the page, select the target cluster fromthe drop-down list.
3. Inthe upper-right corner of the page, click Edit.

4. Inthe Global Settings section, modify the resolve_timeout, smtp_info, and notifications settings.
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Global Settings

resolve_timeout () — 5 + " .
smtp_info « @
Attribute Key Attribute Value
smitp_from

smtp_smarthost
smitp_hello
smtp_auth_username
smtp_auth_password
smitp_auth_identity

smitp_auth_secret

smitp_require_tls @
nofifications \)

Parameter Description

. Specifies the time period before an alert is marked as resolved if
resolve_timeout . e
- the Alertmanager does not receive further notifications of the alert.

Specifies global SMTP information.

To modify this item, turn on the switch on the right and then click
the Show icon. You can configure the following parameters:

o smtp_from: the source email address used to send alerts.

o smtp_smarthost: the SMTP server address and port number
for the source email address used to send alerts. Example:
smtp_smarthos t:smtp.example.com:465

o smtp_hello: the default hostname that identifies the SMTP
server.

smtp_info o smtp_auth_username, smtp_auth_password: the username
and password for the source email address used to send alerts.

o smtp_auth_identity: specifies the PLAIN SMTP authentication
method.

o smtp_auth_secret: specifies the CRAM-MD5 SMTP
authentication method.

o smtp_require_tls: the default SMTP TLS configuration.
Although the default value is true, the parameter is typically set
to false to avoid starttls errors that occur if the parameter is set
totrue.
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Parameter Description

The Slack configuration.

To modify this item, turn on the switch on the right and then click
the Show icon. You can configure the following parameters:

o
o
o

o

notifications

slack_api_url: the API URL for Slack notifications.
victorops_api_key: the VictorOps API key.
victorops_api_url: the VictorOps API URL.
pagerduty_url: the destination URL for API requests.
opsgenie_api_key: the Opsgenie API key.

opsgenie_api_url: the destination URL for Opsgenie API
requests.

hipchat_api_url: the source URL for APl requests.
hipchat_auth_token: the authentication token.
wechat_api_url: the WeChat API URL.
wechat_api_secret: the WeChat API key.
wechat_api_corp_id: the WeChat API corporate ID.

5. Inthe upper-right corner of the page, click Save.

7.1.8.2.2.2. Modify routing settings

You can modify global routing settings, and create or delete sub-routes.

Procedure

1. Inthe left-side navigation pane of the PaaS console, select Notification Channels fromthe

Alerts drop-down list.

2. Inthe upper part of the page, select the target cluster fromthe drop-down list.

3. Inthe upper-right corner of the page, click Edit.

4. Inthe Routing section, performthe following operations:

o Modify routing settings

You can modify the default route or subroutes.
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Routing

Default Route

Attribute Key

receiver
group_wait
group_interval
repeat_interval
group_by
continue
match

match_re

Subroutes

Attribute Key

receiver
group_wait
group_interval
repeat_interval
group_by
continue

match

match_re

Parameter

Attribute Value

null
30=
5m
12h
job
-
Add

Add

Attribute Value

null

Separate multiple val

(1>
Add

alertname

Add

Description

=

Watchdog ]
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Parameter

Default Route

Subroutes

Description

The global route. You can configure the route information based
on the actual environment.

= receiver: the name of the alert receiver.

® group_wait: specifies the waiting time to initialize a message
when a new alert group is created. This method ensures that
the system can have enough time to obtain multiple alerts for
the same alert group, and then trigger an alert message.

® group_interval: specifies the waiting time to send a new alert
message.

® repeat_interval: specifies the waiting time to resend an alert
message.

® group_by: the tag list. It is the regrouping tag list after alert
messages are received. For example, all received alert

messages that containthe cluster=A and alertname=Latncy
High tags are aggregated into a group.

® continue: specifies whether an alert matches subsequent
nodes.

® match: Click Add and specify a receiver for matched alerts.

® match_re: Click Add. Enter a regular expression and specify a
receiver for alerts that match the regular expression.

Configure subroutes in a similar way to the global route, so that
you can export an alert type to another location.

® receiver: the name of the alert receiver.

® group_wait: specifies the waiting time to initialize a message
when a new alert group is created. This method ensures that
the system can have enough time to obtain multiple alerts for
the same alert group, and then trigger an alert message.

®m group_interval: specifies the waiting time to send a new alert
message.

= repeat_interval: specifies the waiting time to resend an alert
message.

= group_by: the tag list. It is the regrouping tag list after alert
messages are received. For example, all received alert

messages that contain the cluster=A and alertname=Latncy

High tags are aggregated into a group.

® continue: specifies whether an alert matches subsequent
nodes.

® match: click Add. Enter the key and value of a tag and specify
a receiver for alerts that match the tag.

® match_re: click Add. Enter a regular expression based on the
key and value of atag and specify a receiver for alerts that
match the regular expression.
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o Create asubroute

To export an alert type to another location, you can click Add Subroute in the lower part of
the Routing section to configure a new subroute.

o Delete a subroute

In the Routing section, find a subroute that is no longer needed and click the Delete iconto
delete the subroute.

Routing

Default Route

Subroutes -~ (\'
Attribute Key Attnbute Value
receiver null
group_wait
group_interval
repeat_interval
group_by Separate multiple values 1
continue [:D
match Add
alertname ' Watchdog Q
match_re Add

7.1.8.2.2.3. Modify receiver settings

You can create, modify, or delete alert receiver settings.

Procedure

1. Inthe left-side navigation pane of the PaaS console, select Notification Channels fromthe
Alerts drop-down list.
2. Inthe upper part of the page, select the target cluster fromthe drop-down list.

3. Inthe upper-right corner of the page, click Edit.
4. Inthe Receivers section, performthe following operations:
o Modify receiver settings

Modify the name and type of a receiver.

Receivers Add Receiver

" nul _@_
Receiver Mame nu
Receiver Type Sele
Parameter Description
Receiver Name The name of the alert receiver.
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Parameter

Receiver Type

o Add a receiver

Description

Valid values for Receiver Type: webhook and email.

If Receiver Type is set to webhook, you must configure the
following parameters:

= url: the URL of the alert receiver.

= send_resolved: specifies whether to send messages for
resolved alerts. Default value: No.

If Receiver Type is set to email, you must configure the following
parameters:

®m send_resolved: specifies whether to send messages for
resolved alerts. Default value: No.

® to: the destination email address for alerts.
B from: the source email address used to send alerts.

® smarthost: the server address and port number for the source
email address used to send alerts.

® hello: the default hostname that identifies the email server.

® aguth_username: the username for the source email address
used to send alerts.

® auth_password: the password for the source email address
used to send alerts.

= auth_secret: specifies the CRAM-MD5 authentication method.
= auth_identity: specifies the PLAIN authentication method.

= require_tls: the default TLS configuration. Although the
default value is Yes, the parameter is typically set to No to
avoid starttls errors that occur if the parameter is set to Yes.

In the upper-right corner of the Receivers section, click Add Receiver. Configure the

parameters.

o Delete areceiver

In the Receivers section, find the target receiver and click the Delete iconto delete a receiver

that is no longer needed.
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Receivers Add Receiver

Receiver Mame U
Receiver Type wehhook
Attribute Key Attribute Value
url
send_resolved E
=
> Receiver o

7.2. Harbor-based image repository
console

7.2.1. Overview

This topic describes the features and purposes of Harbor.

The Harbor service is integrated into Apsara Stack Agility PaaS Kubernetes to provide a high-availability
image repository and support image permission control, security scanning, and synchronization.

You can use Docker to push and pull images, as well as grant different image repository permissions to
different roles.

Harbor 1.9.3 is an open-source tool. This documentation only provides basic instructions on image
pushing and permission control. For more information about the features of Harbor, visit
https://github.com/goharbor/harbor/blob/release-1.9.0/docs/user_guide.md.

7.2.2. Preparations

Before you use the Harbor-based image repository, you must obtain the domain name of the Harbor-
based image repository and configure the host information.

7.2.2.1. Query the domain name of the Harbor-based

image repository

Afterthe environment is deployed, you can performthe following steps to query the domain name of
the Harbor-based image repository:

Procedure

1. Log onto the master1 node.

2. Runthe following command: kubectl get ingress -n acs-harbor
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[root@node2 ~]# kubectl get ingress -n acs—-harbor
INAME, HOSTS ADDRESS PORTS AGE

harbor-harbor-ingress harbor.myk8s.paas.com 80 3dz2h
[root@node2 ~]1# I

You can obtain the domain name of the Harbor-based image repository based on the returned
result.

For example, if the returned result is harbor.myk8s.paas.com , the domain name of the Harbor-
based image repository is harbor.myk8s.paas.com:80.

7.2.2.2. Configure host information

Before you use the Harbor-based image repository, you must perform a series of configurations to
ensure that each machine in the cluster can access the Harbor-based image repository.

Add master1 node information

If the DNS of the machine accessing the Harbor-based image repository cannot resolve to the domain

name of the repository, you must add the following content to the /etc/hostsfile of the machine:

XX.XX.XX.XX harbor.myk8s.${domain}

In this example, the domain name of the Harbor-based image repository is harbor.myk8s.paas.com .
You must add the following content to the /etc/hosts file:

XX.XX.XX.XX harbor.myk8s.paas.com

Inthe content, xx.xx.xx.xx isthe IP address of the master1 node.

Configure insecure-registry for Docker

You must access the Harbor-based image repository over HTTP because Harbor does not have TLS
enabled. If the current machine encounters HTTPS problems when attempting to use Docker to access
the Harbor-based image repository, you can solve these problems by configuring insecure-registry.

This example shows how to configure insecure-registry for Linux machines. Follow these steps:
1. Log onto each node of the PaaS cluster separately.
2. Find the daemon.jsonfile in the /etc/docker/daemon.jsondirectory.
3. Add the domain name of the Harbor-based image repository to the daemon.jsonfile.

An example of the result is as follows:

{
"insecure-registries";[
"harbor.myk8s.paas.com:80"
]

}
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4. Afterthe modification, run the following command to restart Docker: systemctl restart docker

7.2.3. Log on to the Harbor-based image
repository console

This topic describes how to log on to the Harbor-based image repository console.

Prerequisites

Before you log on to the Harbor-based image repository console, make sure that the following
requirements are met:

e You have obtained the URL of the Harbor-based image repository console. For more information, see
Query the domain name of the Harbor-based image repository.

e You have obtained the username and password that are used to log on to the Harbor-based image
repository console fromthe deployment personnel or administrator.

e We recommend that you use the Google Chrome browser.

Procedure

1. Enterthe access URL of the Harbor-based image repository console in the address bar:
harbor.myk8s.${domain}:80. Press the Enter key.

@ Note ff you cannot access the Harbor-based image repository console, see Configure
host information.

2. Enter your username and password.

@ Note We recommend that you change your password immediately after you log onto
the Harbor-based image repository console.

Method: In the upper-right corner of the page, click Change Password. Enter the current
password and new password, and confirmthe password. Click OK.
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3.

Harbor

Remember me Forgot password

Click LOG IN.

7.2.4. Create users

Afterlogging onto the Harbor-based image repository console, an administrator must create users to
meet different requirements for access control.

Procedure

1.

Log onto the Harbor-based image repository console as an administrator.

2. Inthe left-side navigation pane, choose Administration > Users.
3.
4

On the Users page, click NEW USER.

. Inthe New User dialog box that appears, set Username, Email, First and last name, Password,

Confirm Password, and Comments. Click OK.
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New User

Username * info

Email * info@example.com
First and last name * infotest
Password * [

Confirm Password *
Comments

7.2.5. Create projects

Projects are containers that store image repositories. You must create a project before you can push or
pull images.

Procedure

1. Log onto the Harbor-based image repository console as an administrator.
2. Inthe left-side navigation pane, click Projects.

3. Onthe Projects page, click NEW PROJECT.
4

. Inthe New Project dialog box that appears, configure the following parameters.
Parameter Description

Project Name The name of the project to be created.

The access level of the project. Whether the project is public
determines whether permissions are required to pull images from
Access Level the image repository.

If Public is selected, all users including unlogged users are allowed
to use Docker to pull images.

The maximum number of images that can be stored in the image
repository. The default value is -1, indicating that no upper limit is
set on the number of images that can be stored in the image
repository.

Count quota
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Parameter Description

The storage capacity of the image repository. The default value is -
Storage quota 1, indicating that no upper limit is set on the storage capacity of
the image repository.

New Project

Project Name info_library|

Access Level Public @

Count quota * 10000 @
Storage quota * 500 g~ @

5. Click OK. By default, the creator of the project is the project administrator.

7.2.6. Grant project permissions

After creating a user and a project, you must grant the user project permissions so that the user can
access the project.

Prerequisites

e A useris created. For more information about how to create a user, see Create users.

e A project is created. For more information about how to create a project, see Create projects.

Procedure

1.

o v M W N

Log on to the Harbor-based image repository console as an administrator.

In the left-side navigation pane, click Projects.

In the project list, find the project you just created and click the project name.
Click the Members tab.

Click+ USER.

Inthe New Member dialog box that appears, configure the following parameters.
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Parameter Description

Enter the name of the user to whom you want to grant project
Name permissions. For example, you can enter the name of the user you
just created.

Valid values:

o Project Admin: This role has all project permissions such as
those to push images, pull images, and configure the project.

o Master: This role has the permissions to push images and pull
images.

Role

o Developer: This role has the permissions to push images and
pull images.

o Guest: This role has the permission to pull images.

New Member
Add a user to be a member of this project with specified role

Name * info
Role © Project Admin
| Master
) Developer
) Guest
7. Click OK.

7.2.7. Push images

To deploy your applications on the cloud, you must push images to the Harbor-based image repository.

Prerequisites
Before you push images, make sure that the following requirements are met:

e You have the permission to push images as a project administrator, maintenance personnel, or
developer.

e The image to be pushed is available. It can be a local image or an image downloaded from another
image repository.
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@ Note
o The Harbor-based image repository does not support images with manifest v2 schema 1.

o The Harbor-based image repository limits the size of an image layerto 5,000 MB. If this
limit is exceeded, the image will failto be uploaded. If an image layer is larger than 5,000
MB in size, reduce the size of the image.

Procedure

1. Inthe left-side navigation pane of the Harbor-based image repository console, click Projects.

2. Inthe project list, find the project to which you want to push the image and click the project name.
3. Clickthe Repositories tab.
4. Inthe upper-right corner of the page, click PUSH IMAGE. The command used to push images is
displayed.
info_library
summary Repositories Members Labels Logs Robot Accounts Tag Retention Webhooks Configuration
PUSH IMAGE ~ O\ E=|C
Push Image @
[[]  Name
Tag an image for this project:
docker tag SOURCE_IMAGE[:TAG] harbor.myk8s n E
Push an image to this project:
docker push harbor.myk8s! = vinfo_library/IMAC E
y ready! O items

@ Note The specific domain name of the image repository to which you push images varies
with the environment. This topic uses the domain name harbor.myk8s.paas.com:80 of the
Harbor-based image repository as an example.

5. Tag and push the image by using the displayed commands.
i. Log onto the masterl node.
ii. Prepare the image to be pushed in the local environment.
iii. Runthe following command to tag the image.
In this example, the 7.73.3-k8stag is added to the info_library/nginximage repository.

docker tag info_library/nginx:1.13.3-k8sharbor.myk8s.paas.com:80 /info_library/nginx:1.7
3.3-k8s
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iv. Use the Docker command to log onto the image repository.

a. Runthe following command to log on to the image repository:

docker login harbor.myk8s.paas.com:80

b. Enterthe administrator account and password of the image repository.

Afteryou log onto the image repository, Login Succeeded is displayed.

P Notice If the system prompts that the certificate verification failed during
logon, you must referto Configure host information to complete the configuration of

insecure-registry.

v. Afteryou log onto the image repository, run the following command to push the tagged

image to the current project:

docker push harbor.myk8s.paas.com:80/info_library/nginx:1.13.3-k8s

6. Wait a few minutes and then log on to the Harbor-based image repository console again. On the
Projects page, the value of Repositories Count corresponding to the info_library project is

displayed as 1.

NEW PROJECT

[ Project Name + | Access Level
O info_library Public
O Public
[m] Public

Role

Project Admin
Project Admin

Project Admin

All Projects

Repositories Count Creation Time

2

3/30/20, 539 PM
3/30/20, 6:49 AM
3/12/20, 6:22 PM

7. Clickthe project name. On the page that appears, clickthe Repositories tab to view the pushed

image.

8. Clickthe image name to view the image tag.

info_library/nginx

Info Images
O Tag v Size
0 113.3-kss 12.05MB

Pull Command

O

Vulnerability

(Mot Scanned )
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8.1. ApsaraDB for RDS
8.1.1. Architecture
8.1.1.1. System architecture

8.1.1.1.1. Backup system

ApsaraDB for RDS can back up databases at any time and restore themto any point in time based on
the backup policy, which makes the data more traceable.

Automatic backup
ApsaraDB RDS for MySQL supports both physical and logical backup.

You can flexibly configure the backup start time based on the service off-peak hours. All backup files
are retained for seven days.

Temporary backup

You can create temporary backup files when necessary. Temporary backup files are retained for seven
days.

Log management

ApsaraDB RDS for MySQL automatically generates binlogs and allows you to download themfor local
incremental backup.

Instance cloning

A cloned instance is a new instance with the same content as the primary instance, including data and
settings. This feature allows you to restore data of the primary instance or create multiple instances
that are the same as the primary instance.

8.1.1.1.2. Monitoring system

RDS provides multi-dimensional monitoring services across the physical, network, and application layers
to ensure business availability.

Performance monitoring

RDS provides nearly 20 metrics for system performance monitoring, such as disk capacity, IOPS,
connections, CPU utilization, network traffic, TPS, QPS, and cache hit rate. You can obtain the running
status information for any instances within the past year.

SQL auditing
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The systemrecords the SQL statements and related information sent to RDS instances, such as the
connection IP address, database name, access account, execution time, and number of records
returned. You can use SQL auditing to check instance security and locate problems.

Threshold alerts

RDS provides alert SMS notifications if status or performance exceptions occur in the instance.

These exceptions can be involved in instance locking, disk capacity, IOPS, connections, and CPU. You can
configure alert thresholds and up to 50 alert recipients (of which five are effective at a time). When an
instance exceeds the threshold, an SMS notification is sent to the alert recipients.

Web operation logs

The system logs all modification operations in the RDS console for administrators to check. These logs
are retained for a maximum of 30 days.

8.1.1.1.3. Control system

If a host orinstance does not respond, the RDS high-availability (HA) component checks for exceptions
and fails over services within 30 seconds to guarantee that applications run normally.

8.1.1.1.4. Task scheduling system

You can use the RDS console or APl operations to create and delete instances, or switch instances
between the internal network and Internet. All instance operations are scheduled, traced, and
displayed as tasks.

8.1.2. Log on to the Apsara Stack Operations
console

Prerequisites

e The URL of the ASO console, and the username and password used for logging on to the console are
obtained fromthe deployment personnel or an administrator.

The URL of the ASO console is in the following format: region-id.aso.intranet-domain-id.com.

e A browser is available. We recommend that you use the Google Chrome browser.

Procedure

1. Open your browser.

2. Inthe address bar, enter the URL region-id.aso.int ranet-domain-id.com and press the Enter key.
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Enter a user name

(@ Note Youcanselect a language from the drop-down list in the upper-right corner of the
page.

3. Enteryour username and password.

@ Note Obtain the username and password for logging on to the ASO console fromthe
deployment personnel or an administrator.

When you log onto the ASO console forthe first time, you must change the password of your
username as prompted.

To enhance security, a password must meet the following requirements:
o It must contain uppercase and lowercase letters.

o It must contain digits.

o [t must contain special characters such as exclamation points (1), at signs (@), number signs (#),
dollar signs ($), and percent signs (%).

o It must be 10 to 20 characters in length.

4. ClickLog On to gotothe ASO console.

8.1.3. Manage instances

You can view instance details, logs, and user information.

Procedure
1. Log onto the Apsara Stack Operations console.
2. Inthe left-side navigation pane, choose Products > RDS.
3. OntheInstance Management tab of the RDS page, you can performthe following operations:
o View instances

View instances that belong to the account on the Instance Management tab, as shown in
Instances.

Instances
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CcPU
Perfor

QpPs
Perfor.

10PS
Perfor.

Disk
Usage

Instance
Status

Insiance Name

Availa... Conne....

Creating

Using

o View instance details

Datab.
Type

Actions
mysql

redis

Clickthe ID of aninstance to view details, as shown in Instance details. You can switch your
service between primary and secondary instances and query historical operations on this page.

@ Note

We recommend that you do not perform forced switchover, because it may

result in data loss if data is not synchronized between the primary and secondary instances.

Instance details

Instance Information

Instance Name: m
Active-Standby Delay: 0
Connections: 0

Trafiic

Client Instance Level: P4
Database Version: 5.6

Cluster
Network Details of Instance Host
Host IP Addresses:
VIP IB_ID List of SLE:
Network Details of Instance-Attached Host

Host IP Addresses:

VIP IB_ID List of SLE:

Primary/Secondary Switch Query History

o View user information

CPU Performance: 0 %
QPS Performance: %
10PS Performance: 0 °
Aclive Threads: 0
Instance Status:

Link Type: Ivs

Created Al

Proxies:

ECS-yped Dedicated Host of Client Instance: No

Proxies:

EC3-typed Dedicated Host of Client Instance: No

Click User Information in the Actions column corresponding to an instance, as shown in User

information.

User information

User Information *>
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o Create backups

For ApsaraDB RDS for MySQL instances, click Create Backup inthe Actions columnto view the
backup information, as shown in Backup information. You can also click Create Single
Database Backup on the Backup Information page to back up a single database.

Backup information

Backup ID:

Instance Name:

Backup Switch: On

Retention Days: Estimated Time:
Database List Backup Time: 1

Backup Status: Next Backuj

Backup Method 3ackup Backup Typs: Full

Secondary Server IP: IDC:

Backup Start At - Backup Uploading Start At -
Backup Source: y Log Uploading Start At Se,
Backup Compression: Tabl

Backup Period: | # Monday [ Tuesday 'y# Wednesday o Thursday # Friday o Saturday o Sunday
Note:

Create Single Database Backup

8.1.4. Manage hosts

You can view and manage hosts.

Procedure

1. Log onto the Apsara Stack Operations console.
2. Inthe left-side navigation pane, choose Products > RDS.

3. Onthe Host Management tab of the RDS page, you can view the information of all hosts.
Instance Ma nage: ment

Normal offine

Normal

cn-gingd

Normal offline

4. Click a hostname to go to the RDS Instance page. You can view all instances on this host.
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| RDS Instance 3

8.1.5. Security maintenance

8.1.5.1. Network security maintenance
Network security maintenance consists of device and network security maintenance.

Device security

Check network devices and enable their security management protocols and configurations of devices.
Checkfortimely updates to secure versions of network device software.

For more information about the security maintenance method, see the device documentation.

Network security

Based on your network considerations, select the intrusion detection system (IDS) or intrusion
prevention system (IPS) to detect abnormal Internet and Intranet traffic and protect against attacks.

8.1.5.2. Account password maintenance

Account passwords include RDS system passwords and device passwords.

To ensure account security, you must periodically change the system and device passwords, and use
passwords with high complexity.
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9.Appendix
9.1. Operation Access Manager (OAM)
9.1.1. OAM introduction

Overview

Operation Access Manager (OAM) is a centralized permission management platform of Apsara Stack
Operations (ASO). OAM uses a simplified role-based access control (RBAC) model. Administrators can use
OAMto assign roles to operations personnel, granting them corresponding operation permissions to
operations systems.

OAM permission model

In RBAC, administrators do not directly grant system operation permissions to users. Instead, they create
a collection of roles between a collection of users and a collection of permissions. Each role
corresponds to a group of permissions. If a role is assigned to a user, the user is granted all the
operation permissions of that role. Therefore, when creating a user, administrators are only required to
assign a role to the user, saving the trouble to grant specific permissions to the user. In addition, the
frequency of role permission changes is less than that of user permission changes, simplifying the user
permission management and reducing the system overhead.

See the OAM permission model as follows.

Permission model
permission assignment

user assignment

subject

User /

. v

Role RoleCell

Resource

Group .
ActionSet

9.1.2. Instructions

Before using Operation Access Manager (OAM), you must know the following basic concepts about
permission management.

subject

Operators of the access control system. OAM has two types of subjects: users and groups.

user
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Administrators and operators of operations systems.

group
A collection of users.
role

The core of the role-based access control (RBAC) system.

Generally, a role can be regarded as a collection of permissions. A role can contain multiple RoleCells or
roles.

RoleHierarchy

In the OAM system, a role can contain other roles to form RoleHierarchy.

RoleCell

The specific description of a permission. A RoleCell consists of resources, ActionSets, and available
authorizations.

resource

The description of an authorized object. For more information about resources of operations
platforms, see Permission lists of operations platforms.

ActionSet

The description of authorized actions. An ActionSet can contain multiple actions. For more information
about actions of operations platforms, see Permission lists of operations platforms.

available authorizations

The maximum number of authorizations in the cascaded authorization, which is an integer greater than
orequalto zero. If the value is not zero, the permission can be granted. If the value is zero, the
permission cannot be granted.

For example, if administrator A sets Available Authorizations to 5 when granting a permission to
administrator B, the permission can be granted for another five times at most. When administrator B
grants the permission to administrator C, the value of Available Authorizations cannot be greater
than 4. If Available Authorizations is set to 0 when administrator B grants the permission to operator
D, operator D can only use the permission but cannot grant it to others.

@ Note Current ly, OAM does not support the cascaded revocation for cascaded authorization.
Therefore, administrator C and operator D still have the permission even if the permission is revoked
for administrator B.

9.1.3. Quick Start

By completing the steps in this guide, you will learn how to create and assign roles for O&M.

9.1.3.1. Log on to OAM

This topic describes how to log on to Operation Administrator Manager (OAM).
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Prerequisites

e The URL of the ASO console, and the username and password used for logging onto the console are
obtained fromthe deployment personnel or an administrator.

The URL of the ASO console is in the following format: region-id.aso.intranet-domain-id.com.

e A browser is available. We recommend that you use the Google Chrome browser.

Procedure

1. Open your browser.

2. Inthe address bar, enter the URL region-id.aso.intranet-domain-id.com and press the Enter key.

(@ Note Youcanselect a language from the drop-down list in the upper-right corner of the
page.

3. Enteryour username and password.

@ Note Obtain the username and password for logging on to the ASO console fromthe
deployment personnel or an administrator.

When you log onto the ASO console forthe first time, you must change the password of your
username as prompted.

To enhance security, a password must meet the following requirements:
o It must contain uppercase and lowercase letters.
o It must contain digits.

o [t must contain special characters such as exclamation points (1), at signs (@), number signs (#),
dollar signs ($), and percent signs (%).

o It must be 10 to 20 characters in length.
4. ClickLog On to gotothe ASO console.
5. Inthe left-side navigation pane, choose Products > Product List.

6. Inthe Apsara Stack O&M > Basic O&M section, click OAM.

9.1.3.2. Create groups
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You can create user groups for centralized management.

Procedure
1. Logonto OAM.
2. Inthe left-side navigation pane, choose Group Management > Owned Groups.

3. Onthe Owned Groups page, click Create Group in the upper-right corner. Inthe Create Group
dialog box that appears, set Group Name and Description.

Create Group

Group Name: Ceeate Group

The group name is globally unigue.

Description:

4. Click Confirm.Afterthe group is created, it is displayed on the Owned Groups page.

9.1.3.3. Add group members

You can add members to an existing group to grant permissions to the group members in a centralized
manner.

Procedure

1. Log onto OAM.
2. Inthe left-side navigation pane, choose Group Management > Owned Groups.

3. Find the group whose name and description you want to modify and clickManage inthe Actions
column.

4. Inthe upper-right corner of the Group Member section, clickAdd Member.

Add Member

Search: Logon Account N w || Login Name, eg. example@aliyun.com Details

RAM User Account
Account Primary Key

Logon Account Name

5. Select a search mode, enter the corresponding information, and click Det ails. Details of the
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6.
7.

specified user are displayed.

Three search modes are available:

o RAM User Account: Search inthe format of RAM user@Apsara Stack tenant account ID.

o Account Primary Key: Search by using the unique ID of the Apsara Stacktenant account.

o Logon Account Name: Search by using the logon name of the Apsara Stacktenant account.
Click Add.

You can repeat the preceding steps to add multiple group members.To remove a memberfroma
group, clickRemove inthe Actions column corresponding to the member.

9.1.3.4. Add group roles

You can add roles to an existing group.

Prerequisites

e Therole to be added is created. For more information, see Create roles.

e You are the owner of the group and the role.

Procedure

1.
2.
3.

Log onto OAM.
In the left-side navigation pane, choose Group Management > Owned Groups.

Find the group whose name and description you want to modify and click Manage in the Actions
column.

In the upper-right corner of the Role List section, click Add Role.
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Add Role

Role Name | | Role Name

Role Name Owned By Description
roledoam_
roledoam_
roledoam_
roledoam_
roledozm_
roledoam_
roledoam_
roledozm_

roledoam_

o o o o o o o o o oog

roledoam_

Total: 286 item(s), Per Page: 10 item(s) « < 26 28 B £

Expiration Time: 1 Month o

5. Search forroles by Role Name. Select one or more roles and set Expiration Time.
6. Click Confirm.

To remove a role froma group, find the role in Role List, and clickRemove inthe Actions column.

9.1.3.5. Create roles

Procedure

1. Log onto OAM.
2. Inthe left-side navigation pane, choose Role Management > Owned Roles.

3. Onthe Owned Roles page, click Create Role inthe upper-right corner.
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Create Role
Role Name:
The role name is globally unigue.
Description:
Role Type: 0OAM w

Tag: Edit Tag

4. Inthe Create Role dialog box that appears, set Role Name, Description, and Role Type.
5. (Optional)Configure the role tags, which can be used to filter roles.

i. ClickEdit Tags.

Edit Tags

MaFa: fin #a 71 Faac —an A ~—h racn a
Note: Up to 10 tags can be bound to each resource.

Add: | Available Tags Create

ii. Inthe Edit Tags dialog box that appears, click Create.
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ii. Set Key and Value forthe tag and click Confirm.

Edit Tags

Add:  Available Tags  Key: Value: Cancel

iv. Repeat the preceding step to create more tags.
The created tags are displayed inside the dotted box.
v. Click Confirm to create the tags and exit the Edit Tags dialog box.

6. ClickConfirmto create the role.

9.1.3.6. Add inherited roles to arole

You can add inherited roles to a role to grant the permissions of the inherited roles to the role.

Prerequisites
You are the owner of the current role and the inherited role to be added.

For more information about how to query your owned roles, see Query roles.

Procedure

1. Logonto OAM.
In the left-side navigation pane, choose Role Management > Owned Roles.
Find the role to which you want to add an inherited role and click Manage in the Actions column.

Onthe Role Information page, clickthe Inherited Role tab.

oA wN

Click Add Role. Inthe Add Role dialog box that appears, search for roles by Role Name. Select
one or more roles.
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Add Role

Role Name | | Role Name

Role Name Owned By Description
roledoam_

roledoam_ u

roledoam_

roledoam_

roledoam_
roledoam_
roledoam_
roledoam_

O
O
O
O
g
O  roledoam,
a
a
a
O
O

roledoam_

Total: 286 item(s), Per Page: 10 item(s) & < 27 n 20 » P
O

6. Click Confirm.

9.1.3.7. Add resources to a role
You must add resources to a created role.

Procedure

1. Logonto OAM.

In the left-side navigation pane, choose Role Management > Owned Roles.

Find the role to which you want to add a resource and click Manage in the Actions column.
Onthe Role Information page, clickthe Resource List tab.

Click Add Resource.

vk W
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Add Resource

BID: *
Product: *
Resource Path: *
Actions: read,
write

Use "," to split actions. For example, write,\n read.

Available 0
Authorizations:

Description:
Resource: T

6. Inthe Add Resource dialog box, complete the configurations. For more information, see

Parameters.
Parameters
Parameter Description
BID The deployment region ID.
The cloud product to be added, such as rds.
Product @ Note The cloud product name must be lowercase. For
example, enter rds instead of RDS.
The resources of the cloud product. For more information about
Resource Path resources of the 0&M platforms, see Permission lists of operations

platforms.
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7.

Parameter Description
An action set, which can contain multiple actions.
Actions For more information about actions on the O&M platforms, see

Permission lists of operations platforms.

The maximum number of authorizations in cascaded authorization, which

Available must be an integer greater than or equal to zero. If the value is not zero,
Authorizations the permission can be granted. If the value is zero, the permission cannot
be granted.
Description The description of the resource.
ClickAdd.

9.1.3.8. Assign a role to authorized users

You can assign an existing role to users or user groups.

Prerequisites

The corresponding users or user groups are created. Users are created in the Apsara Uni-manager
console. For more information about how to create a user group, see Create groups.

Procedure

1.

o U A W N

Log onto OAM

. Inthe left-side navigation pane, choose Role Management > Owned Roles.

. Find the role that you want to assign to a user and clickManage in the Actions column.
. Onthe Role Information page, click the Authorized Users tab.

. Click Add User in the upper-right corner.

. Select a search mode and enter corresponding information to search for the user to which you

want to assign the role.
Four search modes are available:

o RAM User Account: Enter a RAM user in the format of RAM user@Apsara Stack tenant account |
Dto search forthe RAM user.

o Account Primary Key: Search by using the unique ID of the Apsara Stacktenant account.
o Logon Account Name: Search by using the logon name of the Apsara Stacktenant account.

o Group Name: Search by group name.

(@ Note Youcansearchfora single user or user group. For more information about how to
create a user group, see Create groups.

. Set Expiration Time.When the specified expiration time is due, the user no longer has the

permissions of the role. To authorize the user again, the role creator must clickRenew inthe
Actions column corresponding to the authorized user on the Authorized Users tab to modify the
expiration time.
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8. Click Add to assign the role to the user.To cancel the authorization, clickRemove in the Actions
column corresponding to the authorized user on the Authorized Users tab.

9.1.4. Manage groups

Group management allows you to view, modify, and delete groups.

9.1.4.1. Modify group information

Afteryou create a group, you can modify the group name and description on the Group Information
page.

Procedure

1. Logonto OAM.
2. Inthe left-side navigation pane, choose Group Management > Owned Groups.

3. Find the group whose name and description you want to modify and click Manage inthe Actions
column.

4. Onthe Group Information page, click Modify in the upper-right corner.
5. Inthe Modify Group dialog box that appears, modify the group name and description.
6. Click Confirm.

9.1.4.2. View group role details
You can view information about the inherited roles, resource list, and inheritance tree of a group role.

Prerequisites

A role is added to the group.

Procedure

1. Logonto OAM.
2. Inthe left-side navigation pane, choose Group Management > Owned Groups.

3. Find the group whose name and description you want to modify and clickManage inthe Actions
column.

4. InRole List section, click Details in the Actions column corresponding to a role.
5. Onthe Role Information page, performthe following operations:
o Clickthe Inherited Role tab to view the information about the inherited roles of the role.

To view the detailed information of an inherited role, click Det ails in the Actions column
corresponding to the inherited role.

o Clickthe Resource List tab to view the resource information of the role.
For information about how to add other resources to this role, see Add resources to arole.

o Clickthe Inheritance Tree tab to view the basic information and resource information of the
role and its inherited roles by using the inheritance tree onthe left.
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9.1.4.3. Delete groups

You can delete groups that are no longer needed.

Prerequisites

The group to be deleted does not contain members.

Procedure

1. Log onto OAM.
2. Inthe left-side navigation pane, choose Group Management > Owned Groups.

3. Find the group to be deleted and click Delete inthe Actions column.

9.1.4.4. View authorized groups

You can view the groups to which you are added on the Authorized Groups page.

Context

You can view only the groups to which you belong, but cannot view groups of other users.

Procedure

1. Logonto OAM.
2. Inthe left-side navigation pane, choose Group Management > Authorized Groups.

3. Onthe Authorized Groups page, view the name, owner, description, and modification time of the
group to which you belong.

9.1.5. Manage roles

Role management allows you to view, modify, transfer, and delete roles.

9.1.5.1. Query roles

You can view your owned roles on the Owned Roles page.

Procedure
1. Log onto OAM.
2. Inthe left-side navigation pane, choose Role Management > Owned Roles.

3. Enter arole name in the Role Name field and click Search to search for roles that meet the search
criteria.

@ Note If the role you want to search for has atag, you can click Tag and select the tag
key to search forthe role based on the tag.
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Owned Roles

Show By Role Owner: | Current User ~ Role Name + m
BT

9.1.5.2. Modify role information
Afteryou create arole, you can modify the role information.

Procedure

1. Logonto OAM.

In the left-side navigation pane, choose Role Management > Owned Roles.

Find the role whose information you want to modify and clickManage inthe Actions column.
Onthe Role Information page, clickModify in the upper-right corner.

In the Modify Role dialog box that appears, set Role Name, Description, Role Type and Tag.

A S

Click Confirm.

9.1.5.3. View the role inheritance tree

You can view the role inheritance tree to learn about the basic information and resource information of
arole and its inherited roles.

Procedure
1. Log onto OAM.
2. Inthe left-side navigation pane, choose Role Management > Owned Roles.
3. Find the role whose information you want to modify and click Manage in the Actions column.
4. Onthe Role Information page, clickthe Inheritance Tree tab.

View the basic information and resource information of the role and its inherited roles by using the
inheritance tree onthe left.

Inherited Role  Resourcelist | Authorized Users | Inheritance Tree

Role Name: tesla_operator Role Type: OAM

Ovined By: Modified At: Jun 24, 2020, 1:58:44 AM
Description: teslz operator

Tag

odps. login, read o tesla_login Jun 24, 2020, 1:58:44 AM

Total: 1 item(s), Per Page: 15 item(s -

9.1.5.4. Transfer roles
You can transfer roles to other groups or users based on business requirements.

Procedure
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1. Log onto OAM.
2. Inthe left-side navigation pane, choose Role Management > Owned Roles.

3. Onthe Owned Roles page, configure the search condition and search forthe roles to be
transferred.

4. Select one or more roles in the search results and click Transfer in the lower-left corner.

5. Inthe Transfer dialog box that appears, select a search mode, enter the corresponding
information, and then click Det ails. Det ails of the user or group are displayed.

Four search modes are available:

o RAM User Account: Search in the format of RAM user@Apsara Stack tenant account ID.

o Account Primary Key: Search by using the unique ID of the Apsara Stacktenant account.

o Logon Account Name: Search by using the logon name of the Apsara Stacktenant account.

o Group Name: Search by group name.

Transfer

Search: Group Name w Details

Account Primary Key
Logon Account Mame
Group Name

6. ClickTransfer.

9.1.5.5. Delete arole

You can delete arole that is no longer in use according to business requirements.

Prerequisites

The role to be deleted does not contain inherited roles, resources, or authorized users.

Procedure

1. Logonto OAM.
2. Inthe left-side navigation pane, choose Role Management > Owned Roles.

3. At theright of the role to be deleted and then click Delete.

9.1.5.6. View assigned roles

You can view the roles assigned to you and permissions granted to the roles.

Procedure

1. Log onto OAM.
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2. Inthe left-side navigation pane, choose Role Management > Authorized Roles.

3. Onthe Authorized Roles page, you can view the name, owner, description, modification time,
and expiration time of each role assigned to you.You can also click Det ails in the Actions column
corresponding to arole to view the inherited roles, resources, and inheritance tree of the role.

9.1.5.7. View all roles

You can view all roles in Operation Administrator Manager (OAM) on the All Roles page.

Procedure
1. Logonto OAM.
2. Inthe left-side navigation pane, choose Role Management > All Roles.
3. Onthe All Roles page, view all the roles in the system.You can search for roles by Role Name.
4

. Click Details inthe Actions column corresponding to a role to view the inherited roles, resources,
and inheritance tree of the role.

9.1.6. Search for resources

You can search for resources to view the roles to which the resources are assigned.

Procedure

1. Logonto OAM.
2. Inthe left-side navigation pane, click Search Resource.

3. Set Resource and Action, and click Search to search for the roles that meet the specified
conditions.

Search Resource

Resource acton [ seaan |

W Tag Edit Tag

4. Click Details inthe Actions column corresponding to a role to view the inherited roles, resources,
and inheritance tree of the role.

9.1.7. View personal information

You can view the personal information of the current user on the Personal Information page and test
the user permissions.

Procedure
1. Logonto OAM.

2. Inthe left-side navigation pane, click Personal Information.

3. Inthe Basic Information section, you can view the username, type, creation time, AccessKey ID,
and AccessKey secret of the current user.

personal Information

Type: User Created At: Jun 24, 2020, 1:58:44 AM
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(@ Note You can click Show or Hide to show or hide the AccessKey secret.

4. Inthe Test Permission section, you can check whether the current user has a specific permission.

i. Enterthe resource information in the Resource field.

@ Note Usethe English input method when you enter values in the Resource and
Action fields.

ii. Enterthe permissions such as create, read, and write in the Action field. Separate multiple
permissions with commas (,).

9.1.8. Default roles and permissions

9.1.8.1. Default roles and their functions

This topic describes the default roles in Operation Access Manager (OAM) and their functions.

9.1.8.1.1. Default role of OAM

This topic describes the default role of Operation Access Manager (OAM) and the corresponding
available authorizations.

. . Available
Role name Role description Resource Actions .
authorizations
An administrator
with root
permissions

Super
administrator

9.1.8.1.2. Default roles of Apsara Infrastructure

Management Framework

This topic describes the default roles of Apsara Infrastructure Management Framework and the
corresponding available authorizations.

Apsara Infrastructure Management Framework is a distributed data center management system, used
to manage applications on clusters containing multiple machines, and provides basic functions such as
deployment, upgrade, expansion, contraction, and configuration change.

For more information about the default roles of Apsara Infrastructure Management Framework and the
corresponding available authorizations, see the following table.

Available

Role name Role description Resource Actions .
authorizations
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Role name

Tianji_Project
read-only

Tianji_Project
administrator

Tianji_Service
read-only

Role description

Has the read-only
permission to
Apsara
Infrastructure
Management
Framework
projects, which
allows you to
view the
configurations
and statuses of
all projects and
clusters

Has all the
permissions to
Apsara
Infrastructure
Management
Framework
projects, which
allows you to
view and modify
the configurations
and statuses of
all projects and
clusters

Has the read-only
permission to
Apsara
Infrastructure
Management
Framework
services, which
allows you to
view the
configurations
and templates of
all services

Resource

*:tianji: projects

*:tianji: projects

*:tianji:services

Actions

["read"]

"]

["read"]

Available
authorizations

274
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Role name Role description Resource Actions Avallaple .
authorizations

Has all the
permissions to
Apsara
Infrastructure
Management

Tianji_Service Framework

administrator services, which
allows you to
view and modify
the configurations
and templates of
all services

*:tianji: services ["*"] 0

Has all the
permissions to
Apsara
Infrastructure
Management
Framework data *:tianji:idcs ["*"] 0
centers, which
allows you to
view and modify
the data center
information

Tianji_IDC
administrator

Has all the
permissions to
Apsara
Infrastructure
Management
Framework, which
Tianji allows you to
administrator perform
operations on all
Apsara
Infrastructure
Management
Framework
configurations

*:tianji ["*"] 0

9.1.8.1.3. Default role of Tianjimon

This topic describes the default role of Tianjimon and the corresponding available authorizations.

Tianjimon, as the monitoring module of Apsara Infrastructure Management Framework, is used for the
basic monitoring function of physical machines and services deployed based on Apsara Infrastructure
Management Framework.

For more information about the default role of Tianjimon and the corresponding available
authorizations, see the following table.
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. . Available
Role name Role description Resource Actions .
authorizations
Has all Tianjimon
permissions,
Tianjimon which allows you
) . y . 26842:tianjimon:* ["*" 0
operations to perform basic
monitoring and
operations

9.1.8.1.4. Default roles of Opsapi

This topic describes the default roles of the Apsara Opsapi Management (Opsapi) system and the
corresponding grant options.

Opsapiis a platform that manages O&M APIs and SDKs in the Apsara Stack environment in a centralized
manner. This system also manages APl and SDK versions.

The following table describes the default roles of Opsapi and the corresponding grant options.

Role Role description Resource Action Grant option
Opsapi platform Has all the
P .p. P permissions on *:opsapi:* ["read","write"] 0
administrator .
Opsapi.

Has the read
permissions on

Opsapi platform Opsapl énd the *: opsapi:* ['read" "invoke"] 0
developer permissions to

call API

operations.
Opsapi common Has the read

permissions on *:opsapi:* ["read"] 0

user Opsapi.

9.1.8.1.5. Default roles of ASO

This topic describes the default roles of the Apsara Stack Operations (ASO) system and the
corresponding grant options.

ASOQis a centralized 0&M management systemthat is developed forthe Apsara Stack O&M personnel
to perform centralized O&M operations.

The following table describes the default roles of ASO and the corresponding grant options.

Role Role description Resource Action Grant option
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Role

ASO system
administrator

ASO security
officer

Role description

Has the
permissions to
manage platform
nodes, physical
devices, and
virtual resources,
back up, restore,
and migrate
product data, and
query and back up
system logs.

Has the
permissions to
manage
permissions,
security polices,
and network
security, and
review and
analyze security
logs and activities
of security audit
officers.

Resource

*:as0:api-
adapter:*

*:aso:auth:*

*:aso:backup:*

*:aso:cmdb:*

*.aso:doc:*

;aso:fullview:*

*:aso:init:*

*:aso:inventory:*

*:aso:itil:*

*:aso:lock:*

:aso:physical:*

*:aso:psm:*

*:aso0:scm:*

*:as0:serviceWhit
elist:*

*:aso:slalink:*

*:aso:task:*

*:aso:auth:*

*:aso:plat-
access:*

*:aso:twoFactorA

uth:*

Action

["read","write"]

["read"]

["read","write"]

["read","write"]

["read","write"]

["read","write"]

["read","write"]

["read","write"]

["read","write"]

["read","write"]

["read","write"]

["read","write"]

["read","write"]

["read","write"]

["read","write"]

["read","write"]

["read","write"]

["read","write"]

["read","write"]

Grant option
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Role

ASO security
auditor

ASO product O&M
officer

ASO common 0&M

Role description

Has the
permissions to
audit, track, and
analyze the
activities of the
system
administrator and
security officer.

Has the
permissions to
perform O&M
operations such
as data import
and export,
modification,
configuration,
upgrade, and
troubleshooting
coordination.

Has the
permissions to
perform daily
health checks,
query service

Resource
*:aso:audit:*

*:aso:auth:*

*:as0:serviceWhit
elist:*

*:as0:api-
adapter:*
*:aso:backup:*
*:aso:cmdb:*

*.aso:doc:*

*

:aso:fullview:*
:aso:init:*
*:aso:inventory:*
*:aso:itil:*
*.aso:lock:*
*.:aso:physical:*
:aso:psm:*
*:aso:scm:*
*:aso:slalink:*
*:aso:task:*

*

:aso:api-
adapter:*

*:aso:backup:*
*:aso:cmdb:*
*:aso:doc:*
:aso:fullview:*
*:aso:init:*

:aso:inventory:*

Action

["read","write"]

["read"]

["read"]

["read"]

["read"]

["read"]

["read"]

["read","write"]

["read"]

["read","write"]

["read"]

["read"]

["read","write"]

["read"]

["read"]

["read"]

["read"]

["read"]

["read"]

["read"]

["read"]

["read"]

["read"]

["read","write"]

Grant option
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ﬂg)fl'ec er ﬁ%ﬁ%“&e?éir‘?&( ion Resource Action Grant option
inventory
information, and *:aso:itil:* ["read"] 0
query product
Usage. *:aso:lock:* ["read"] 0
*:as0:physical:* ["read","write"] 0
*:aso:psm:* ["read"] 0
*:aso:scm:* ["read"] 0
*:aso:slalink:* ["read"] 0
*:aso:task:* ["read"] 0
Has the *:aso:doc:* ["read"] 0
permissions to
view and monitor
ASO duty observer the dashboard
! *:aso:fullview:* ["read"] 0

and monitor
system alerts.

9.1.8.1.6. Default roles of PaaS

This topic describes the default roles of the Platform as a Service (PaaS) console and the corresponding
grant options.

The PaasS console is an 0&M platform designed for the PaaS platform and products, and is used to
view, manage, and upgrade the products deployed on the PaaSs platform.

The following table describes the default roles of the PaaS console and the corresponding grant
options.

Role Role description Resource Action Grant option

Has all the
permissions in the *:paas-ops:* ™" 0
Paas console.

PaaS_Operation_M
anager

9.1.8.2. Operation permissions on O&M platforms

This topic describes the operation permissions on O&M platforms.

9.1.8.2.1. Permissions on Apsara Infrastructure

Management Framework

This topic describes the operation permissions on Apsara Infrastructure Management Framework.
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Resource

*:tianji:services:
[sname]:tjmontemplates:
[tmplname]

*:tianji:services:
[sname]:tjmontemplates:
[tmplname]

*:tianji:services:
[sname]:templates:[tmplname]

*:tianji:services:
[sname]:templates:[tmplname]

*:tianji:services:
[sname]:serviceinstances:
[siname]:tjmontemplate

*:tianji:services:
[sname]:serviceinstances:
[siname]:tssessions

*:tianji:services:
[sname]:serviceinstances:
[siname]:template

*:tianji:services:
[sname]:serviceinstances:
[siname]:template

*:tianji:services:
[sname]:serviceinstances:
[siname]:template

*:tianji:services:
[sname]:serviceinstances:
[siname]:tags:[tag]

*:tianji:services:
[sname]:serviceinstances:
[siname]:tags:[tag]

*:tianji:services:
[sname]:serviceinstances:
[siname]:serverroles:
[serverrole]:resources

*:tianji:services:
[sname]:serviceinstances:
[siname]:serverroles:
[serverrole]:machines:[machine]

Action

delete

write

write

delete

read

terminal

write

delete

read

delete

write

read

write

Description

DeleteServiceTjmonT mpl

PutServiceTjmonT mpl

PutServiceConfTmpl

DeleteServiceConfTmpl

GetServicelnstanceTjmonTmpl

CreateTsSessionByService

SetServicelnstanceTmpl

DeleteServicelnstanceT mpl

GetServicelnstanceT mpl

DeleteServicelnstanceProductTagl
nService

AddServicelnstanceProductTaginS

ervice

GetServerroleResourcelnService

OperateSRMachinelnService
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Resource

*:tianji:services:
[sname]:serviceinstances:
[siname]:serverroles:
[serverrole]:machines:[machine]

*:tianji:services:
[sname]:serviceinstances:
[siname]:serverroles:
[serverrole]:machines:[machine]

*:tianji:services:
[sname]:serviceinstances:
[siname]:serverroles:
[serverrole]:machines

*:tianji:services:
[sname]:serviceinstances:
[siname]:serverroles:
[serverrole]:machines

*:tianji:services:
[sname]:serviceinstances:
[siname]:serverroles:
[serverrole]:machines

*:tianji:services:
[sname]:serviceinstances:
[siname]:serverroles:
[serverrole]:apps:[app]:resources

*:tianji:services:
[sname]:serviceinstances:
[siname]:serverroles:
[serverrole]:apps:
[app]:machines:
[machine]:tianjilogs

*:tianji:services:
[sname]:serviceinstances:
[siname]:serverroles

*:tianji:services:
[sname]:serviceinstances:
[siname]:schema

*:tianji:services:
[sname]:serviceinstances:
[siname]:schema

*:tianji:services:
[sname]:serviceinstances:
[siname]:rollings:[version]

Action

read

delete

read

delete

write

read

read

read

write

delete

write

Description

GetMachineSRInfolnService

DeleteSRMachineActioninService

GetMachinesSRInfoInService

DeleteSRMachinesActionInService

OperateSRMachinesInService

GetAppResourcelnService

TianjiLogsInService

GetServicelnstanceServerrolesinSe
rvice

SetServicelnstanceSchema

DeleteServicelnstanceSchema

OperateRollingJobInService
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*:tianji:services:
[sname]:serviceinstances: read ListRollingJoblInService
[siname]:rollings

*:tianji:services:
[sname]:serviceinstances: read GetInstanceResourcelnService
[siname]:resources

*:tianji:services:
[sname]:serviceinstances: read GetMachineAllSRInfolnService
[siname]:machines:[machine]

*:tianji:services:
[sname]:serviceinstances: write DeployServicelnstancelnService
[siname]

*:tianji:services:
[sname]:serviceinstances: read GetServicelnstanceConf
[siname]

*:tianji:services:
[sname]:serverroles:
[serverrole]:machines:
[machine]:apps:[app]:files:name

read GetMachineAppFileListInService

*:tianji:services:

[sname]:serverroles:

[serverrole]: machines: read
[machine]:apps:

[app]:files:download

GetMachineAppFileDownloadInSer
vice

*:tianji:services:

[sname]:serverroles:
[serverrole]:machines: read
[machine]:apps:

[app]:files:content

GetMachineAppFileContentInServi
ce

*:tianji:services:
[sname]:serverroles:
[serverrole]:machines:
[machine]:apps:[app]:filelist

read GetMachineFileListInService

*:tianji:services:
[sname]:serverroles:
[serverrole]:machines:
[machine]:apps:[app]:dockerlogs

read DockerLogsInService

*:tianji:services:
[sname]:serverroles:
[serverrole]:machines:
[machine]:apps:[app]:debuglog

read GetMachineDebuglLoglInService
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Resource

*:tianji:services:
[sname]:serverroles:
[serverrole]:machines:
[machine]:apps

*:tianji:services:
[sname]:serverroles:
[serverrole]:apps:
[app]:dockerinspect

*:tianji:services:
[sname]:schemas:[schemaname]

*:tianji:services:
[sname]:schemas:[schemaname]

*:tianji:services:
[sname]:resources

*:tianji: services:[sname]

*:tianji: services:[sname]

*:tianji: projects:
[pname]: machinebuckets:
[bname]: machines:[machine]

*:tianji: projects:
[pname]: machinebuckets:
[bname]: machines

*:tianji: projects:
[pname]: machinebuckets:
[bname]

*:tianji: projects:
[pname]: machinebuckets:
[bname]

*:tianji: projects:
[pname]: machinebuckets:
[bname]

*:tianji: projects:
[pname]: machinebuckets:
[bname]

*:tianji: projects:
[pname]: machinebuckets

Action

read

read

write

delete

read

delete

write

read

read

write

write

delete

read

read

Description

GetMachineAppListinService

Dockerlnspect

PutServiceSchema

DeleteServiceSchema

GetResourcelnService

DeleteService

CreateService

GetMachineBucketMachineinfo

GetMachineBucketMachines

CreateMachineBucket

OperateMachineBucketMachines

DeleteMachineBucket

GetMachineBucketMachinesLegac
y

GetMachineBucketList
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Resource

*:tianji: projects:
[pname]: projects:
[pname]:clusters:
[cname]:tssessions:
[tssessionname]:tsses

*:tianji: projects:
[pname]: projects:
[pname]:clusters:
[cname]:tssessions

*:tianji: projects:
[pname]:clusters:
[cname]:serviceinstances:
[siname]:tjmontemplate

*:tianji: projects:
[pname]:clusters:
[cname]:serviceinstances:
[siname]:template

*:tianji: projects:
[pname]:clusters:
[cname]:serviceinstances:
[siname]:template

*:tianji: projects:
[pname]:clusters:
[cname]:serviceinstances:
[siname]:template

*:tianji: projects:
[pname]:clusters:
[cname]:serviceinstances:
[siname]:tags:[tag]

*:tianji:projects:
[pname]:clusters:
[cname]:serviceinstances:
[siname]:tags:[tag]

*:tianji: projects:
[pname]:clusters:
[cname]:serviceinstances:
[siname]:serverroles:
[serverrole]:resources

*:tianji: projects:
[pname]:clusters:
[cname]:serviceinstances:
[siname]:serverroles:
[serverrole]:machines:
[machine]:apps:[app]:files:name

Action

terminal

terminal

read

delete

write

read

write

delete

read

read

Description

UpdateTsSessionTssByCluster

CreateTsSessionByCluster

GetServicelnstanceTjmonT mplinCl
uster

DeleteServicelnstanceT mplinClust
er

SetServicelnstanceT mplinCluster

GetServicelnstanceT mplinCluster

AddServicelnstanceProductTagInC
luster

DeleteServicelnstanceProductTagl

nCluster

GetServerroleResourcelnCluster

GetMachineAppFileList

284

> Document Version: 20210128



Operations and Maintenance Guide-
Appendix

Resource Action Description

*:tianji: projects:

[pname]:clusters:

[cname]:serviceinstances:

[siname]:serverroles: read GetMachineAppFileDownload
[serverrole]:machines:

[machine]: apps:

[app]:files:download

*:tianji: projects:

[pname]:clusters:

[cname]:serviceinstances:

[siname]:serverroles: read GetMachineAppFileContent
[serverrole]:machines:

[machine]:apps:

[app]:files:content

*:tianji: projects:
[pname]:clusters:
[cname]:serviceinstances:
[siname]:serverroles:
[serverrole]:machines:
[machine]:apps:[app]:filelist

read GetMachineFileList

*:tianji: projects:
[pname]:clusters:
[cname]:serviceinstances:
[siname]:serverroles:
[serverrole]:machines:
[machine]:apps:[app]:dockerlogs

read DockerLogsInCluster

*:tianji: projects:
[pname]:clusters:
[cname]:serviceinstances:
[siname]:serverroles:
[serverrole]:machines:
[machine]:apps:[app]:debuglog

read GetMachineDebuglLog

*:tianji: projects:
[pname]:clusters:
[cname]:serviceinstances:
[siname]:serverroles:
[serverrole]:machines:
[machine]:apps

read GetMachineAppList

*:tianji: projects:

[pname]:clusters:

[cname]:serviceinstances: read GetMachineSRInfolnCluster
[siname]:serverroles:

[serverrole]:machines:[machine]
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*:tianji: projects:

[pname]:clusters:

[cname]:serviceinstances: write OperateSRMachineInCluster
[siname]:serverroles:

[serverrole]:machines:[machine]

*:tianji: projects:

[pname]:clusters:

[cname]:serviceinstances: delete DeleteSRMachineActionInCluster
[siname]:serverroles:

[serverrole]:machines:[machine]

*:tianji: projects:

[pname]:clusters:

[cname]:serviceinstances: write OperateSRMachinesInCluster
[siname]:serverroles:

[serverrole]:machines

*:tianji: projects:

[pname]:clusters:

[cname]:serviceinstances: delete DeleteSRMachinesActioninCluster
[siname]:serverroles:

[serverrole]:machines

*:tianji: projects:

[pname]:clusters:

[cname]:serviceinstances: read GetAllMachineSRInfolnCluster
[siname]:serverroles:

[serverrole]:machines

*:tianji: projects:

[pname]:clusters:

[cname]:serviceinstances: read GetAppResourcelnCluster
[siname]:serverroles:

[serverrole]:apps:[app]:resources

*:tianji: projects:

[pname]:clusters:

[cname]:serviceinstances:

[siname]:serverroles: read TianjiLogsInCluster
[serverrole]:apps:

[app]:machines:

[machine]:tianjilogs

*:tianji: projects:
[pname]:clusters:
[cname]:serviceinstances:
[siname]:serverroles:
[serverrole]:apps:
[app]:dockerinspect

read DockerlnspectinCluster

286 > Document Version: 20210128



Operations and Maintenance Guide-
Appendix

Resource

*:tianji: projects:
[pname]:clusters:
[cname]:serviceinstances:
[siname]:serverroles

*:tianji: projects:
[pname]:clusters:
[cname]:serviceinstances:
[siname]:schema

*:tianji: projects:
[pname]:clusters:
[cname]:serviceinstances:
[siname]:schema

*:tianji: projects:
[pname]:clusters:
[cname]:serviceinstances:
[siname]:resources

*:tianji: projects:
[pname]:clusters:
[cname]:serviceinstances:
[siname]

*:tianji: projects:
[pname]:clusters:
[cname]:serviceinstances:
[siname]

*:tianji: projects:
[pname]:clusters:
[cname]:serviceinstances:
[siname]

*:tianji:projects:
[pname]:clusters:
[cname]:rollings:[version]

*:tianji: projects:
[pname]:clusters:[cname]:rollings

*:tianji: projects:
[pname]:clusters:
[cname]:resources

*:tianji: projects:
[pname]:clusters:[cname]:quota

*:tianji: projects:
[pname]:clusters:
[cname]:machinesinfo

Action

read

delete

write

read

delete

write

read

write

read

read

write

read

Description

GetServicelnstanceServerrolesinCl
uster

DeleteServicelnstanceSchemainCl
uster

SetServicelnstanceSchemalnClust
er

GetlInstanceResourceInCluster

DeleteServicelnstance

CreateServicelnstance

GetServicelnstanceConfInCluster

OperateRollingjob

ListRollingjob

GetResourcelnCluster

SetClusterQuotas

GetClusterMachinelnfo
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*:tianji: projects:
[pname]:clusters: read GetMachineAllSRInfo
[cname]:machines:[machine]

*:tianji: projects:
[pname]:clusters: write SetMachineAction
[cname]:machines:[machine]

*:tianji: projects:
[pname]:clusters: delete DeleteMachineAction
[cname]:machines:[machine]

*:tianji: projects:
[pname]:clusters: write OperateClusterMachines
[cname]: machines

-tianji: projects: et read GetVersionDiffList

[pname]: clusters:[cname]: difflist
‘tianji:projects: . read GetVersionDiff

[pname]:clusters:[cname]: diff

*:tianji: projects:

[pname]:clusters: read GetDeployLoglInCluster

[cname]:deploylogs:[version]

*:tianji: projects:
[pname]:clusters: read GetDeployLogListIinCluster
[cname]:deploylogs

*:tianji: projects:
[pname]:clusters:[cname]: builds: read GetBuildjob

[version]

*:tianji: projects:

d List Buil

[pname]: clusters:[cname]: builds rea IstBuildjob
*:tianji:projects:

'anji- proj write OperateCluster
[pname]:clusters:[cname]
*egr HE H .
tlanji:projects: delete DeleteCluster
[pname]:clusters:[cname]
L XX 3 H .
‘tianji: projects: read GetClusterConf
[pname]:clusters:[cname]
*:tianji:projects:

'anji: proj write DeployCluster
[pname]:clusters:[cname]
*:tianji: projects:[pname] write CreateProject
*:tianji: projects:[pname] delete DeleteProject
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*:tianji:idcs:[idc]:rooms:
[room]:racks:[rack]:rackunits:
[rackunit]
*:tianji:idcs:[idc]:rooms:
[room]:racks:[rack]:rackunits:
[rackunit]
*:tianji:idcs:[idc]:rooms:
[room]:racks:[rack]: rackunits:

[rackunit]

*:tianji:idcs:[idc]:rooms:
[room]:racks:[rack]

*:tianji:idcs:[idc]:rooms:
[room]:racks:[rack]

*:tianjizidcs:[idc]:rooms:
[room]:racks:[rack]

*:tianji:idcs:[idc]:rooms:[room]
*:tianji:idcs:[idc]:rooms:[room]
*:tianjizidcs:[idc]:rooms:[room]
*:tianjizidcs:[idc]
*:tianji:idcs:[idc]

*:tianjizidcs:[idc]

Action

write

write

delete

write

write

delete

write

delete

write

delete

write

write

Description

CreateRackunit

SetRackunitAttr

DeleteRackunit

SetRackAttr

CreateRack

DeleteRack

CreateRoom

DeleteRoom

SetRoomAttr

Deleteldc

SetldcAttr

Createldc

9.1.8.2.2. Permissions on Monitoring System of Apsara

Infrastructure Management Framework

This topic describes the operation permissions on Monitoring System of Apsara Infrastructure

Management Framework.
Resource

26842:tianjimon:monitor-
manage

Action

manage

Description

Monitoring and O&M
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